summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDustin Polke <DuPol@gmx.de>2012-04-28 13:47:29 +0200
committerDustin Polke <DuPol@gmx.de>2012-04-28 13:47:29 +0200
commitce3ffd26ad3d951f773b8d645454386337a64542 (patch)
tree31ed1b87779bb2e164c6a4810c74fa80db4cafab /x11-misc/cairo-dock/files
parent[x11-plugins/cd-plugins-good] Fix slot of dev-libs/libdbusmenu dependency. (diff)
downloadDuPol-ce3ffd26ad3d951f773b8d645454386337a64542.tar.gz
DuPol-ce3ffd26ad3d951f773b8d645454386337a64542.tar.bz2
DuPol-ce3ffd26ad3d951f773b8d645454386337a64542.zip
[x11-misc/cairo-dock] Version bump to 3.0.0; add ~x86 wrt bug #412543c10.
Diffstat (limited to 'x11-misc/cairo-dock/files')
-rw-r--r--x11-misc/cairo-dock/files/cairo-dock-3.0.0-CMakeLists.patch81
1 files changed, 81 insertions, 0 deletions
diff --git a/x11-misc/cairo-dock/files/cairo-dock-3.0.0-CMakeLists.patch b/x11-misc/cairo-dock/files/cairo-dock-3.0.0-CMakeLists.patch
new file mode 100644
index 0000000..460ebc2
--- /dev/null
+++ b/x11-misc/cairo-dock/files/cairo-dock-3.0.0-CMakeLists.patch
@@ -0,0 +1,81 @@
+--- CMakeLists.txt.orig
++++ CMakeLists.txt
+@@ -14,9 +14,6 @@ project ("cairo-dock")
+ set (VERSION "3.0.0")
+
+ add_definitions (-std=c99 -Wextra -Wwrite-strings -Wuninitialized -Werror-implicit-function-declaration -Wstrict-prototypes) # removed for stable versions: -Wstrict-prototypes #-Wunreachable-code -Wno-unused-parameter -Wall
+-if (NOT ${CMAKE_BUILD_TYPE})
+- add_definitions (-O3)
+-endif()
+ add_definitions (-DGL_GLEXT_PROTOTYPES="1")
+ add_definitions (-DCAIRO_DOCK_DEFAULT_ICON_NAME="default-icon.svg")
+ add_definitions (-DCAIRO_DOCK_ICON="cairo-dock.svg")
+@@ -55,39 +52,33 @@ set (mandir "${prefix}/${CMAKE_INSTALL_M
+
+ set (VERSION_HELP "0.9.991") # needed to parse Help.conf.in
+
+-if( CMAKE_SIZEOF_VOID_P EQUAL 8 AND "${FORCE_LIB64}" STREQUAL "yes") # 64bits and force install in lib64
+- set (libdir "${prefix}/lib64")
+-else()
+- set (libdir "${prefix}/${CMAKE_INSTALL_LIBDIR}${LIB_SUFFIX}") # (...)/lib
+-endif()
++set (libdir "${prefix}/${CMAKE_INSTALL_LIBDIR}") # (...)/lib
+
+ set (includedir "${prefix}/${CMAKE_INSTALL_INCLUDEDIR}") # (...)/include
+ set (bindir "${prefix}/${CMAKE_INSTALL_BINDIR}") # (...)/bin
+
++set (CMAKE_SKIP_BUILD_RPATH TRUE)
++set (CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
++
+ ########### dependencies ###############
+
+ set (packages_required "gthread-2.0 cairo librsvg-2.0 dbus-1 dbus-glib-1 libxml-2.0 xrender gl glu pangox libcurl") # for the .pc
+ STRING (REGEX REPLACE " " ";" packages_required_semicolon ${packages_required}) # replace blank space by semicolon => to have more details if a package is missing
+ pkg_check_modules ("PACKAGE" REQUIRED "${packages_required_semicolon}")
+
+-set (xextend_required "xtst xcomposite xinerama") # for the .pc
+-STRING (REGEX REPLACE " " ";" xextend_required_semicolon ${xextend_required})
+-pkg_check_modules ("XEXTEND" "${xextend_required_semicolon}")
+-if (${XEXTEND_FOUND})
++if (WITH_XEXTEND)
++ set (xextend_required "xtst xcomposite xinerama") # for the .pc
++ STRING (REGEX REPLACE " " ";" xextend_required_semicolon ${xextend_required})
++ pkg_check_modules ("XEXTEND" REQUIRED "${xextend_required_semicolon}")
+ set (HAVE_XEXTEND 1)
+-else()
+- set (xextend_required)
+ endif()
+
+-if (NOT "${force-gtk2}" STREQUAL "yes") # by default, we use GTK+3 except if we force the use of GTK+2
+- set (gtk_required "gtk+-3.0") # for the .pc
+- pkg_check_modules ("GTK" "${gtk_required}") # the check is not set as 'required' because we can use GTK+2 if GTK+3 isn't available
+-endif()
+-
+-if (NOT "${GTK_FOUND}")
++if (WITH_GTK2) # by default, we use GTK+3 except if we force the use of GTK+2
+ set (gtk_required "gtk+-2.0") # for the .pc
+- pkg_check_modules ("GTK" REQUIRED "${gtk_required}") # the check is requiered this time because we need GTK anyway.
++else()
++ set (gtk_required "gtk+-3.0") # for the .pc
+ endif()
++pkg_check_modules ("GTK" REQUIRED "${gtk_required}")
+
+ STRING (REGEX REPLACE "\\..*" "" GTK_MAJOR "${GTK_VERSION}")
+
+@@ -95,9 +86,13 @@ add_definitions (-DGTK_DISABLE_DEPRECATE
+ # add_definitions (-DG_DISABLE_DEPRECATED="1")
+
+ # We use crypt(3) which may be in libc, or in libcrypt (eg FreeBSD)
+-check_library_exists (crypt encrypt "" HAVE_LIBCRYPT)
+-if (${HAVE_LIBCRYPT})
+- set (LIBCRYPT_LIBS "-lcrypt")
++if (WITH_CRYPT)
++ check_library_exists (crypt encrypt "" HAVE_LIBCRYPT)
++ if (${HAVE_LIBCRYPT})
++ set (LIBCRYPT_LIBS "-lcrypt")
++ else()
++ MESSAGE (FATAL_ERROR "crypt not found!")
++ endif()
+ endif()
+
+ check_include_files ("math.h" HAVE_MATH_H)