summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/khal/khal-0.1.0.ebuild')
-rw-r--r--app-misc/khal/khal-0.1.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/khal/khal-0.1.0.ebuild b/app-misc/khal/khal-0.1.0.ebuild
new file mode 100644
index 0000000..caec223
--- /dev/null
+++ b/app-misc/khal/khal-0.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_USE_WITH="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="CLI calendar application build around CalDAV."
+HOMEPAGE="https://github.com/geier/khal"
+SRC_URI="https://github.com/geier/khal/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-python/lxml-3.0.0
+ dev-python/requests
+ >=dev-python/urwid-1.1.0
+ dev-python/pyxdg
+ >=dev-python/icalendar-3.1
+ dev-db/sqlite:3
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+EXAMPLES=( khal.conf.sample )
+
+pkg_postinst() {
+ ewarn "Copy and edit the supplied khal.conf.sample file"
+ ewarn "(default location is ~/.config/khal/khal.conf)."
+ ewarn "Beware that only you can access this file,"
+ ewarn "if you have untrusted users on your machine,"
+ ewarn "since the password is stored in cleartext."
+}