summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRussell Harmon <russ@eatnumber1.com>2009-03-25 23:23:33 -0400
committerRussell Harmon <russ@eatnumber1.com>2009-03-25 23:23:33 -0400
commit917602b4f9361800e1c9cde4cf3454664329ea89 (patch)
tree7f39441972a7779f386a76c6abaef6ca504b6c83
parentFix mad shit, yo. (diff)
downloadeatnumber1-917602b4f9361800e1c9cde4cf3454664329ea89.tar.gz
eatnumber1-917602b4f9361800e1c9cde4cf3454664329ea89.tar.bz2
eatnumber1-917602b4f9361800e1c9cde4cf3454664329ea89.zip
Change more shit.
-rw-r--r--dev-libs/arch/Manifest7
-rw-r--r--dev-libs/arch/arch-2.5a.ebuild3
-rw-r--r--dev-libs/arch/files/arch.pc.in4
-rw-r--r--dev-libs/arch/files/arch_autotools.patch12
-rw-r--r--dev-libs/arch/files/arch_gcc.patch351
-rw-r--r--dev-libs/arch/files/libarch_autotools-gcc.patch51
6 files changed, 371 insertions, 57 deletions
diff --git a/dev-libs/arch/Manifest b/dev-libs/arch/Manifest
index fa801ef..1439f30 100644
--- a/dev-libs/arch/Manifest
+++ b/dev-libs/arch/Manifest
@@ -1,6 +1,7 @@
AUX Makefile.am 647 RMD160 978c2b9b02d5a7ff7129e32c240d108c2fe67fd1 SHA1 1d26c7ad9fdf7d338774d71ea9617d208456652d SHA256 1eb0fdb91e3d8c3cff890bb92fba5064a25aec1921dac0a91368ff8693281510
-AUX arch.pc.in 253 RMD160 714e19a8771d5c20bc71252813c960c8e9c20867 SHA1 12ff0ebc742a99c5e673075f7d485af5b575021e SHA256 1efc63c7dc0c38f4d33dde6fe1a94831a95bd2957e39c30a640e5c905f82744f
+AUX arch.pc.in 243 RMD160 0df7e019928b9d6eea3edb4eede3006514b68c6b SHA1 7b8cf1a4a9c4335ab6244e7affe89b6b92d66798 SHA256 9a92198be6c373b34b33d8fae42541e7752c5372e0a12e78df63dce3c0e97180
+AUX arch_autotools.patch 270 RMD160 0e17e5f2c5b31aec50ffed9909f29055e5412ec4 SHA1 7064ded2ac1a286df24645cb409f113196b96529 SHA256 a9968761920bbb363392ae5000c2306d2c6b3edf29c4f64a0802dc3bf12052f3
+AUX arch_gcc.patch 9713 RMD160 4562ebc89975033d2fbc1b21d9a9035dcd97a5cb SHA1 6c8762d5d1ebd2975db1c9aa4d8de031433bc271 SHA256 e7231ee022ed5247eb16d37b565bf94aa93cbda3a1183811aeac6a4306bd716b
AUX configure.ac 178 RMD160 f0000edf33e19bb11f6f61a2fa3e8aed2aed82d9 SHA1 77311a5ba69fac7e7ef02d0a09b38f7811af1b3d SHA256 5a6ea5b82e128d389cc01ec2a7285519fe5896629a970309ef036a333e5eb8d9
-AUX libarch_autotools-gcc.patch 1599 RMD160 9a23a7db201c8172be7ca12524a2d59fd730ba92 SHA1 4278b2c5327a1ee79895adfe82383b78e1f7af6c SHA256 6f60aef2f23be2a6f92712df89bffbdde447418a490d3a7c791e5e5174737a9e
DIST arch2-5a.tar.gz 19986 RMD160 be62d70a2808c6ac7f0ac967904060ee61d3010a SHA1 05ba5421771026d508cb3f8bef1ac79bcbf12478 SHA256 21810f9ff76d2020768929a134d5c2dd4fd6f35ac699452ee5d5beef19a23ec5
-EBUILD arch-2.5a.ebuild 638 RMD160 abb5d791fb79d5386bb7dde7906efd590d7855ea SHA1 9d39a28f737f78e78f0fe9efe53e931649d63f61 SHA256 6ce90ce2072d481e41641f0bffedb6a383ecbb79a040db78f5eadb3bdb83e4a2
+EBUILD arch-2.5a.ebuild 670 RMD160 4c1bc7c0ad78aab492c0051ceb32783eff71ae70 SHA1 76701771fc23437d9efbe75b673ad8f3a81f1e7c SHA256 6efa290722c9247feaaaaeb9e228ee94b8a8bb2e9c48b66408ee4c242ef0d4d5
diff --git a/dev-libs/arch/arch-2.5a.ebuild b/dev-libs/arch/arch-2.5a.ebuild
index b83e923..dd71169 100644
--- a/dev-libs/arch/arch-2.5a.ebuild
+++ b/dev-libs/arch/arch-2.5a.ebuild
@@ -21,7 +21,8 @@ RDEPEND=""
S="${WORKDIR}"
src_prepare() {
- epatch "${FILESDIR}/libarch_autotools-gcc.patch"
+ epatch "${FILESDIR}/${PN}_autotools.patch"
+ epatch "${FILESDIR}/${PN}_gcc.patch"
cp "${FILESDIR}/Makefile.am" .
cp "${FILESDIR}/configure.ac" .
cp "${FILESDIR}/${PN}.pc.in" .
diff --git a/dev-libs/arch/files/arch.pc.in b/dev-libs/arch/files/arch.pc.in
index 0f0833b..4ded19e 100644
--- a/dev-libs/arch/files/arch.pc.in
+++ b/dev-libs/arch/files/arch.pc.in
@@ -6,5 +6,5 @@ includedir=@includedir@
Name: arch
Description: RIT's computer architecture simulation library.
Version: @VERSION@
-Libs: -L${libdir} -larch-@VERSION@
-Cflags: -I${includedir} -I${libdir}/include
+Libs: -L${libdir} -larch
+Cflags: -I${includedir}
diff --git a/dev-libs/arch/files/arch_autotools.patch b/dev-libs/arch/files/arch_autotools.patch
new file mode 100644
index 0000000..7a628f5
--- /dev/null
+++ b/dev-libs/arch/files/arch_autotools.patch
@@ -0,0 +1,12 @@
+Only in b: Makefile.am
+diff -ur a/Version.h b/Version.h
+--- a/Version.h 2009-03-25 03:59:43.552211345 -0400
++++ b/Version.h 2009-03-25 04:00:48.130243022 -0400
+@@ -12,6 +12,4 @@
+
+ using namespace std;
+
+-const char * VERSION = "2.5a";
+-
+ #endif
+Only in b: configure.ac
diff --git a/dev-libs/arch/files/arch_gcc.patch b/dev-libs/arch/files/arch_gcc.patch
new file mode 100644
index 0000000..0f29469
--- /dev/null
+++ b/dev-libs/arch/files/arch_gcc.patch
@@ -0,0 +1,351 @@
+diff -ur a/Bus.C b/Bus.C
+--- a/Bus.C 2003-12-04 12:03:18.000000000 -0500
++++ b/Bus.C 2009-03-25 03:57:45.885211654 -0400
+@@ -13,8 +13,8 @@
+ using namespace std;
+
+ Bus::Bus( const char *id, int numbits ):
+- Connector(id,numbits),
+ CPUObject(id,numbits),
++ Connector(id,numbits),
+ input(id,numbits),
+ output(id,numbits,*this) {
+ }
+diff -ur a/BusALU.C b/BusALU.C
+--- a/BusALU.C 2003-12-04 12:05:42.000000000 -0500
++++ b/BusALU.C 2009-03-25 03:57:45.885211654 -0400
+@@ -17,8 +17,8 @@
+ using namespace std;
+
+ CarryConnector::CarryConnector( const char *id, BusALU &b ):
+- Connector(id,1),
+ CPUObject(id,1),
++ Connector(id,1),
+ busALU(b),
+ carry("Carry",1,*this) {
+ }
+@@ -32,8 +32,8 @@
+ }
+
+ OverflowConnector::OverflowConnector( const char *id, BusALU &b ):
+- Connector(id,1),
+ CPUObject(id,1),
++ Connector(id,1),
+ busALU(b),
+ overflow("Overflow",1,*this) {
+ }
+@@ -53,7 +53,7 @@
+ };
+
+ BusALU::BusALU( const char *id, int numbits ):
+- Connector(id,numbits), CPUObject(id,numbits),
++ CPUObject(id,numbits), Connector(id,numbits),
+ op1("OP1",numbits), op2("OP2",numbits),
+ result("Result",numbits,*this), operation(op_none),
+ carryConnector("Carry",*this),
+@@ -342,7 +342,7 @@
+ unsigned long signBit = x & (1 << (get_bits()-1));
+ unsigned long sh = (unsigned long)op2Copy;
+
+- for( long i=0; i<sh; i++ )
++ for( unsigned long i=0; i<sh; i++ )
+ x = (x >> 1) | signBit;
+
+ value = x;
+diff -ur a/BusALU.h b/BusALU.h
+--- a/BusALU.h 2003-12-04 12:05:42.000000000 -0500
++++ b/BusALU.h 2009-03-25 03:57:45.888210663 -0400
+@@ -68,9 +68,9 @@
+ ~CarryConnector();
+
+ long computeValue();
+- OutFlow carry;
+-
+ BusALU &busALU;
++
++ OutFlow carry;
+ };
+
+ class OverflowConnector: public Connector {
+@@ -82,9 +82,9 @@
+ ~OverflowConnector();
+
+ long computeValue();
+- OutFlow overflow;
+-
+ BusALU &busALU;
++
++ OutFlow overflow;
+ };
+
+ class BusALU : public Connector {
+@@ -138,10 +138,10 @@
+ void rshiftFunction();
+ void rashiftFunction();
+
+- Operation operation;
+ InFlow op1;
+ InFlow op2;
+ OutFlow result;
++ Operation operation;
+ friend class CarryConnector;
+ CarryConnector carryConnector;
+ friend class OverflowConnector;
+diff -ur a/CPUObject.C b/CPUObject.C
+--- a/CPUObject.C 2003-12-04 12:04:08.000000000 -0500
++++ b/CPUObject.C 2009-03-25 03:57:45.886211743 -0400
+@@ -64,7 +64,7 @@
+ cout << "Object " << myName << " created\n";
+ }
+
+- if( (numBits<1) || (numBits > (8*sizeof(long))) ) {
++ if( (numBits<1) || (numBits > (int)(8*sizeof(long))) ) {
+ cout << id << ": " << numBits << " bits is out of range\n";
+ throw ArchLibError( "CPUObject size out of range" );
+ }
+diff -ur a/CPUObject.h b/CPUObject.h
+--- a/CPUObject.h 2009-03-25 03:59:43.551211326 -0400
++++ b/CPUObject.h 2009-03-25 03:57:45.888210663 -0400
+@@ -59,17 +59,17 @@
+ trace_ticks = 16 };
+
+ static int debug;
++ void set_name( const char *id );
+
+ protected:
+ int get_bits() const;
+ unsigned long get_mask() const;
+ void set_mask( unsigned long m );
+- void set_name( const char *id );
+
+ private:
+- char *myName;
+-
+ int bits;
++
++ char *myName;
+ unsigned long mask; // mask representing above data (right-justified)
+
+ private:
+diff -ur a/Clearable.C b/Clearable.C
+--- a/Clearable.C 2003-12-04 12:04:08.000000000 -0500
++++ b/Clearable.C 2009-03-25 03:57:45.886211743 -0400
+@@ -18,8 +18,8 @@
+ using namespace std;
+
+ Clearable::Clearable ( const char *id, int numBits, long value ):
+- StorageObject(id,numBits,value),
+ CPUObject(id,numBits),
++ StorageObject(id,numBits,value),
+ change(none) {
+ }
+
+diff -ur a/Clock.C b/Clock.C
+--- a/Clock.C 2009-03-25 03:59:43.551211326 -0400
++++ b/Clock.C 2009-03-25 03:57:45.886211743 -0400
+@@ -54,7 +54,7 @@
+ trace2 = CPUObject::debug & CPUObject::trace_ticks;
+
+ if( trace1 ) {
+- long old = cout.setf( ios::dec, ios::basefield );
++ std::_Ios_Fmtflags old = cout.setf( ios::dec, ios::basefield );
+ cout << " ________\n_____/" << setw(7) << time
+ << " \\_____\n" << flush;
+ (void)cout.flags( old );
+diff -ur a/Constant.C b/Constant.C
+--- a/Constant.C 2003-12-04 12:03:19.000000000 -0500
++++ b/Constant.C 2009-03-25 03:57:45.886211743 -0400
+@@ -13,8 +13,8 @@
+ using namespace std;
+
+ Constant::Constant( const char *id, int numbits, long value ):
+- Connector(id,numbits),
+ CPUObject(id,numbits),
++ Connector(id,numbits),
+ output(id,numbits,*this),
+ v(value) {
+ }
+diff -ur a/Constant.h b/Constant.h
+--- a/Constant.h 2003-12-04 12:03:19.000000000 -0500
++++ b/Constant.h 2009-03-25 03:57:45.888210663 -0400
+@@ -34,8 +34,8 @@
+ OutFlow &OUT() { return output; }
+
+ private:
+- const long v;
+ OutFlow output;
++ const long v;
+ };
+
+ #endif
+diff -ur a/Counter.C b/Counter.C
+--- a/Counter.C 2003-12-04 12:03:19.000000000 -0500
++++ b/Counter.C 2009-03-25 03:57:45.886211743 -0400
+@@ -17,8 +17,8 @@
+ using namespace std;
+
+ Counter::Counter ( const char *id, int numBits, long value ):
+- StorageObject(id,numBits,value),
+ CPUObject(id,numBits),
++ StorageObject(id,numBits,value),
+ change(none),
+ oflow(0),
+ newOflow(0) {
+Only in b: Makefile.am
+diff -ur a/Memory.C b/Memory.C
+--- a/Memory.C 2003-12-04 12:08:26.000000000 -0500
++++ b/Memory.C 2009-03-25 03:57:45.887210994 -0400
+@@ -71,9 +71,9 @@
+ bool littleEndian
+ // set if LSB is first (e.g., PDP-11)
+ ):
++ CPUObject( id, unitsInDataPath*bitsPerUnit ),
+ Connector( id, unitsInDataPath*bitsPerUnit ),
+ ClockedObject( id, unitsInDataPath*bitsPerUnit ),
+- CPUObject( id, unitsInDataPath*bitsPerUnit ),
+ mar( "MAR", bitsInAddr ),
+ writeFlow( "MemoryWrite", unitsInDataPath*bitsPerUnit ),
+ readFlow( "MemoryRead", unitsInDataPath*bitsPerUnit, *this ),
+@@ -193,7 +193,7 @@
+ break;
+
+ case readOp:
+- if( rangeError = (highPoint < lastAddr) ) {
++ if( ( rangeError = (highPoint < lastAddr) ) ) {
+ return 0;
+ }
+ tempStore = 0;
+@@ -240,7 +240,7 @@
+ // lowest address
+ tempStore = newValue;
+ lastAddr = currentAddr+dataPathWidth-1;
+- if( rangeError = (highPoint < lastAddr) ) {
++ if( ( rangeError = (highPoint < lastAddr) ) ) {
+ return;
+ }
+
+diff -ur a/Memory.h b/Memory.h
+--- a/Memory.h 2003-12-04 12:07:30.000000000 -0500
++++ b/Memory.h 2009-03-25 03:57:45.889210473 -0400
+@@ -44,8 +44,8 @@
+ void allocate( long sz );
+ long get( long index );
+ void put( long index, long value );
+- long size;
+ long *data;
++ long size;
+ };
+
+ class Memory : public Connector, public ClockedObject {
+@@ -99,10 +99,12 @@
+ private:
+ long computeValue();
+
+- Operation op;
+ StorageObject mar;
+ InFlow writeFlow;
+ OutFlow readFlow;
++ int unitSize;
++ int dataPathWidth;
++ Operation op;
+
+ unsigned long currentAddr;
+ long newValue;
+@@ -110,11 +112,9 @@
+ LongArray mem;
+
+ unsigned long highPoint;
+- int unitSize;
+ int rangeError;
+ unsigned long address_mask;
+ unsigned long unit_mask;
+- int dataPathWidth;
+
+ int addressFieldWidth;
+ int dataFieldWidth;
+diff -ur a/PseudoInput.C b/PseudoInput.C
+--- a/PseudoInput.C 2003-12-04 12:04:09.000000000 -0500
++++ b/PseudoInput.C 2009-03-25 03:57:45.887210994 -0400
+@@ -17,8 +17,8 @@
+ using namespace std;
+
+ PseudoInput::PseudoInput( const char *id, int numBits ):
+- StorageObject(id,numBits),
+ CPUObject(id,numBits),
++ StorageObject(id,numBits),
+ latestTime(-1) {
+ }
+
+diff -ur a/PseudoOutput.C b/PseudoOutput.C
+--- a/PseudoOutput.C 2003-12-04 12:03:20.000000000 -0500
++++ b/PseudoOutput.C 2009-03-25 03:57:45.887210994 -0400
+@@ -15,8 +15,8 @@
+ using namespace std;
+
+ PseudoOutput::PseudoOutput( const char *id, int numBits ):
+- StorageObject(id,numBits),
+- CPUObject(id,numBits) {
++ CPUObject(id,numBits),
++ StorageObject(id,numBits) {
+ }
+
+ PseudoOutput::~PseudoOutput() {
+diff -ur a/ShiftRegister.C b/ShiftRegister.C
+--- a/ShiftRegister.C 2003-12-04 12:04:09.000000000 -0500
++++ b/ShiftRegister.C 2009-03-25 03:57:45.887210994 -0400
+@@ -18,8 +18,8 @@
+ using namespace std;
+
+ ShiftRegister::ShiftRegister ( const char *id, int numBits, long initVal ) :
+- StorageObject( id, numBits, initVal ),
+ CPUObject( id, numBits ),
++ StorageObject( id, numBits, initVal ),
+ change( none ),
+ lefterly( 0 ),
+ righterly( 0 ) {
+diff -ur a/StorageObject.C b/StorageObject.C
+--- a/StorageObject.C 2009-03-25 03:59:43.552211345 -0400
++++ b/StorageObject.C 2009-03-25 03:57:45.887210994 -0400
+@@ -26,8 +26,8 @@
+ using namespace std;
+
+ StorageObject::StorageObject ( const char *id, int numBits, long initVal ):
+- ClockedObject( id, numBits ),
+ CPUObject( id, numBits ),
++ ClockedObject( id, numBits ),
+ contents( initVal ),
+ newContents( initVal ),
+ update( 0 ),
+@@ -39,7 +39,7 @@
+
+ if( get_contents() != initVal ) {
+ // switch to hex, but remember old settings
+- long k = cout.setf( ios::hex, ios::basefield );
++ std::_Ios_Fmtflags k = cout.setf( ios::hex, ios::basefield );
+ cout << "StorageObject " << id
+ << ": initial value of " << initVal
+ << " does not fit in " << numBits
+diff -ur a/StorageObject.h b/StorageObject.h
+--- a/StorageObject.h 2003-12-04 12:07:30.000000000 -0500
++++ b/StorageObject.h 2009-03-25 03:57:45.889210473 -0400
+@@ -114,16 +114,16 @@
+ // is anyone updating my value?
+
+ private:
+- OutFlow *newValueSource; // ...if from the outside
+ unsigned long contents; // current visible value
+- int update;
+ unsigned long newContents; // new value, not yet visible
++ int update;
++ FlowSet flows; // to what am I permanently connected?
++ OutFlow *newValueSource; // ...if from the outside
+ // (pre - phase 2)
+
+ static int storObjCount;
+ static int backDoorUsed;
+
+- FlowSet flows; // to what am I permanently connected?
+ };
+
+ inline void StorageObject::hello() {
+Only in b: configure.ac
diff --git a/dev-libs/arch/files/libarch_autotools-gcc.patch b/dev-libs/arch/files/libarch_autotools-gcc.patch
deleted file mode 100644
index 4521ec0..0000000
--- a/dev-libs/arch/files/libarch_autotools-gcc.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-diff -ur a/CPUObject.h b/CPUObject.h
---- a/CPUObject.h 2003-12-04 12:04:08.000000000 -0500
-+++ b/CPUObject.h 2009-03-24 13:22:49.456420184 -0400
-@@ -59,12 +59,12 @@
- trace_ticks = 16 };
-
- static int debug;
-+ void set_name( const char *id );
-
- protected:
- int get_bits() const;
- unsigned long get_mask() const;
- void set_mask( unsigned long m );
-- void set_name( const char *id );
-
- private:
- char *myName;
-diff -ur a/Clock.C b/Clock.C
---- a/Clock.C 2003-12-04 12:03:19.000000000 -0500
-+++ b/Clock.C 2009-03-24 13:24:12.173373534 -0400
-@@ -54,7 +54,7 @@
- trace2 = CPUObject::debug & CPUObject::trace_ticks;
-
- if( trace1 ) {
-- long old = cout.setf( ios::dec, ios::basefield );
-+ std::_Ios_Fmtflags old = cout.setf( ios::dec, ios::basefield );
- cout << " ________\n_____/" << setw(7) << time
- << " \\_____\n" << flush;
- (void)cout.flags( old );
-diff -ur a/StorageObject.C b/StorageObject.C
---- a/StorageObject.C 2003-12-04 12:09:11.000000000 -0500
-+++ b/StorageObject.C 2009-03-24 13:24:24.080171368 -0400
-@@ -39,7 +39,7 @@
-
- if( get_contents() != initVal ) {
- // switch to hex, but remember old settings
-- long k = cout.setf( ios::hex, ios::basefield );
-+ std::_Ios_Fmtflags k = cout.setf( ios::hex, ios::basefield );
- cout << "StorageObject " << id
- << ": initial value of " << initVal
- << " does not fit in " << numBits
-diff -ur a/Version.h b/Version.h
---- a/Version.h 2003-12-04 12:06:08.000000000 -0500
-+++ b/Version.h 2009-03-24 14:30:02.477420295 -0400
-@@ -12,6 +12,4 @@
-
- using namespace std;
-
--const char * VERSION = "2.5a";
--
- #endif