summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRussell Harmon <russ@eatnumber1.com>2010-04-11 10:40:45 -0400
committerRussell Harmon <russ@eatnumber1.com>2010-04-11 10:51:07 -0400
commiteec44bf271e2704a4b78856666d184e3097650c5 (patch)
tree36f4fddc25499239ecad50464baf32b8e1784378
parentAdd rftg ebuild. (diff)
downloadeatnumber1-eec44bf271e2704a4b78856666d184e3097650c5.tar.gz
eatnumber1-eec44bf271e2704a4b78856666d184e3097650c5.tar.bz2
eatnumber1-eec44bf271e2704a4b78856666d184e3097650c5.zip
Add libhx-3.4
-rw-r--r--sys-libs/libhx/libhx-3.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-libs/libhx/libhx-3.4.ebuild b/sys-libs/libhx/libhx-3.4.ebuild
new file mode 100644
index 0000000..b4b860f
--- /dev/null
+++ b/sys-libs/libhx/libhx-3.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libhx/libhx-3.2.ebuild,v 1.1 2010/01/10 15:28:41 hanno Exp $
+
+DESCRIPTION="Platform independent library providing basic system functions."
+HOMEPAGE="http://libhx.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/libHX-${PV}.tar.xz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/libHX-${PV}"
+
+src_compile() {
+ econf --docdir="/usr/share/doc/${PF}" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc doc/*.txt || die
+}