summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Mavrinac <mavrinac@gmail.com>2011-03-30 16:49:53 -0400
committerAaron Mavrinac <mavrinac@gmail.com>2011-03-30 16:49:53 -0400
commitc00b079340b71e0dd51923fbfdba2e8bb8e48341 (patch)
treea5ddb4f473a674288049cc759a3a3a34ac153e97 /dev-python
parentAdd list generator for web. (diff)
downloadezod-c00b079340b71e0dd51923fbfdba2e8bb8e48341.tar.gz
ezod-c00b079340b71e0dd51923fbfdba2e8bb8e48341.tar.bz2
ezod-c00b079340b71e0dd51923fbfdba2e8bb8e48341.zip
Add dev-python/python-graph ebuild.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-graph/Manifest1
-rw-r--r--dev-python/python-graph/python-graph-1.8.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/python-graph/Manifest b/dev-python/python-graph/Manifest
new file mode 100644
index 0000000..3a675fc
--- /dev/null
+++ b/dev-python/python-graph/Manifest
@@ -0,0 +1 @@
+DIST python-graph-1.8.0.tar.bz2 193745 RMD160 4b52f871719862f6bc9349bbaffea9623132d594 SHA1 2ab1d261c03a58649bb3e8d75be4b9961e1dad2a SHA256 3c69bae0faa25b1c066801be401b59084f9a8f75cace3add0d09026ed92a56f5
diff --git a/dev-python/python-graph/python-graph-1.8.0.ebuild b/dev-python/python-graph/python-graph-1.8.0.ebuild
new file mode 100644
index 0000000..ec8669e
--- /dev/null
+++ b/dev-python/python-graph/python-graph-1.8.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6 3"
+
+inherit python distutils
+
+DESCRIPTION="python-graph is a library for working with graphs in Python."
+HOMEPAGE="http://code.google.com/p/python-graph/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="pydot"
+
+RDEPEND="virtual/python
+ pydot? ( media-gfx/pydot )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${S}/core"
+
+src_prepare() {
+ if use pydot; then
+ cp ${S}/../dot/pygraph/readwrite/dot.py ${S}/pygraph/readwrite/
+ fi
+ distutils_src_prepare
+}