summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-server/tpadmin-cpp')
-rw-r--r--games-server/tpadmin-cpp/Manifest4
-rw-r--r--games-server/tpadmin-cpp/files/tpadmin-cpp-0.1.0-stdint.patch11
-rw-r--r--games-server/tpadmin-cpp/metadata.xml8
-rw-r--r--games-server/tpadmin-cpp/tpadmin-cpp-0.1.0.ebuild31
4 files changed, 54 insertions, 0 deletions
diff --git a/games-server/tpadmin-cpp/Manifest b/games-server/tpadmin-cpp/Manifest
new file mode 100644
index 0000000..8396c3f
--- /dev/null
+++ b/games-server/tpadmin-cpp/Manifest
@@ -0,0 +1,4 @@
+AUX tpadmin-cpp-0.1.0-stdint.patch 376 RMD160 905074d95f8a1e3434e25ef9a3fc58864e0b3f51 SHA1 08e73c7880cbcbd593f715ffb31ef0becd4cf80f SHA256 adfd5c3917290fee0ba19bc3a7b172c25593f1f883a12bd08c73a0292b8c3949
+DIST tpadmin-cpp-0.1.0.tar.gz 159598 RMD160 523533de1dbac47847561abe825c7b4457a970b9 SHA1 2e5b31106c54a1d46f5d59833149175ab93c4626 SHA256 082aea8c60effd1728be13b7200c2e416ffc0da5ef9f6c45a77b864a2c66d4b6
+EBUILD tpadmin-cpp-0.1.0.ebuild 572 RMD160 997d21cf530331eaf754d6b563ccac796dbc714f SHA1 56e1ca9e3b0366baf5ddd4596e53cc0b0fb1e978 SHA256 910290aa1acb87c4a8df36ad12a8e45cfa22b214ccd88a250eb624b8c3bf1b25
+MISC metadata.xml 230 RMD160 65b1879f0881b046ac536157a1b73ae8e08a8a23 SHA1 14b143872462f3e5df4ac14bb0e872f1dc762ef0 SHA256 0ef810189a3667f1a7527037968f2b88fae043d5efcaaaa27e33287da96783b6
diff --git a/games-server/tpadmin-cpp/files/tpadmin-cpp-0.1.0-stdint.patch b/games-server/tpadmin-cpp/files/tpadmin-cpp-0.1.0-stdint.patch
new file mode 100644
index 0000000..ff1d9d7
--- /dev/null
+++ b/games-server/tpadmin-cpp/files/tpadmin-cpp-0.1.0-stdint.patch
@@ -0,0 +1,11 @@
+diff -ruN tpadmin-cpp-0.1.0.old/tpadmin//session.h tpadmin-cpp-0.1.0/tpadmin//session.h
+--- tpadmin-cpp-0.1.0.old/tpadmin//session.h 2008-07-03 12:45:34.000000000 -0400
++++ tpadmin-cpp-0.1.0/tpadmin//session.h 2012-02-22 16:45:53.000000000 -0500
+@@ -21,6 +21,7 @@
+ #ifndef SESSION_H
+ #define SESSION_H
+
++#include <stdint.h>
+ #include <set>
+ #include <boost/shared_ptr.hpp>
+
diff --git a/games-server/tpadmin-cpp/metadata.xml b/games-server/tpadmin-cpp/metadata.xml
new file mode 100644
index 0000000..3510201
--- /dev/null
+++ b/games-server/tpadmin-cpp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mavrinac@gmail.com</email>
+ <name>Aaron Mavrinac</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-server/tpadmin-cpp/tpadmin-cpp-0.1.0.ebuild b/games-server/tpadmin-cpp/tpadmin-cpp-0.1.0.ebuild
new file mode 100644
index 0000000..6f4b172
--- /dev/null
+++ b/games-server/tpadmin-cpp/tpadmin-cpp-0.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2008-2012 Funtoo Technologies
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit games
+
+DESCRIPTION="A command-line administration utility for Thousand Parsec servers."
+HOMEPAGE="http://www.thousandparsec.net/tp/"
+SRC_URI="
+ ${HOMEPAGE}/downloads/${PN}/${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/boost
+ >=dev-libs/libtprl-0.1.2
+ >=dev-games/libtpproto-cpp-0.1.9
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-stdint.patch"
+)
+
+DOCS="AUTHORS ChangeLog NEWS README"