summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Pranaitis <jens@chaox.net>2010-05-15 13:34:22 +0200
committerJens Pranaitis <jens@chaox.net>2010-05-15 13:34:22 +0200
commited911252ab6a3ee749b074305b8cc6b6d94e1016 (patch)
tree5cdd94d4571a3396c3a8b36b6d2dbc3cb4648bdf
parentFix desktop entry (diff)
downloadjensp-ed911252ab6a3ee749b074305b8cc6b6d94e1016.tar.gz
jensp-ed911252ab6a3ee749b074305b8cc6b6d94e1016.tar.bz2
jensp-ed911252ab6a3ee749b074305b8cc6b6d94e1016.zip
lugaru: various QA cleanups
-rw-r--r--games-action/lugaru/Manifest2
-rw-r--r--games-action/lugaru/lugaru-9999.ebuild27
2 files changed, 11 insertions, 18 deletions
diff --git a/games-action/lugaru/Manifest b/games-action/lugaru/Manifest
index 44ab607..ed08c99 100644
--- a/games-action/lugaru/Manifest
+++ b/games-action/lugaru/Manifest
@@ -1 +1 @@
-EBUILD lugaru-9999.ebuild 977 RMD160 829aac20bfb8c5df7de33659ac1d309ea443eda4 SHA1 abece44c58e3d9b769e8fb1c0c876fc5db336279 SHA256 77f527e5c4e6697a06b40a72df1d45ae7dfeecb66fdc525b06aee22c66fa5ec5
+EBUILD lugaru-9999.ebuild 972 RMD160 1963a592b1b376ee0cc867e9b2ca20a2364c191e SHA1 be859a1b8d2e0e9f25d73feae768081a0a964db3 SHA256 b18af6d5afaa78ee3d5954ae9ef64538d3fe4f49f172ebf6ea242097430a6767
diff --git a/games-action/lugaru/lugaru-9999.ebuild b/games-action/lugaru/lugaru-9999.ebuild
index c7ef79a..af8594d 100644
--- a/games-action/lugaru/lugaru-9999.ebuild
+++ b/games-action/lugaru/lugaru-9999.ebuild
@@ -4,25 +4,26 @@
EAPI=3
-inherit cmake-utils games mercurial
+inherit games mercurial cmake-utils
DESCRIPTION="a cross platform 3d action adventure"
HOMEPAGE="http://www.wolfire.com/lugaru"
SRC_URI=""
-EHG_REPO_URI="http://hg.icculus.org/icculus/lugaru"
+EHG_REPO_URI="http://hg.icculus.org/icculus/${PN}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE=""
-DEPEND="media-libs/openal
+DEPEND="media-libs/jpeg
+ media-libs/libogg
media-libs/libpng
- media-libs/jpeg
media-libs/libsdl
- virtual/opengl
media-libs/libvorbis
- media-libs/libogg"
+ media-libs/openal
+ virtual/opengl"
+
RDEPEND="${DEPEND}
games-action/lugaru-data"
@@ -32,17 +33,9 @@ pkg_setup() {
mycmakeargs="-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX_OPT}/${PN}"
}
-src_configure() {
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
src_install() {
cmake-utils_src_install
- rm -rf "${D}"/opt/lugaru/Data
- games_make_wrapper lugaru ./lugaru "${GAMES_PREFIX_OPT}/${PN}" "${GAMES_PREFIX_OPT}/${PN}"
- make_desktop_entry lugaru "Lugaru: The Rabbit's Foot"
+ rm -rf "${D}"/opt/${PN}/Data
+ games_make_wrapper ${PN} ./${PN} "${GAMES_PREFIX_OPT}/${PN}" "${GAMES_PREFIX_OPT}/${PN}"
+ make_desktop_entry ${PN} "Lugaru: The Rabbit's Foot"
}