summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/libgcal/libgcal-0.9.6.ebuild')
-rw-r--r--app-pda/libgcal/libgcal-0.9.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-pda/libgcal/libgcal-0.9.6.ebuild b/app-pda/libgcal/libgcal-0.9.6.ebuild
new file mode 100644
index 0000000..58ef552
--- /dev/null
+++ b/app-pda/libgcal/libgcal-0.9.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: app-pda/libgcal-0.9.1$
+
+EAPI=2
+
+inherit eutils cmake-utils
+
+DESCRIPTION="C/C++ interface to the Google Data API"
+HOMEPAGE="http://code.google.com/p/libgcal/"
+SRC_URI="http://libgcal.googlecode.com/files/$P.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+google test"
+DEPEND="google? ( app-misc/ca-certificates )
+ test? ( app-pda/libopensync )
+ dev-libs/libxml2
+ net-misc/curl"
+RDEPEND="${DEPEND}"
+
+RESTRICT="mirror"
+
+src_configure() {
+ mycmakeargs="$(cmake-utils_use_enable test TESTS)"
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}