summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/timidity++/files')
-rw-r--r--media-sound/timidity++/files/50timidity++-gentoo.el6
-rw-r--r--media-sound/timidity++/files/conf.d.timidity.227
-rw-r--r--media-sound/timidity++/files/init.d.timidity.320
-rw-r--r--media-sound/timidity++/files/init.d.timidity.420
-rw-r--r--media-sound/timidity++/files/timidity++-2.14.0-params.patch22
-rw-r--r--media-sound/timidity++/files/timidity++-2.14.0-revert-for-required-ctl_speana_data-function.patch28
-rw-r--r--media-sound/timidity++/files/timidity++-2.14.0-tcltk86.patch13
-rw-r--r--media-sound/timidity++/files/timidity.cfg-r124
-rw-r--r--media-sound/timidity++/files/timidity.desktop.210
-rw-r--r--media-sound/timidity++/files/timidity.service10
-rw-r--r--media-sound/timidity++/files/timidity.xpm56
11 files changed, 236 insertions, 0 deletions
diff --git a/media-sound/timidity++/files/50timidity++-gentoo.el b/media-sound/timidity++/files/50timidity++-gentoo.el
new file mode 100644
index 0000000..3f9e35c
--- /dev/null
+++ b/media-sound/timidity++/files/50timidity++-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; timidity++ site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'timidity "timidity" "TiMidity Interface" t)
+(setq timidity-prog-path "/usr/bin/timidity")
diff --git a/media-sound/timidity++/files/conf.d.timidity.2 b/media-sound/timidity++/files/conf.d.timidity.2
new file mode 100644
index 0000000..0a153ca
--- /dev/null
+++ b/media-sound/timidity++/files/conf.d.timidity.2
@@ -0,0 +1,27 @@
+# TIMIDITY_OPTS
+# Command line arguements to be passed to timidity. -iA is always used
+# Common options:
+# -Os : Output to ALSA pcm device
+# -Oe : Output to esd
+# -On : Output to NAS
+#
+# -B<n>,<m> : Set number of buffer fragments(n), and buffer size(2^m)
+#
+# -EFreverb=0 : Disable MIDI reverb effect control
+# -EFreverb=1[,level] : Enable MIDI reverb effect control
+# `level' is optional to specify reverb level [0..127]
+# This effect is only available in stereo
+# (default)
+# -EFreverb=2 : Global reverb effect
+
+TIMIDITY_OPTS="-B2,8 -Os -EFreverb=0"
+
+# TIMIDITY_PCM_NAME
+# This option can be used to choose an alternate ALSA pcm device. This will
+# be most useful for users of the dmix alsa plugin or those with multiple
+# cards. If you don't know what this is, chances are you want the default.
+
+#TIMIDITY_PCM_NAME="default"
+
+#LADSPA plugins library path
+LADSPA_PATH="/usr/lib/ladspa"
diff --git a/media-sound/timidity++/files/init.d.timidity.3 b/media-sound/timidity++/files/init.d.timidity.3
new file mode 100644
index 0000000..444a914
--- /dev/null
+++ b/media-sound/timidity++/files/init.d.timidity.3
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+
+depend() {
+ after alsasound esound
+}
+
+start() {
+ ebegin "Starting TiMidity++ Virtual Midi Sequencer"
+ test -n "$TIMIDITY_PCM_NAME" && export TIMIDITY_PCM_NAME
+ start-stop-daemon --start --background --chdir /usr/share/timidity \
+ --chuid timidity:audio --make-pidfile --pidfile /var/run/timidity.pid \
+ --exec /usr/bin/timidity -- -iA ${TIMIDITY_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping TiMidity++"
+ start-stop-daemon --stop --quiet --pidfile /var/run/timidity.pid
+ eend $?
+}
diff --git a/media-sound/timidity++/files/init.d.timidity.4 b/media-sound/timidity++/files/init.d.timidity.4
new file mode 100644
index 0000000..e3dac7f
--- /dev/null
+++ b/media-sound/timidity++/files/init.d.timidity.4
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+
+depend() {
+ after alsasound esound
+}
+
+start() {
+ ebegin "Starting TiMidity++ Virtual Midi Sequencer"
+ test -n "$TIMIDITY_PCM_NAME" && export TIMIDITY_PCM_NAME
+ start-stop-daemon --start --background --chdir /usr/share/timidity \
+ --user timidity --group audio --make-pidfile --pidfile /var/run/timidity.pid \
+ --exec /usr/bin/timidity -- -iA ${TIMIDITY_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping TiMidity++"
+ start-stop-daemon --stop --quiet --pidfile /var/run/timidity.pid
+ eend $?
+}
diff --git a/media-sound/timidity++/files/timidity++-2.14.0-params.patch b/media-sound/timidity++/files/timidity++-2.14.0-params.patch
new file mode 100644
index 0000000..d56448b
--- /dev/null
+++ b/media-sound/timidity++/files/timidity++-2.14.0-params.patch
@@ -0,0 +1,22 @@
+--- configure.in
++++ configure.in
+@@ -2245,10 +2245,15 @@
+
+ AM_CONDITIONAL(W32READDIR, test "x$W32READDIR" = "xyes")
+
+-SET_UNIQ_WORDS(LDFLAGS,$LDFLAGS)
+-SET_UNIQ_WORDS(SHLDFLAGS,$SHLDFLAGS)
+-SET_UNIQ_WORDS(CFLAGS,$EXTRACFLAGS $CFLAGS)
+-SET_UNIQ_WORDS(CPPFLAGS,$CPPFLAGS $EXTRADEFS)
++# These break flags like --param wrt #276433
++# SET_UNIQ_WORDS(LDFLAGS,$LDFLAGS)
++# SET_UNIQ_WORDS(SHLDFLAGS,$SHLDFLAGS)
++# SET_UNIQ_WORDS(CFLAGS,$EXTRACFLAGS $CFLAGS)
++# SET_UNIQ_WORDS(CPPFLAGS,$CPPFLAGS $EXTRADEFS)
++LDFLAGS="$LDFLAGS"
++SHLDFLAGS="$SHLDFLAGS"
++CFLAGS="$EXTRACFLAGS $CFLAGS"
++CPPFLAGS="$CPPFLAGS $EXTRADEFS"
+
+ if test "x$oss_device" != x; then
+ AC_DEFINE_UNQUOTED(OSS_DEVICE,"$oss_device", oss device name)
diff --git a/media-sound/timidity++/files/timidity++-2.14.0-revert-for-required-ctl_speana_data-function.patch b/media-sound/timidity++/files/timidity++-2.14.0-revert-for-required-ctl_speana_data-function.patch
new file mode 100644
index 0000000..a83a7db
--- /dev/null
+++ b/media-sound/timidity++/files/timidity++-2.14.0-revert-for-required-ctl_speana_data-function.patch
@@ -0,0 +1,28 @@
+This will revert part of the commit from:
+
+http://timidity.git.sourceforge.net/git/gitweb.cgi?p=timidity/timidity;a=commit;h=e73b53437dbc1e57e61dd4d0c1407784797b08d9
+
+Because otherwise TiMidity++ simply won't build as per:
+
+../interface/libinterface.a(xskin_c.o): In function `ctl_event':
+xskin_c.c:(.text+0x17c): undefined reference to `ctl_speana_data'
+collect2: error: ld returned 1 exit status
+
+--- interface/xskin_c.c
++++ interface/xskin_c.c
+@@ -228,7 +228,6 @@
+ }
+ }
+
+-#if 0
+ static void ctl_speana_data(double *val, int size) {
+
+ /* 0 <= val[n] <= (AMP*NCOLOR) */
+@@ -280,7 +279,6 @@
+
+ return;
+ }
+-#endif
+
+ /*ARGSUSED*/
+ static int ctl_open(int using_stdin, int using_stdout) {
diff --git a/media-sound/timidity++/files/timidity++-2.14.0-tcltk86.patch b/media-sound/timidity++/files/timidity++-2.14.0-tcltk86.patch
new file mode 100644
index 0000000..ea2c0ee
--- /dev/null
+++ b/media-sound/timidity++/files/timidity++-2.14.0-tcltk86.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/451296
+
+--- interface/tk_c.c
++++ interface/tk_c.c
+@@ -913,7 +913,7 @@
+ vsnprintf(buf, sizeof(buf), fmt, ap);
+ Tcl_Eval(my_interp, buf);
+ va_end(ap);
+- return my_interp->result;
++ return Tcl_GetStringResult(my_interp);
+ }
+
+ static const char *v_get2(const char *v1, const char *v2)
diff --git a/media-sound/timidity++/files/timidity.cfg-r1 b/media-sound/timidity++/files/timidity.cfg-r1
new file mode 100644
index 0000000..3923fb2
--- /dev/null
+++ b/media-sound/timidity++/files/timidity.cfg-r1
@@ -0,0 +1,24 @@
+##############################################################################
+#
+# timidity-update core configuration file
+#
+# Easy process:
+#
+# 1. Change directory to patch directory
+# 2. Source current/timidity.cfg
+#
+# Current patch set will always be symlinked to current, so make sure that the
+# proper timidity.cfg is in there
+#
+#
+# - source /usr/share/timidity
+# - source ~/.timidity/current
+# - Make ~/.timidity/current point to the current patch set, or to whatever
+# the individual user sets
+# - If ~/.timidity/current isn't found, it will try
+# /usr/share/timidity/current
+#
+
+dir /usr/share/timidity
+dir ~/.timidity
+source current/timidity.cfg
diff --git a/media-sound/timidity++/files/timidity.desktop.2 b/media-sound/timidity++/files/timidity.desktop.2
new file mode 100644
index 0000000..00c7f1d
--- /dev/null
+++ b/media-sound/timidity++/files/timidity.desktop.2
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Comment=Software sound renderer (MIDI sequencer, MOD player)
+Name=TiMidity++ MIDI sequencer
+Terminal=true
+NoDisplay=true
+Type=Application
+Exec=timidity %F
+Categories=AudioVideo;Audio;Sequencer;
+Icon=timidity
+MimeType=audio/midi;audio/x-mod;
diff --git a/media-sound/timidity++/files/timidity.service b/media-sound/timidity++/files/timidity.service
new file mode 100644
index 0000000..420d888
--- /dev/null
+++ b/media-sound/timidity++/files/timidity.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=TiMidity++ Daemon
+After=sound.target
+
+[Service]
+EnvironmentFile=-/etc/conf.d/timidity
+ExecStart=/usr/bin/timidity -iA $TIMIDITY_OPTS
+
+[Install]
+WantedBy=multi-user.target
diff --git a/media-sound/timidity++/files/timidity.xpm b/media-sound/timidity++/files/timidity.xpm
new file mode 100644
index 0000000..dc56a6d
--- /dev/null
+++ b/media-sound/timidity++/files/timidity.xpm
@@ -0,0 +1,56 @@
+/* XPM */
+static char * timidity_xpm[] = {
+"32 32 21 1",
+" c None",
+". c #333399",
+"+ c #000000",
+"@ c #666699",
+"# c #FFFFFF",
+"$ c #DDDDDD",
+"% c #888888",
+"& c #999999",
+"* c #7777A4",
+"= c #4949A4",
+"- c #BBBBBB",
+"; c #111111",
+"> c #444444",
+", c #2B2B2B",
+"' c #555555",
+") c #FF9999",
+"! c #FF9966",
+"~ c #666666",
+"{ c #333333",
+"] c #FF0000",
+"^ c #00FF00",
+" . .. ",
+" . ... + ",
+" . ..@ +#+ + ",
+" .@@.. +#$#+%#+ ",
+" ....@ +#$#$#+$#+ ",
+" .... +#$#$#$#+$#+ ",
+" @...@ +#$#$#$#$#+$#+ ",
+" @.... +#$#$#$#$#$#+$#+ ",
+" @...@. %#$#$#$#$#$#$#&$#& ",
+" @...@ +++++++$#++$+++++&$++ ",
+" ...@ ++$++#++$++#++$$++$++$ ",
+" @..@ %++#++$++#++$++$&++$++ ",
+" ... %#++$++#++$++#++&$++#++ ",
+"*..@ .&++#++$++#++$++++++&++ ",
+"=.. ...&#$#$#$#$#$#&-$#$& ",
+"=.. ...+++++$++#+$+++++++ ++ ",
+"=.. .. .&#$#$#$$&-$#&& ",
+"=.. .. . +&$#$&+-$#&+ ",
+" ;;;;;;;;;;;;;;;;;;;>;;;;;;; ",
+",#%%%%%%%%%%%%%%%%%';#%%%%%'+ ",
+",%+++++++++++++++''>;%'''''>+ ",
+",%+#)))))))))))!;''>;%'%~+'>+ ",
+",'+);;!;!!;!!!!!;>>>;'>+++>>+ ",
+",'+)>!!;!!;!;!;!;>>>;'>>>>>>+ ",
+",'+!!!!!!!!!!!!!;>>{;'>%~+>>+ ",
+",'+;;;;;;;;;;;;;'>>{;'>+++>>+ ",
+",'>>>>>>>>>>>>>>>>>{;'>>>>>>+> ",
+",'%~'>>%~'>>'>'>'>>{;'>%~+>{++> ",
+",']++>>^++>>+>+>+>>{;'>+++>{++>>",
+",'>>>>>>>>>>>>>>{{{';'>>{{{'+>>~",
+" +++++++++++++++++++>+++++++>>~ ",
+" "};