aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2019-05-18 13:05:50 +0100
committerPaul Healy <lmiphay@gmail.com>2019-05-18 13:05:50 +0100
commitaa2210ccabb4c7293d298342b749d541fa119bc5 (patch)
tree6d2f2222ebd3dbe972d45f37165ae3c73f7ec9c2 /app-emulation
parentremove old ebuilds (diff)
downloadlmiphay-aa2210ccabb4c7293d298342b749d541fa119bc5.tar.gz
lmiphay-aa2210ccabb4c7293d298342b749d541fa119bc5.tar.bz2
lmiphay-aa2210ccabb4c7293d298342b749d541fa119bc5.zip
add ebuild for portainer
Signed-off-by: Paul Healy <lmiphay@gmail.com>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/portainer-bin/Manifest4
-rw-r--r--app-emulation/portainer-bin/files/portainer.conf.d8
-rwxr-xr-xapp-emulation/portainer-bin/files/portainer.init.d33
-rw-r--r--app-emulation/portainer-bin/portainer-bin-1.20.2.ebuild55
4 files changed, 100 insertions, 0 deletions
diff --git a/app-emulation/portainer-bin/Manifest b/app-emulation/portainer-bin/Manifest
new file mode 100644
index 0000000..10717bf
--- /dev/null
+++ b/app-emulation/portainer-bin/Manifest
@@ -0,0 +1,4 @@
+AUX portainer.conf.d 239 BLAKE2B cc10a16056c4c17a0a1f1f5fa31dcd9be5365629bef436dba1ecb9eba2011d83e6906449f0a21693cc4667686cdd5c7b75720e388dc5818bc7f20cee28d13b11 SHA512 e976e9ee42a610f96e5390db4eb8f95210f782ca889d765a6db4d086e3d1196673fdf5ddd644a60c69ec46c0ff0ab4148c471b9c27b59f4a01d7561e6ed4de28
+AUX portainer.init.d 750 BLAKE2B 93b4b5dafb08bbcd3a8f99a48c3f1876ded71b965aaafa78f36b062f2e5d3ad662e002810ed65311a38d9922ee715743f62ec932dd783838769df1dae8e1a341 SHA512 e1035915bf741cd5c37e0063a1483e5ef88b7c6c18ceb1f213f83a2b4565bc8dcedb44dc1824f0f4d61c9eb182d897aec713796c1a028181d1b8a96cf27ddfc4
+DIST portainer-1.20.2-linux-amd64.tar.gz 21887455 BLAKE2B 3079a9662db787223a21b0d1019cdf51dc93a4a4e8e8a63ea420142068c1d6a220e666e4f24e424d93c82da0f0961228a83953dbfbcb787d634c6211c9cbdf62 SHA512 3e0443a27d51dc9a2a260c12beffaf73700e29f688cd1da8710a1d9f508d8cdb23c66b3dbe6306f713173f76d40ca83154641e1dee01dc481b8711123ac339ec
+EBUILD portainer-bin-1.20.2.ebuild 1081 BLAKE2B aa1cccd43e7065fdf1149ad7e8ff38c1789dfc9a482dd42a2f54e4443c5ad79348f882356e7b827fd4f4eac76d88b72d23d3f3cac974394fb520850407450e9b SHA512 98592e13fd4ba0cf9d1b0a0f00340e516f4c77178cbdb7ddc82bb3236c69ba5348482666d56cac4fff565988b36af194e376882bb0ff313bb34c648cc8776ef5
diff --git a/app-emulation/portainer-bin/files/portainer.conf.d b/app-emulation/portainer-bin/files/portainer.conf.d
new file mode 100644
index 0000000..7369f7d
--- /dev/null
+++ b/app-emulation/portainer-bin/files/portainer.conf.d
@@ -0,0 +1,8 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# /etc/conf.d/portainer: configuration for /etc/init.d/portainer
+
+# Switches to pass to portainer
+#
+#PORTAINER_OPTS="--bind :9000"
diff --git a/app-emulation/portainer-bin/files/portainer.init.d b/app-emulation/portainer-bin/files/portainer.init.d
new file mode 100755
index 0000000..d8ee5ee
--- /dev/null
+++ b/app-emulation/portainer-bin/files/portainer.init.d
@@ -0,0 +1,33 @@
+#!/sbin/openrc-run
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+description="Simple management UI for Docker"
+
+user="portainer:portainer"
+
+log="/var/log/portainer.log"
+errorlog="/var/log/portainer.errors"
+
+start_stop_daemon_args="--user $user --stdout $log --stderr $errorlog --retry 20"
+
+command="/opt/portainer-bin/portainer"
+command_args="
+ --data /var/lib/portainer/data
+ --no-analytics
+ --template-file /var/lib/portainer/templates.json
+ ${PORTAINER_OPTS}
+"
+
+command_background=yes
+pidfile=/run/portainer.pid
+
+depend() {
+ need net
+ after bootmisc
+}
+
+start_pre() {
+ checkpath --file --owner $user --mode 0644 $log
+ checkpath --file --owner $user --mode 0644 $errorlog
+}
diff --git a/app-emulation/portainer-bin/portainer-bin-1.20.2.ebuild b/app-emulation/portainer-bin/portainer-bin-1.20.2.ebuild
new file mode 100644
index 0000000..d46759e
--- /dev/null
+++ b/app-emulation/portainer-bin/portainer-bin-1.20.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit user eutils
+
+MY_PN="${PN/-bin/}"
+
+DESCRIPTION="Simple management UI for Docker"
+HOMEPAGE="http://portainer.io"
+SRC_URI="https://github.com/portainer/portainer/releases/download/${PV}/${MY_PN}-${PV}-linux-amd64.tar.gz"
+RESTRICT="mirror"
+
+LICENSE="ZLIB MIT"
+SLOT="0"
+KEYWORDS="~amd64 -*"
+IUSE=""
+
+INST_DIR="opt/${PN}"
+QA_PREBUILT="${INST_DIR}/*"
+
+RDEPEND="
+ >=app-emulation/docker-18.09.5
+"
+DEPEND="${RDEPEND}
+ app-admin/chrpath
+"
+
+S="${WORKDIR}/${MY_PN}"
+
+pkg_setup() {
+ enewgroup "${MY_PN}"
+ enewuser "${MY_PN}" -1 -1 "/$INST_DIR" "${MY_PN}"
+ usermod -aG "docker" "${MY_PN}"
+}
+
+src_prepare() {
+ rm -f docker || die
+ eapply_user
+}
+
+src_install() {
+ mkdir -p "${D}/${INST_DIR}/"
+ cp -a . "${D}/${INST_DIR}/" || die
+
+ newconfd "${FILESDIR}/${MY_PN}.conf.d" "${MY_PN}"
+ newinitd "${FILESDIR}/${MY_PN}.init.d" "${MY_PN}"
+
+ keepdir "/var/lib/${MY_PN}/data"
+ fowners -R "${MY_PN}:${MY_PN}" "/var/lib/${MY_PN}"
+
+ insinto "/var/lib/${MY_PN}"
+ doins templates.json
+}