aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2022-07-10 13:36:47 +0100
committerPaul Healy <lmiphay@gmail.com>2022-07-10 13:36:47 +0100
commitf9fe6547b93c0965dcd0435b9831bea6c2b0804d (patch)
tree87095e506b0a4b288fc3ce5d8901ac70f779277e /app-misc
parentrevbump piper; disable tests looking for appstreamcli (diff)
downloadlmiphay-f9fe6547b93c0965dcd0435b9831bea6c2b0804d.tar.gz
lmiphay-f9fe6547b93c0965dcd0435b9831bea6c2b0804d.tar.bz2
lmiphay-f9fe6547b93c0965dcd0435b9831bea6c2b0804d.zip
call udev_reload in pkg_postinst/rm
Signed-off-by: Paul Healy <lmiphay@gmail.com>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/g13/Manifest2
-rw-r--r--app-misc/g13/g13-20150528_p1.ebuild10
2 files changed, 9 insertions, 3 deletions
diff --git a/app-misc/g13/Manifest b/app-misc/g13/Manifest
index 16977bd..25e81c5 100644
--- a/app-misc/g13/Manifest
+++ b/app-misc/g13/Manifest
@@ -7,5 +7,5 @@ AUX g13loadbind 190 BLAKE2B 65ec73e769ef328c77edbbbf3bc09dce2f5d97de79859b7b1513
AUX g13mod 319 BLAKE2B 0a461d634090a0b62f72350e0d1c8d593d06a5cf64a59f0cc92d7ab28a80690429735e3019711d0794ba99fe9447fcaf4cbd2cd81666d1caf8ccdc6233ddd51f SHA512 ff51531522fe35f0c71c5b2c4692062355e86841bdf48e4f7fc9b19df2440b738f274ddcc4d8b5acb3ca5df84a694d251a2fa504a8ff6230fa7e846dcdd510fd
AUX g13writelcd 270 BLAKE2B 13a63acde0454c3d37b5e63234946d396ff66179d8865c9f4301687e07936ad709e0b52659e29f903f84466a304b208ed2056bed0dcd397707d15aae025fc397 SHA512 330b968d676e5fab9034004d1c659f61f312194267021e0b07b4ed0f5660671a4bec59b21493bcb66c2eb711da188be6609c8fa7c0ff787ccfed8bf3a2b4ae71
AUX keys.txt 1054 BLAKE2B c2ba762ee4fbfcdb201dddd1a06ae4edd97bcffa4be1ddf13a71781d90f8ebbc0e4918c7f8bbeb1bdfe9000f8ec000799cab63d397b33b81a2aebb8fb4e6eedc SHA512 a96d1eaef75f1b93637d25fb5b94b34a14eb9083a596e37b3c147a4ad4d762bf679c1dba44545620e23a56fb7c7dc1bff7122cd2a36813a7a1aa8c51fa6d0e58
-EBUILD g13-20150528_p1.ebuild 2162 BLAKE2B 2364492014177a939bf61c0d810dcdf3ffe0cce3260348a6adc19ae1c0038fe1551c29522245aae4084e82c605c975260a4e7071675d43f4443a732623d20189 SHA512 74274e2f2e8c29239bd002c516d582bba55050f6439e9f2d3801429f6fe0ce2a7e3449a56d1e81f29673bb7d053dbd34a5ab5f46676bf73efd1f68562065f0cd
+EBUILD g13-20150528_p1.ebuild 2212 BLAKE2B 0d35302f36b209a7bd9aa81dc8e0e4b867ae5a68299e3d8767cfff6e81e17614ee095a0900289c8f74b6d18f04fdea91e37440957c17b1d9abefac1698b33c33 SHA512 d3b3a1ba1b6a45119c18de28eb3ea5317d2382dd816ca0e2158e46f73cd40f85d0706bf51d76aa4b75aa8465078bc40e5490f81dbe29d2ec9a784a3210943e66
EBUILD g13-9999.ebuild 1947 BLAKE2B 4c21a40a7a2b68eedbf91b13487b3ce3025cd257f58fb2a02b705bb64ca3f13ea2ddfb7d8e731d3e744953f97e843a628d3ab0a97b059b9d423b5f100d38b211 SHA512 97f13a0d2782b15946ba14840a9cfb2e84d4374659b855e245b578af09ab1ab876016dbfd55706422e0dd4398c58138652199e648ad1b116b9f3d63f75c70b6b
diff --git a/app-misc/g13/g13-20150528_p1.ebuild b/app-misc/g13/g13-20150528_p1.ebuild
index af44329..0d8edb5 100644
--- a/app-misc/g13/g13-20150528_p1.ebuild
+++ b/app-misc/g13/g13-20150528_p1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit eutils user linux-info git-r3
+inherit eutils user linux-info git-r3 udev
DESCRIPTION="libusb driver for the g13"
HOMEPAGE="https://github.com/ecraven/g13"
@@ -69,6 +69,8 @@ src_install() {
}
pkg_postinst() {
+ udev_reload
+
elog "Note that the command pipe is: /run/g13-0"
elog "And you need to be in the plugdev group to write to it."
elog ""
@@ -86,3 +88,7 @@ pkg_postinst() {
elog "Bindings similar to the windows default are available at:"
elog " https://github.com/zekesonxx/g13-profiles"
}
+
+pkg_postrm() {
+ udev_reload
+}