aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/fake-hwclock/fake-hwclock-0.14.ebuild')
-rw-r--r--sys-apps/fake-hwclock/fake-hwclock-0.14.ebuild42
1 files changed, 21 insertions, 21 deletions
diff --git a/sys-apps/fake-hwclock/fake-hwclock-0.14.ebuild b/sys-apps/fake-hwclock/fake-hwclock-0.14.ebuild
index 0bff12e..730ffcc 100644
--- a/sys-apps/fake-hwclock/fake-hwclock-0.14.ebuild
+++ b/sys-apps/fake-hwclock/fake-hwclock-0.14.ebuild
@@ -1,47 +1,47 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# see: https://bugs.gentoo.org/704920
-
EAPI="8"
-inherit systemd git-r3
+inherit systemd
DESCRIPTION="Save/restore system clock on machines without working RTC hardware"
-HOMEPAGE="https://tracker.debian.org/pkg/fake-hwclock"
-EGIT_REPO_URI="https://git.einval.com/git/fake-hwclock.git"
-EGIT_COMMIT="00a0feb706bfc11e1e0dbaa887c603b8f9875c78"
+HOMEPAGE="https://tracker.debian.org/pkg/${PN}"
+SRC_URI="mirror://debian/pool/main/f/${PN}/${PN}_${PV}.tar.xz"
-LICENSE="GPL-2+"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64"
+S=${WORKDIR}/git
+
src_prepare() {
- sed -i -e 's:/etc/fake-hwclock.data:/var/lib/fake-hwclock/data:' fake-hwclock
+ sed -i -e "s:/etc/${PN}.data:/var/lib/${PN}/data:" "${PN}" "${PN}.8"
+ sed -i -e "s:/etc/default/fake-hwclock:/etc/conf.d/fake-hwclock:" "${PN}.8"
eapply_user
}
src_install() {
- insinto "/var/lib/fake-hwclock"
- date -u '+%Y-%m-%d %H:%M:%S' > "${T}/data"
- doins "${T}/data"
+ keepdir "/var/lib/${PN}"
into /
- dosbin fake-hwclock
-
- newinitd "${FILESDIR}/fake-hwclock.init.d" fake-hwclock
+ dosbin "${PN}"
+ doman "${PN}.8"
+ dodoc debian/changelog
- systemd_dounit debian/fake-hwclock-load.service
- systemd_dounit debian/fake-hwclock-save.service
- systemd_dounit debian/fake-hwclock-save.timer
+ newinitd "${FILESDIR}/${PN}.init.d" "${PN}"
+ doconfd "etc/default/${PN}"
+ insinto /etc/cron.hourly
+ newins "debian/${PN}.cron.hourly" "${PN}.cron"
- doman fake-hwclock.8
- dodoc debian/changelog
+ systemd_dounit "debian/${PN}-load.service"
+ systemd_dounit "debian/${PN}-save.service"
+ systemd_dounit "debian/${PN}-save.timer"
}
pkg_postinst() {
- elog "To enable and start the services:"
+ elog "To enable and start the systemd services:"
elog ""
- elog "systemctl enable --now fake-hwclock-load.service fake-hwclock-save.service fake-hwclock-save.timer"
+ elog "systemctl enable --now ${PN}-load.service ${PN}-save.service ${PN}-save.timer"
}