summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/openctm/openctm-1.0.3.ebuild')
-rw-r--r--media-libs/openctm/openctm-1.0.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/openctm/openctm-1.0.3.ebuild b/media-libs/openctm/openctm-1.0.3.ebuild
new file mode 100644
index 0000000..0c6759a
--- /dev/null
+++ b/media-libs/openctm/openctm-1.0.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# TODO: unbundle tinyxml, glew, etc...
+
+EAPI=2
+
+inherit eutils multilib qt4-r2 versionator
+
+MY_PF=OpenCTM-1.0.3
+
+DESCRIPTION="OpenCTM - the Open Compressed Triangle Mesh file format - is a file format, a software library and a tool set for compression of 3D triangle meshes."
+HOMEPAGE="http://openctm.sourceforge.net"
+SRC_URI="mirror://sourceforge/openctm/${MY_PF}/${MY_PF}-src.tar.bz2"
+
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="media-libs/glew
+ media-libs/freeglut"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_PF}
+
+src_configure() {
+ sed -i 's/-lglut/-lglut -lGLU/g' tools/Makefile.linux
+}
+
+src_compile() {
+ emake -f Makefile.linux openctm toolset
+}
+
+src_install() {
+ doexe tools/bin2c
+ doexe tools/ctmconv
+ doexe tools/ctmbench
+ doexe tools/ctmviewer
+ dolib tools/libopenctm.so
+}