summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/alembic/Manifest5
-rw-r--r--media-libs/alembic/alembic-1.0.1.2011091600.ebuild84
-rw-r--r--media-libs/alembic/alembic-1.0.2.2011101200.ebuild84
-rw-r--r--media-libs/alembic/alembic-9999.ebuild79
-rw-r--r--media-libs/collada-dom/Manifest6
-rw-r--r--media-libs/collada-dom/collada-dom-2.3.1.ebuild24
-rw-r--r--media-libs/glfw/Manifest4
-rw-r--r--media-libs/glfw/files/glfw-2.7.2-compile.patch38
-rw-r--r--media-libs/glfw/files/glfw-2.7.2-dyn.patch20
-rw-r--r--media-libs/glfw/glfw-2.7.2.ebuild79
-rw-r--r--media-libs/luxrays/Manifest1
-rw-r--r--media-libs/luxrays/luxrays-9999.ebuild49
-rw-r--r--media-libs/opencollada/Manifest1
-rw-r--r--media-libs/opencollada/opencollada-9999.ebuild23
-rw-r--r--media-libs/opensg/Manifest5
-rw-r--r--media-libs/opensg/files/opensg-2.0_alpha2284-fix-gdal-png.patch51
-rw-r--r--media-libs/opensg/opensg-2.0_alpha2284.ebuild79
-rw-r--r--media-libs/opensg/opensg-9999.ebuild98
-rw-r--r--media-libs/spacenav/Manifest1
-rw-r--r--media-libs/spacenav/spacenav-9999.ebuild59
20 files changed, 790 insertions, 0 deletions
diff --git a/media-libs/alembic/Manifest b/media-libs/alembic/Manifest
new file mode 100644
index 0000000..b8167a6
--- /dev/null
+++ b/media-libs/alembic/Manifest
@@ -0,0 +1,5 @@
+DIST Alembic_1.0.1_2011091600.tgz 566444 RMD160 e2de15236d76e91839df29724a12ac6ef109e3c9 SHA1 8d0760c07eb26d70865e10e3470be4f43c0e620e SHA256 dfc499280a59a179e09e159884e0ab60b5f3335566cb4db2c5f94c88a1f50653
+DIST Alembic_1.0.2_2011101200.tgz 574206 RMD160 c4eccd05783fe36ced6324616cd16602a0f3fb58 SHA1 b8230399370a8f54b5a3395f087516bae0a5f3df SHA256 e66fd41dd42d55d91721afec3d019a8bfc657e2642bc1d0ee5c611729e9f2c71
+EBUILD alembic-1.0.1.2011091600.ebuild 2267 RMD160 6525b0a1decd6118c0f21ba2e8af24ea2e57c4d8 SHA1 e3978bb5fa9043deb30114e287075f77c28e7035 SHA256 151f11583c90e1b73976f9ee07bb487c2e93e20f0ba7f4161cf72ec3d40874fe
+EBUILD alembic-1.0.2.2011101200.ebuild 2279 RMD160 20afb56273285a0d8c19910a2f5ca3e414a1ceb2 SHA1 77d36ce2857256a49d1af44cb472abc472bb4c8f SHA256 150b2c95979cbc80f6b57a6c248c35cea0cc68721dc7910253724df0bc0a4713
+EBUILD alembic-9999.ebuild 2041 RMD160 de599413bfd7288f9677743dc44287bd18276ee2 SHA1 1f1acbd5537952f324f5dccd11079e401f6574ab SHA256 363446482e107d4ab87c513327e23341fe1524911dcc424f0e556c086fd01198
diff --git a/media-libs/alembic/alembic-1.0.1.2011091600.ebuild b/media-libs/alembic/alembic-1.0.1.2011091600.ebuild
new file mode 100644
index 0000000..d68fb0e
--- /dev/null
+++ b/media-libs/alembic/alembic-1.0.1.2011091600.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# TODO: replace the alembic_bootstrap.py with proper gentoo methods (cmake eclass)
+
+EAPI=2
+
+inherit eutils versionator
+
+DESCRIPTION="Alembic is an open framework for storing and sharing 3D geometry data that includes a C++ library, a file format, and client plugins and applications."
+HOMEPAGE="http://code.google.com/p/alembic"
+
+MY_PN="Alembic"
+MY_PV=$(replace_version_separator 3 '_')
+MY_P="${MY_PN}_${MY_PV}"
+MY_PV_NODATE=$(get_version_component_range 1-3)
+
+SRC_URI="http://alembic.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples doc"
+RDEPEND=""
+DEPEND=">=dev-util/cmake-2.8
+ >=dev-libs/boost-1.44[static-libs]
+ >=media-libs/ilmbase-1.0.1[static-libs]
+ >=sci-libs/hdf5-1.8.7[-mpi]
+ doc? ( >=app-doc/doxygen-1.7.3 )"
+
+TMPBUILD="${WORKDIR}/alembic-build"
+TMPINSTALL="${WORKDIR}/alembic-install"
+
+src_configure() {
+ mkdir ${TMPBUILD} && cd ${TMPBUILD}
+ S=${TMPBUILD}
+
+ python ${WORKDIR}/${MY_P}/build/bootstrap/alembic_bootstrap.py \
+ --disable-prman --disable-maya --disable-arnold \
+ --hdf5_include_dir=/usr/include \
+ --hdf5_hdf5_library=/usr/lib/libhdf5.a \
+ --boost_include_dir=${LIBS}/boost_install/include \
+ --boost_thread_library=/usr/lib/libboost_thread-mt.a \
+ --zlib_include_dir=/usr/include \
+ --zlib_library=/usr/lib/libz.a \
+ --ilmbase_include_dir=/usr/include/OpenEXR \
+ --ilmbase_imath_library=/usr/lib/libImath.a \
+ .
+}
+
+src_compile() {
+ emake
+
+ if use examples; then
+ cd ${S}/examples
+ emake all
+ fi
+}
+
+src_install() {
+ mkdir ${TMPINSTALL}
+
+ cd ${S}
+ emake DESTDIR=${TMPINSTALL} install
+
+ dolib.a ${TMPINSTALL}/usr/local/${PN}-${MY_PV_NODATE}/lib/static/*.a
+ cp -r ${TMPINSTALL}/usr/local/${PN}-${MY_PV_NODATE}/include/Alembic ${D}/usr/include
+
+ if use examples; then
+ dobin ${TMPBUILD}/examples/bin/AbcEcho/abcecho
+ dobin ${TMPBUILD}/examples/bin/AbcEcho/abcechobounds
+ dobin ${TMPBUILD}/examples/bin/AbcStitcher/abcstitcher
+ dobin ${TMPBUILD}/examples/bin/SimpleAbcViewer/SimpleAbcViewer
+ fi
+
+ dodoc ${WORKDIR}/${MY_P}/{ACKNOWLEDGEMENTS,FEEDBACK,LICENSE,MANIFEST,NEWS,README}.txt
+
+ if use doc; then
+ cd ${WORKDIR}/${MY_P}
+ doxygen
+ dohtml -r doc/html/*
+ fi
+}
diff --git a/media-libs/alembic/alembic-1.0.2.2011101200.ebuild b/media-libs/alembic/alembic-1.0.2.2011101200.ebuild
new file mode 100644
index 0000000..6cefad9
--- /dev/null
+++ b/media-libs/alembic/alembic-1.0.2.2011101200.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# TODO: replace the alembic_bootstrap.py with proper gentoo methods (cmake eclass)
+
+EAPI=2
+
+inherit eutils versionator
+
+DESCRIPTION="Alembic is an open framework for storing and sharing 3D geometry data that includes a C++ library, a file format, and client plugins and applications."
+HOMEPAGE="http://code.google.com/p/alembic"
+
+MY_PN="Alembic"
+MY_PV=$(replace_version_separator 3 '_')
+MY_P="${MY_PN}_${MY_PV}"
+MY_PV_NODATE=$(get_version_component_range 1-3)
+
+SRC_URI="http://alembic.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples doc"
+RDEPEND=""
+DEPEND=">=dev-util/cmake-2.8
+ >=dev-libs/boost-1.44[static-libs]
+ >=media-libs/ilmbase-1.0.1[static-libs]
+ >=sci-libs/hdf5-1.8.7[-mpi,static-libs]
+ doc? ( >=app-doc/doxygen-1.7.3 )"
+
+TMPBUILD="${WORKDIR}/alembic-build"
+TMPINSTALL="${WORKDIR}/alembic-install"
+
+src_configure() {
+ mkdir ${TMPBUILD} && cd ${TMPBUILD}
+ S=${TMPBUILD}
+
+ python ${WORKDIR}/${MY_P}/build/bootstrap/alembic_bootstrap.py \
+ --disable-prman --disable-maya --disable-arnold \
+ --hdf5_include_dir=/usr/include \
+ --hdf5_hdf5_library=/usr/lib/libhdf5.a \
+ --boost_include_dir=${LIBS}/boost_install/include \
+ --boost_thread_library=/usr/lib/libboost_thread-mt.a \
+ --zlib_include_dir=/usr/include \
+ --zlib_library=/usr/lib/libz.a \
+ --ilmbase_include_dir=/usr/include/OpenEXR \
+ --ilmbase_imath_library=/usr/lib/libImath.a \
+ .
+}
+
+src_compile() {
+ emake
+
+ if use examples; then
+ cd ${S}/examples
+ emake all
+ fi
+}
+
+src_install() {
+ mkdir ${TMPINSTALL}
+
+ cd ${S}
+ emake DESTDIR=${TMPINSTALL} install
+
+ dolib.a ${TMPINSTALL}/usr/local/${PN}-${MY_PV_NODATE}/lib/static/*.a
+ cp -r ${TMPINSTALL}/usr/local/${PN}-${MY_PV_NODATE}/include/Alembic ${D}/usr/include
+
+ if use examples; then
+ dobin ${TMPBUILD}/examples/bin/AbcEcho/abcecho
+ dobin ${TMPBUILD}/examples/bin/AbcEcho/abcechobounds
+ dobin ${TMPBUILD}/examples/bin/AbcStitcher/abcstitcher
+ dobin ${TMPBUILD}/examples/bin/SimpleAbcViewer/SimpleAbcViewer
+ fi
+
+ dodoc ${WORKDIR}/${MY_P}/{ACKNOWLEDGEMENTS,FEEDBACK,LICENSE,MANIFEST,NEWS,README}.txt
+
+ if use doc; then
+ cd ${WORKDIR}/${MY_P}
+ doxygen
+ dohtml -r doc/html/*
+ fi
+}
diff --git a/media-libs/alembic/alembic-9999.ebuild b/media-libs/alembic/alembic-9999.ebuild
new file mode 100644
index 0000000..33ed591
--- /dev/null
+++ b/media-libs/alembic/alembic-9999.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# TODO: replace the alembic_bootstrap.py with proper gentoo methods (cmake eclass)
+# TODO: add tests, add help
+
+EAPI=2
+
+inherit eutils mercurial
+
+DESCRIPTION="Alembic is an open framework for storing and sharing 3D geometry data."
+HOMEPAGE="http://code.google.com/p/alembic"
+EHG_REPO_URI="https://code.google.com/p/alembic"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="examples doc"
+RDEPEND=""
+DEPEND=">=dev-util/cmake-2.8
+ >=dev-libs/boost-1.44[static-libs]
+ >=media-libs/ilmbase-1.0.1[static-libs]
+ >=sci-libs/hdf5-1.8.7[-mpi]
+ doc? ( >=app-doc/doxygen-1.7.3 )"
+
+TMPBUILD="${WORKDIR}/alembic-build"
+TMPINSTALL="${WORKDIR}/alembic-install"
+
+src_configure() {
+ mkdir ${TMPBUILD} && cd ${TMPBUILD}
+ S=${TMPBUILD}
+
+ python ${WORKDIR}/${P}/build/bootstrap/alembic_bootstrap.py \
+ --disable-prman --disable-maya --disable-arnold \
+ --hdf5_include_dir=/usr/include \
+ --hdf5_hdf5_library=/usr/lib/libhdf5.a \
+ --boost_include_dir=${LIBS}/boost_install/include \
+ --boost_thread_library=/usr/lib/libboost_thread-mt.a \
+ --zlib_include_dir=/usr/include \
+ --zlib_library=/usr/lib/libz.a \
+ --ilmbase_include_dir=/usr/include/OpenEXR \
+ --ilmbase_imath_library=/usr/lib/libImath.a \
+ .
+}
+
+src_compile() {
+ emake
+
+ if use examples; then
+ cd ${S}/examples
+ emake all
+ fi
+}
+
+src_install() {
+ mkdir ${TMPINSTALL}
+
+ cd ${S}
+ emake DESTDIR=${TMPINSTALL} install
+
+ dolib.a ${TMPINSTALL}/usr/local/alembic-1.0.0/lib/static/*.a
+ cp -r ${TMPINSTALL}/usr/local/alembic-1.0.0/include/Alembic ${D}/usr/include
+
+ if use examples; then
+ dobin ${TMPBUILD}/examples/bin/AbcEcho/abcecho
+ dobin ${TMPBUILD}/examples/bin/AbcEcho/abcechobounds
+ dobin ${TMPBUILD}/examples/bin/AbcStitcher/abcstitcher
+ dobin ${TMPBUILD}/examples/bin/SimpleAbcViewer/SimpleAbcViewer
+ fi
+
+ dodoc ${WORKDIR}/${P}/{ACKNOWLEDGEMENTS,FEEDBACK,LICENSE,MANIFEST,NEWS,README}.txt
+
+ if use doc; then
+ cd ${WORKDIR}/${P}
+ doxygen
+ dohtml -r doc/html/*
+ fi
+}
diff --git a/media-libs/collada-dom/Manifest b/media-libs/collada-dom/Manifest
new file mode 100644
index 0000000..6848c63
--- /dev/null
+++ b/media-libs/collada-dom/Manifest
@@ -0,0 +1,6 @@
+DIST collada-dom-2.2.zip 29651798 RMD160 b2d4387dfe97d97b30b702f39e4ee312dba6d13a SHA1 e6b72ca4c0327fbc342ab87a1d9d76530a980b5d SHA256 3cba41643815045bc9073d1d0ca0337eeda79ce03a31f249078e04973eeecff5
+DIST collada_dom-2.3.1-src.tgz 12106862 RMD160 e20c00c8964e75429bdd13a05939aeb47b0a79a5 SHA1 055a385bf679db5d9a84f46e9ea439b75bdb8725 SHA256 2f0397a0f6463807ee6d7fcbb5d8f512f635259e7f8dfc87bc5dc2f78b2ef9e0
+EBUILD collada-dom-2.2.ebuild 794 RMD160 ac2f62cde490d9f7650786a65cc9d57ff9e5abb2 SHA1 bf012f342719c84b78e4bcd9f9982f957dc85d98 SHA256 f4f3af8d79064680477835ba2ead8e269fe3762e5228ee5fcca8ddf3eb6f356b
+EBUILD collada-dom-2.3.1.ebuild 668 RMD160 4dd023fe9a88413d325165ac16b3184d1a27506f SHA1 1bdf7ccf0344b5ac16c4a78a7d312197e02204dc SHA256 ece5b437a973038b454b3d6878a0c728fcfd912e0cc0f78797b053b03dbff5c9
+MISC collada-dom-2.3.1.ebuild~ 684 RMD160 72f37b69fa536af417dedd2467679d2d4ad5461b SHA1 2fd2f493d951afd4f4a1555a0aeaf715ba788e01 SHA256 5e5d43b939b321ae0e96f91ac508a7c0a429a9f519454b721edb7c6c87f9783c
+MISC colladadom-2.3.1.ebuild~ 1222 RMD160 a62205fd194ec66496b0887574a135340222ad83 SHA1 4c218f587552f64b88467bedde7d75bd46482a0d SHA256 68e10280179f7198084848800da32895b8830e9f9c9ed3019d97be91d9f5a562
diff --git a/media-libs/collada-dom/collada-dom-2.3.1.ebuild b/media-libs/collada-dom/collada-dom-2.3.1.ebuild
new file mode 100644
index 0000000..aaaf671
--- /dev/null
+++ b/media-libs/collada-dom/collada-dom-2.3.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils cmake-utils versionator
+
+DESCRIPTION="The COLLADA Document Object Model (DOM) is an application programming interface (API) that provides a C++ object representation of a COLLADA XML instance document."
+HOMEPAGE="http://sourceforge.net/projects/collada-dom/"
+
+MY_PN="collada_dom"
+MY_P="${MY_PN}-${PV}"
+
+SRC_URI="mirror://sourceforge/project/collada-dom/Collada%20DOM/Collada%20DOM%202.3/${MY_P}-src.tgz"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE=""
+DEPEND="dev-libs/boost
+ dev-libs/libxml2"
+RDEPEND="${DEPEND}"
diff --git a/media-libs/glfw/Manifest b/media-libs/glfw/Manifest
new file mode 100644
index 0000000..49d3550
--- /dev/null
+++ b/media-libs/glfw/Manifest
@@ -0,0 +1,4 @@
+AUX glfw-2.7.2-compile.patch 1115 RMD160 bc2f9a5aa05017f869d6b1c5deea79c88f3ead4d SHA1 f595dc8f44d3c14e62922967e36fb9d441415977 SHA256 89bd4c770e1187526eb747d0d39e8f024be76f96829e86330366a5260d7fb931
+AUX glfw-2.7.2-dyn.patch 806 RMD160 fa6cfd4f6770acd154e4cb73ccc5656395e5b824 SHA1 a845f0d5e1753e5bd73eb097af109a10f3726eea SHA256 9efb0b7d14c62e636c8896c278773afa1b09aef8ddfa945038407ae2b64e29a6
+DIST glfw-2.7.2.tar.bz2 902680 RMD160 409a0ebb121b8d13f30e0d626ca48ba141f06ff4 SHA1 19033c4d55ec98e85bb96954dddf213006857516 SHA256 c328f43351a1f935661d95970730a551d3207d6067260809155efb1a67eab537
+EBUILD glfw-2.7.2.ebuild 1950 RMD160 d5a7eab221e5ab61e44480420a38182a9f8cbcd7 SHA1 fbbf669aa78d5e03947cb530c8e6e7550c28a1e9 SHA256 97070c1a4816c56ab3ade1f3487946adfd7531872c56f5261911b019fc55a184
diff --git a/media-libs/glfw/files/glfw-2.7.2-compile.patch b/media-libs/glfw/files/glfw-2.7.2-compile.patch
new file mode 100644
index 0000000..f212f96
--- /dev/null
+++ b/media-libs/glfw/files/glfw-2.7.2-compile.patch
@@ -0,0 +1,38 @@
+--- compile.sh.old 2011-08-19 11:20:37.927080832 +0200
++++ compile.sh 2011-08-19 11:21:59.910080833 +0200
+@@ -88,7 +88,7 @@
+ case "x`uname 2> /dev/null`" in
+ xLinux)
+ GLFW_LIB_CFLAGS="$GLFW_LIB_CFLAGS -D_GLFW_USE_LINUX_JOYSTICKS"
+- SOFLAGS="-shared -Wl,-soname,libglfw.so"
++ SOFLAGS="-shared -Wl,-soname,libglfw.so.2.7"
+ echo "Linux" 1>&6
+ ;;
+ xDarwin)
+@@ -96,7 +96,7 @@
+ echo "Mac OS X" 1>&6
+ ;;
+ *)
+- SOFLAGS="-shared -soname libglfw.so"
++ SOFLAGS="-shared -soname libglfw.so.2.7"
+ echo "Generic Unix" 1>&6
+ ;;
+ esac
+@@ -627,7 +627,7 @@
+ CFLAGS = $GLFW_BIN_CFLAGS $GLFW_CFLAGS
+
+ LIB = ../lib/x11/libglfw.a
+-SOLIB = ../lib/x11/libglfw.so
++SOLIB = ../lib/x11/libglfw.so.2.7
+ LFLAGS = \$(LIB) $GLFW_LIB_LFLAGS $GLFW_BIN_LFLAGS $GLFW_LFLAGS
+ SO_LFLAGS = \$(SOLIB) $GLFW_BIN_LFLAGS $GLFW_LFLAGS
+
+@@ -652,7 +652,7 @@
+ CFLAGS = $GLFW_BIN_CFLAGS $GLFW_CFLAGS
+
+ LIB = ../lib/x11/libglfw.a
+-SOLIB = ../lib/x11/libglfw.so
++SOLIB = ../lib/x11/libglfw.so.2.7
+ LFLAGS = \$(LIB) $GLFW_LIB_LFLAGS $GLFW_BIN_LFLAGS $GLFW_LFLAGS
+ SO_LFLAGS = \$(SOLIB) $GLFW_BIN_LFLAGS $GLFW_LFLAGS
+
diff --git a/media-libs/glfw/files/glfw-2.7.2-dyn.patch b/media-libs/glfw/files/glfw-2.7.2-dyn.patch
new file mode 100644
index 0000000..e524e6d
--- /dev/null
+++ b/media-libs/glfw/files/glfw-2.7.2-dyn.patch
@@ -0,0 +1,20 @@
+--- lib/x11/Makefile.x11.in.old 2011-08-19 11:14:45.190080831 +0200
++++ lib/x11/Makefile.x11.in 2011-08-19 11:14:08.950080832 +0200
+@@ -8,7 +8,7 @@
+ ##########################################################################
+ # Default: Build GLFW static library
+ ##########################################################################
+-all: libglfw.a libglfw.so
++all: libglfw.a libglfw.so.2.7
+
+
+ ##########################################################################
+@@ -118,7 +118,7 @@
+ ##########################################################################
+ # Rule for building shared library
+ ##########################################################################
+-libglfw.so: $(SHARED_OBJS)
++libglfw.so.2.7: $(SHARED_OBJS)
+ $(CC) $(SOFLAGS) -o $@ $(SHARED_OBJS) $(LFLAGS) $(LIBS)
+
+
diff --git a/media-libs/glfw/glfw-2.7.2.ebuild b/media-libs/glfw/glfw-2.7.2.ebuild
new file mode 100644
index 0000000..3cd434e
--- /dev/null
+++ b/media-libs/glfw/glfw-2.7.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glfw/glfw-2.6.ebuild,v 1.6 2010/09/13 12:09:46 tupone Exp $
+
+EAPI=2
+inherit eutils multilib
+
+DESCRIPTION="The Portable OpenGL FrameWork"
+HOMEPAGE="http://glfw.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+DEPEND="x11-libs/libXrandr
+ virtual/opengl"
+
+S=${WORKDIR}/${P}
+
+src_prepare() {
+ sed -i -e "s:\"docs/:\"/usr/share/doc/${PF}/pdf/:" readme.html || die "sed failed"
+ epatch "${FILESDIR}/${PF}-dyn.patch"
+ epatch "${FILESDIR}/${PF}-compile.patch"
+}
+
+src_configure() {
+ sh compile.sh
+}
+
+src_compile() {
+ emake -C lib/x11 PREFIX=/usr -f Makefile.x11 all libglfw.pc || die "emake failed"
+ if use examples; then
+ emake -C examples -f Makefile.x11 all || die "emake failed"
+ fi
+}
+
+src_install() {
+ dolib.a lib/x11/libglfw.a || die "dolib.a failed"
+ dolib.so lib/x11/libglfw.so.2.7 || die "dolib.so failed"
+ dosym libglfw.so.2.7 /usr/$(get_libdir)/libglfw.so
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins lib/x11/libglfw.pc || die "doins failed"
+ insinto /usr/include/GL
+ doins include/GL/glfw.h || die "doins failed"
+
+ dohtml -r readme.html
+ #insinto /usr/share/doc/${PF}/html/images
+ #doins images/*
+ insinto /usr/share/doc/${PF}/pdf
+ doins docs/*.pdf
+
+ if use examples; then
+ local f
+ local MY_EXAMPLES="boing gears listmodes mipmaps
+ mtbench mthello particles pong3d splitview
+ triangle wave"
+ local MY_PICS="mipmaps.tga pong3d_field.tga pong3d_instr.tga
+ pong3d_menu.tga pong3d_title.tga
+ pong3d_winner1.tga pong3d_winner2.tga"
+
+ insinto /usr/share/doc/${PF}/examples
+
+ doins examples/Makefile.x11
+ for f in $MY_EXAMPLES; do
+ doins examples/${f}.c
+ done
+ for f in $MY_PICS; do
+ doins examples/${f}
+ done
+
+ insopts -m0755
+ for f in $MY_EXAMPLES; do
+ doins examples/${f}
+ done
+ fi
+}
diff --git a/media-libs/luxrays/Manifest b/media-libs/luxrays/Manifest
new file mode 100644
index 0000000..e6809f3
--- /dev/null
+++ b/media-libs/luxrays/Manifest
@@ -0,0 +1 @@
+EBUILD luxrays-9999.ebuild 1085 RMD160 41b74b3e2f585f0637ae11ecdd89ab922e606f55 SHA1 bd4d5ed68ff3a6cae5174fc74fa7fee5b3207f8f SHA256 6a21c60994d1dc8a1bda0652f0399eb79bee6f12ad4e9c5d33e15dd1aae107e4
diff --git a/media-libs/luxrays/luxrays-9999.ebuild b/media-libs/luxrays/luxrays-9999.ebuild
new file mode 100644
index 0000000..23bebad
--- /dev/null
+++ b/media-libs/luxrays/luxrays-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit cmake-utils mercurial flag-o-matic
+#inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Library to accelerate the ray intersection process by using GPUs \
+(this pkg provides only CPU support atm)"
+HOMEPAGE="http://www.luxrender.net"
+EHG_REPO_URI="https://bitbucket.org/luxrender/luxrays"
+#EHG_REVISION="29e1c03a4ae3"
+#SRC_URI="https://bitbucket.org/luxrender/luxrays/get/${EHG_REVISION}.tar.bz2"
+
+#S="${WORKDIR}/luxrender-luxrays-${EHG_REVISION}/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=">=dev-libs/boost-1.43
+ media-libs/freeimage
+ virtual/opengl"
+
+CMAKE_IN_SOURCE_BUILD=1
+
+src_configure() {
+ append-flags "-fPIC -DLUXRAYS_DISABLE_OPENCL"
+ use debug && append-flags -ggdb
+
+ mycmakeargs=( -DLUXRAYS_DISABLE_OPENCL=ON -Wno-dev )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_make luxrays
+}
+
+src_install() {
+ dodoc AUTHORS.txt
+
+ insinto /usr/include
+ doins -r include/luxrays
+
+ dolib.a lib/libluxrays.a
+}
diff --git a/media-libs/opencollada/Manifest b/media-libs/opencollada/Manifest
new file mode 100644
index 0000000..b8a5aeb
--- /dev/null
+++ b/media-libs/opencollada/Manifest
@@ -0,0 +1 @@
+EBUILD opencollada-9999.ebuild 583 RMD160 fb356c38e2ab31f53fb93e4fc3128007e4f4afa9 SHA1 e6aefd54134bcfcb1eb32a6e00e4a0978d14ae48 SHA256 b43152cfb051dd86e906a8a30e355e42a0059b9461de920044cc507c29cc8206
diff --git a/media-libs/opencollada/opencollada-9999.ebuild b/media-libs/opencollada/opencollada-9999.ebuild
new file mode 100644
index 0000000..cbfcc9b
--- /dev/null
+++ b/media-libs/opencollada/opencollada-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils cmake-utils subversion
+
+DESCRIPTION="OpenCOLLADA is a stream based reader and writer library for COLLADA files"
+HOMEPAGE="http://www.opencollada.org/"
+LICENSE="MIT"
+
+ESVN_REPO_URI="http://opencollada.googlecode.com/svn/trunk"
+ESVN_PROJECT="opencollada-trunk"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND=">=dev-libs/libxml2-2.7.8-r1"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake-utils_src_install
+ dobin ${CMAKE_BUILD_DIR}/bin/OpenCOLLADAValidator
+}
diff --git a/media-libs/opensg/Manifest b/media-libs/opensg/Manifest
new file mode 100644
index 0000000..eec2fed
--- /dev/null
+++ b/media-libs/opensg/Manifest
@@ -0,0 +1,5 @@
+AUX opensg-2.0_alpha2284-fix-gdal-png.patch 2161 RMD160 9e0369fdca0591f568218607f50204fe822c861e SHA1 7233c5ecfcf1bb673397c3f848fa8006444c5531 SHA256 a0bf320fe191176007c35d1954d8f9a85e98febf0ccb5600c91f9bbde708b57d
+DIST opensg-2.0_alpha2284.tar.bz2 9746821 RMD160 a46e7e09c7f60a1ec9e1c8bce877cf81d0e246c8 SHA1 af3beac3cbbdf054233ad7a07a0372f6f2033689 SHA256 a96f45d113aa51ff8209a5aa7a7f5e861e4e2776c606f1b9da4b521414dcbb28
+EBUILD opensg-2.0_alpha2284.ebuild 1540 RMD160 2351f3da59b9608b56db66efe0b74cb6fed8d14a SHA1 79cd58a11cde9decd45f5b874494cd680b03ba50 SHA256 6f36cbb060edfbc2b70946d487c59ddae35e36e84ac0e57f757dac92d3aa3f99
+EBUILD opensg-9999.ebuild 3165 RMD160 c2cd296e3154b61d075d5c8f6205cc9689652b3f SHA1 3752e58ea5981a95e3049601dd2e2f2bc713af50 SHA256 4e3114d5c1be9f86e94c2e422516a447cfc8db45cc268a6e8711fc3d13cc54b3
+MISC opensg-9999.ebuild~ 3164 RMD160 ade26c56cff899224511e07a4873294ce93b7841 SHA1 8800fb589c3c62d91acf121812633a12f39ac077 SHA256 d7e53c37620f2e85c88f3230c46ebf6ad374d96d7bdc3acf544ae5c62a3fc324
diff --git a/media-libs/opensg/files/opensg-2.0_alpha2284-fix-gdal-png.patch b/media-libs/opensg/files/opensg-2.0_alpha2284-fix-gdal-png.patch
new file mode 100644
index 0000000..6f9fe7a
--- /dev/null
+++ b/media-libs/opensg/files/opensg-2.0_alpha2284-fix-gdal-png.patch
@@ -0,0 +1,51 @@
+diff -urN opensg-2.0_alpha2284-original/Source/System/Image/FileIO/OSGGDALImageFileType.cpp opensg-2.0_alpha2284/Source/System/Image/FileIO/OSGGDALImageFileType.cpp
+--- opensg-2.0_alpha2284-original/Source/System/Image/FileIO/OSGGDALImageFileType.cpp 2009-11-30 09:59:08.000000000 +0100
++++ opensg-2.0_alpha2284/Source/System/Image/FileIO/OSGGDALImageFileType.cpp 2010-07-28 14:09:40.000000000 +0200
+@@ -48,9 +48,9 @@
+ #include "OSGGeoReferenceAttachment.h"
+
+ #ifdef OSG_WITH_GDAL
+-#include "gdal/gdal_priv.h"
+-#include "gdal/ogr_srs_api.h"
+-#include "gdal/cpl_multiproc.h"
++#include "gdal_priv.h"
++#include "ogr_srs_api.h"
++#include "cpl_multiproc.h"
+ #endif
+
+
+diff -urN opensg-2.0_alpha2284-original/Source/System/Image/FileIO/OSGGDALImageFileType.h opensg-2.0_alpha2284/Source/System/Image/FileIO/OSGGDALImageFileType.h
+--- opensg-2.0_alpha2284-original/Source/System/Image/FileIO/OSGGDALImageFileType.h 2009-11-30 07:49:49.000000000 +0100
++++ opensg-2.0_alpha2284/Source/System/Image/FileIO/OSGGDALImageFileType.h 2010-07-28 14:09:59.000000000 +0200
+@@ -48,8 +48,8 @@
+ #include "boost/shared_ptr.hpp"
+
+ #ifdef OSG_WITH_GDAL
+-#include "gdal/gdal_priv.h"
+-#include "gdal/ogr_srs_api.h"
++#include "gdal_priv.h"
++#include "ogr_srs_api.h"
+ #endif
+
+ OSG_BEGIN_NAMESPACE
+diff -urN opensg-2.0_alpha2284-original/Source/System/Image/FileIO/OSGPNGImageFileType.cpp opensg-2.0_alpha2284/Source/System/Image/FileIO/OSGPNGImageFileType.cpp
+--- opensg-2.0_alpha2284-original/Source/System/Image/FileIO/OSGPNGImageFileType.cpp 2009-10-05 23:40:17.000000000 +0200
++++ opensg-2.0_alpha2284/Source/System/Image/FileIO/OSGPNGImageFileType.cpp 2010-07-28 13:56:14.000000000 +0200
+@@ -206,7 +206,7 @@
+ // Convert < 8 bit to 8 bit
+ if(color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
+ {
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ bit_depth = 8;
+ }
+
+@@ -683,7 +683,7 @@
+ // Convert < 8 bit to 8 bit
+ if(color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
+ {
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ bit_depth = 8;
+ }
+
diff --git a/media-libs/opensg/opensg-2.0_alpha2284.ebuild b/media-libs/opensg/opensg-2.0_alpha2284.ebuild
new file mode 100644
index 0000000..aa14f7c
--- /dev/null
+++ b/media-libs/opensg/opensg-2.0_alpha2284.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="OpenSG is a portable scenegraph system to create realtime graphics programs, e.g. for virtual reality applications."
+HOMEPAGE="http://www.opensg.org/"
+
+SRC_URI="http://vision.ee.ethz.ch/sihaegle/gentoo/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+
+SLOT="2"
+KEYWORDS="~x86 ~amd64"
+
+IUSE="tests doc examples"
+DEPEND="virtual/opengl
+ media-libs/freeglut
+ media-libs/glew
+
+ sys-devel/flex
+ sys-devel/bison
+
+ dev-libs/boost
+ sys-libs/zlib
+ media-libs/freetype
+ media-libs/tiff
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/openexr
+ sci-libs/gdal
+
+ x11-libs/qt-gui:4
+ x11-libs/qt-opengl:4
+
+ sci-libs/vtk
+
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="${DEPEND}"
+
+EPATCH_OPTS="-p1"
+PATCHES=(
+ "${FILESDIR}/${P}-fix-gdal-png.patch"
+)
+
+src_configure() {
+ mycmakeargs=(
+ -DOSG_USE_OSGSUPPORT_LIBS=OFF
+ -DBOOST_ROOT=/usr
+ -DOSG_DOXY_DOC_TYPE=User
+ -DOSGBUILD_EXAMPLES_SIMPLE=ON
+ -DOSGBUILD_EXAMPLES_ADVANCED=ON
+ -DCOLLADA_ROOT_DIR=/opt/collada-dom
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ cd "${CMAKE_BUILD_DIR}"
+ emake Doc || die "building documentation failed"
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use doc; then
+ cd "${CMAKE_BUILD_DIR}"/Doc
+ dohtml -r html/* || die "dohtml failed"
+ fi
+ if use examples; then
+ cd "${CMAKE_BUILD_DIR}"/demos
+ dobin mandelbrot/mandelbrot opengl/quaternion_demo || die "dobin failed"
+ fi
+}
diff --git a/media-libs/opensg/opensg-9999.ebuild b/media-libs/opensg/opensg-9999.ebuild
new file mode 100644
index 0000000..0a7d89e
--- /dev/null
+++ b/media-libs/opensg/opensg-9999.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils cmake-utils git-2
+
+DESCRIPTION="OpenSG is a portable scenegraph system to create realtime graphics programs, e.g. for virtual reality applications."
+HOMEPAGE="http://www.opensg.org/"
+LICENSE="LGPL-2.1"
+
+EGIT_REPO_URI="git://opensg.git.sourceforge.net/gitroot/opensg/opensg"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="tests doc examples"
+DEPEND="virtual/opengl
+ media-libs/freeglut
+ media-libs/glew
+
+ sys-devel/flex
+ sys-devel/bison
+
+ dev-libs/boost
+ sys-libs/zlib
+ media-libs/freetype
+ media-libs/tiff
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/openexr
+ media-libs/collada-dom
+
+ x11-libs/qt-gui:4
+ x11-libs/qt-opengl:4
+
+ doc? ( app-doc/doxygen )"
+# sci-libs/gdal
+#sci-libs/vtk
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ CMAKE_BUILD_TYPE=Release
+ mycmakeargs=(
+ -DOSG_USE_OSGSUPPORT_LIBS=OFF
+ -DBOOST_ROOT=/usr
+ -DOSG_DOXY_DOC_TYPE=User
+ -DOSGBUILD_EXAMPLES_SIMPLE=ON
+ -DOSGBUILD_EXAMPLES_ADVANCED=ON
+ -DCOLLADA_INCLUDE_DIR=/usr/include/collada-dom
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ cd "${CMAKE_BUILD_DIR}"
+ emake Doc || die "building documentation failed"
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use doc; then
+ dohtml -r ${CMAKE_BUILD_DIR}/Doc/html/* || die "dohtml failed"
+ fi
+ if use examples; then
+ exeinto "/usr/share/OpenSG/examples"
+ doexe ${CMAKE_BUILD_DIR}/bin/01hello || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/02move || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/03share || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/04hiertransform || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/05geometry || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/06indexgeometry || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/07multiindexgeometry || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/08materials || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/09traverse || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/10loading || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/11picking || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/deepclone || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/deferredshading || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/fbotexture || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/hiresimage || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/fbotexture || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/hiresimage || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/lights || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/locallights || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/materialsort || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/occlusionculling || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/openglcallback || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/openglslave || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/shadows || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/simplePluginApp || die "dobin failed"
+ doexe ${CMAKE_BUILD_DIR}/bin/sortlastclient || die "dobin failed"
+ fi
+}
diff --git a/media-libs/spacenav/Manifest b/media-libs/spacenav/Manifest
new file mode 100644
index 0000000..dbf1e4d
--- /dev/null
+++ b/media-libs/spacenav/Manifest
@@ -0,0 +1 @@
+EBUILD spacenav-9999.ebuild 1422 RMD160 c5ed080d00cb03b21f38619db0690d1f9336b5eb SHA1 d78216652e5a85a9fbd04ac096e93a2ff28cc7fe SHA256 18acce3bd2c2cfef6b20df9d82ba611fee6289bdd2de9852599f9dc7a6419559
diff --git a/media-libs/spacenav/spacenav-9999.ebuild b/media-libs/spacenav/spacenav-9999.ebuild
new file mode 100644
index 0000000..019e7bf
--- /dev/null
+++ b/media-libs/spacenav/spacenav-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit subversion
+EAPI=3
+
+DESCRIPTION="Spacenavd is a free software replacement user-space driver (daemon), for 3Dconnexion's space-something 6dof input devices."
+HOMEPAGE="http://spacenav.sourceforge.net/"
+ESVN_REPO_URI="https://spacenav.svn.sourceforge.net/svnroot/spacenav/trunk"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ pushd spacenavd
+ sed -i "/CFLAGS =/s/$/ ${CFLAGS}/" Makefile.in
+ sed -i "/DAEMON=/s/\/local\//\//" init_script
+ econf --prefix="${D}/usr" || die "configure spacenavd failed"
+ popd
+ pushd spnavcfg
+ sed -i "/CFLAGS =/s/$/ ${CFLAGS}/" Makefile.in
+ econf --prefix="${D}/usr" || die "configure spnavcfg failed"
+ popd
+ pushd libspnav
+ sed -i "/CFLAGS =/s/$/ ${CFLAGS}/" Makefile.in
+ econf --prefix="${D}/usr" || die "configure libspnav failed"
+ popd
+}
+
+src_compile() {
+ pushd spacenavd
+ emake || die "compiling spacenavd failed"
+ popd
+ pushd spnavcfg
+ emake || die "compiling spnavcfg failed"
+ popd
+ pushd libspnav
+ emake || die "compilinge libspnav failed"
+ popd
+}
+
+src_install() {
+ pushd spacenavd
+ emake install || die "install failed"
+ newinitd init_script ${PN}
+ popd
+ pushd spnavcfg
+ emake install || die "installing spnavcfg failed"
+ popd
+ pushd libspnav
+ emake install || die "installing libspnav failed"
+ popd
+}