summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/skipfish/skipfish-1.10_beta.ebuild')
-rw-r--r--net-analyzer/skipfish/skipfish-1.10_beta.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/skipfish/skipfish-1.10_beta.ebuild b/net-analyzer/skipfish/skipfish-1.10_beta.ebuild
new file mode 100644
index 0000000..f40c572
--- /dev/null
+++ b/net-analyzer/skipfish/skipfish-1.10_beta.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit
+
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Web application security scanner"
+HOMEPAGE="http://code.google.com/p/skipfish/"
+SRC_URI="http://skipfish.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ net-dns/libidn"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ # Change assets path
+ sed -i 's/assets/\/usr\/share\/skipfish\/assets/g' report.c skipfish.c || die "sed failed"
+}
+
+src_install() {
+ dobin skipfish
+
+ insinto /usr/share/${PN}/dictionaries
+ doins dictionaries/*.wl
+ insinto /usr/share/${PN}/assets
+ doins assets/*
+
+ dodoc README dictionaries/README-FIRST ChangeLog
+}
+
+pkg_postinst() {
+ echo
+ elog "See README-FIRST in /usr/share/doc/${P}/ to pick a dictionary and use with -W option:"
+ elog " ${PN} -W /usr/share/${PN}/dictionaries/<dictionary_name>"
+ echo
+}