summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pdfeditor/pdfeditor-5.0.15.ebuild')
-rw-r--r--app-text/pdfeditor/pdfeditor-5.0.15.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/pdfeditor/pdfeditor-5.0.15.ebuild b/app-text/pdfeditor/pdfeditor-5.0.15.ebuild
new file mode 100644
index 0000000..9030bc9
--- /dev/null
+++ b/app-text/pdfeditor/pdfeditor-5.0.15.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+MY_P="master-pdf-editor"
+MY_V=4
+DESCRIPTION="Create, convert and edit PDF and XPS files"
+HOMEPAGE="http://code-industry.net/pdfeditor.php"
+SRC_URI="http://code-industry.net/public/${MY_P}-${PV}_i386.tar.gz"
+
+LICENSE="CodeIndustry"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+QA_PREBUILT="/opt/${PN}/pdfeditor"
+
+DEPEND=">=dev-qt/qtcore-4.8.1:4"
+RDEPEND="${DEPEND}
+ media-gfx/sane-backends"
+
+S=${WORKDIR}/${MY_P}-${MY_V}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+ fperms 755 /opt/${PN}/masterpdfeditor${MY_V}
+ dosym /opt/${PN}/masterpdfeditor${MY_V} /opt/bin/pdfeditor
+}