summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorroot <root@SCU-MED-DSK-47.datys.cu>2010-03-18 18:56:03 -0400
committerroot <root@SCU-MED-DSK-47.datys.cu>2010-03-18 18:56:03 -0400
commit1f215b8bd262f88d0a1629bc10c1acd5ec77e864 (patch)
treef2aff1a884c8d3d5f035e64fa9b3d6f058d15632 /dev-python
downloadrubenqba-1f215b8bd262f88d0a1629bc10c1acd5ec77e864.tar.gz
rubenqba-1f215b8bd262f88d0a1629bc10c1acd5ec77e864.tar.bz2
rubenqba-1f215b8bd262f88d0a1629bc10c1acd5ec77e864.zip
Initial commit
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-bibtex/Manifest4
-rw-r--r--dev-python/python-bibtex/files/python-bibtex-fix-bad-tests.patch28
-rw-r--r--dev-python/python-bibtex/python-bibtex-1.2.4-r1.ebuild28
-rw-r--r--dev-python/python-bibtex/python-bibtex-1.2.4-r1.tar.bz2bin0 -> 1471 bytes
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/python-bibtex/Manifest b/dev-python/python-bibtex/Manifest
new file mode 100644
index 0000000..fad9914
--- /dev/null
+++ b/dev-python/python-bibtex/Manifest
@@ -0,0 +1,4 @@
+AUX python-bibtex-fix-bad-tests.patch 976 RMD160 59626e4f8de6fd4be3465b1954f3406ba066e142 SHA1 9aeb9b56ee0c64ad8869fb67aaa58ff63e497e5d SHA256 c0fa626de3e4ae07209a2843e387a6dd6c378444d0b8b1e0c040bc33bebf3762
+DIST python-bibtex-1.2.4.tar.gz 57057 RMD160 2ba97290b3d7d0ef6614326ba2cab0504026548e SHA1 f5379d40a873fea1f6f148764d62ec66750b3418 SHA256 0df2e9cec2219aa08133972956d97eb9d641ac2e1e6a115fdded122ae18a1f7a
+EBUILD python-bibtex-1.2.4-r1.ebuild 605 RMD160 7b82bc5d2dc660a3bd0a6c38829680237b9b4233 SHA1 64b473a53b70ed008c279a35a4a6f9fbb6e34ca9 SHA256 44c7fa769779e585a61d9038b8718feced0ee24c3c48fe8f3d3bc9882fcd45fa
+MISC python-bibtex-1.2.4-r1.tar.bz2 1471 RMD160 7064d8561f234acb3ddc64ba738d3040f697d49e SHA1 89884dd309056835961cb6de0844aa75b4382387 SHA256 b711ad87f74fa32300507502d7a99e7fe1d4f7e86340afe2180232954879b1fa
diff --git a/dev-python/python-bibtex/files/python-bibtex-fix-bad-tests.patch b/dev-python/python-bibtex/files/python-bibtex-fix-bad-tests.patch
new file mode 100644
index 0000000..a9436e4
--- /dev/null
+++ b/dev-python/python-bibtex/files/python-bibtex-fix-bad-tests.patch
@@ -0,0 +1,28 @@
+--- python-bibtex-1.2.4/testsuite.py 2007-04-23 20:53:35.000000000 +0100
++++ python-bibtex-1.2.4-r1/testsuite.py 2009-07-24 12:39:03.578875571 +0100
+@@ -4,6 +4,7 @@
+
+ import sys, os
+
++ParserError = "ParserError"
+
+ def check_recode ():
+ try:
+@@ -65,7 +66,7 @@
+
+ valid = result.readline ().strip ()
+
+- if obtained != valid:
++ if eval(obtained) != eval(valid):
+ sys.stderr.write ('error: %s: line %d: unexpected result:\n' % (
+ filename, line))
+ sys.stderr.write ('error: %s: line %d: obtained %s\n' % (
+@@ -117,7 +118,7 @@
+
+ valid = result.readline ().strip ()
+
+- if obtained != valid:
++ if eval(obtained) != eval(valid):
+ sys.stderr.write ('error: %s: line %d: unexpected result:\n' % (
+ filename, line))
+ sys.stderr.write ('error: %s: line %d: obtained %s\n' % (
diff --git a/dev-python/python-bibtex/python-bibtex-1.2.4-r1.ebuild b/dev-python/python-bibtex/python-bibtex-1.2.4-r1.ebuild
new file mode 100644
index 0000000..8e4c01f
--- /dev/null
+++ b/dev-python/python-bibtex/python-bibtex-1.2.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+inherit distutils
+
+DESCRIPTION="A Python extension to parse BibTeX files"
+HOMEPAGE="http://pybliographer.org/"
+SRC_URI="mirror://sourceforge/pybliographer/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ia64 ppc x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2
+ >=app-text/recode-3.6-r1"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare(){
+ einfo "Applying patch.."
+ epatch "${FILESDIR}/${PN}-fix-bad-tests.patch"
+}
+
+src_test() {
+ "${python}" setup.py check || die "tests failed"
+}
diff --git a/dev-python/python-bibtex/python-bibtex-1.2.4-r1.tar.bz2 b/dev-python/python-bibtex/python-bibtex-1.2.4-r1.tar.bz2
new file mode 100644
index 0000000..628f19f
--- /dev/null
+++ b/dev-python/python-bibtex/python-bibtex-1.2.4-r1.tar.bz2
Binary files differ