summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygobject/files/pygobject-2.15.4-fix-codegen-location.patch')
-rw-r--r--dev-python/pygobject/files/pygobject-2.15.4-fix-codegen-location.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pygobject/files/pygobject-2.15.4-fix-codegen-location.patch b/dev-python/pygobject/files/pygobject-2.15.4-fix-codegen-location.patch
new file mode 100644
index 0000000..8882cd0
--- /dev/null
+++ b/dev-python/pygobject/files/pygobject-2.15.4-fix-codegen-location.patch
@@ -0,0 +1,50 @@
+---
+ Fix FHS compliance of codegen
+
+ codegen/Makefile.am | 2 +-
+ codegen/pygtk-codegen-2.0.in | 3 ++-
+ pygtk-2.0.pc.in | 2 +-
+ 3 files changed, 4 insertions(+), 3 deletions(-)
+
+--- a/codegen/Makefile.am 2007-11-01 12:20:22.000000000 -0400
++++ b/codegen/Makefile.am 2008-05-28 22:21:04.000000000 -0400
+@@ -2,7 +2,7 @@ PLATFORM_VERSION = 2.0
+
+ bin_SCRIPTS = pygobject-codegen-$(PLATFORM_VERSION)
+
+-codegendir = $(pkgdatadir)/$(PLATFORM_VERSION)/codegen
++codegendir = $(pyexecdir)/gtk-2.0/codegen
+
+ codegen_PYTHON = \
+ __init__.py \
+--- a/codegen/pygobject-codegen-2.0.in 2007-11-01 12:20:22.000000000 -0400
++++ b/codegen/pygobject-codegen-2.0.in 2008-05-28 22:24:38.000000000 -0400
+@@ -1,9 +1,10 @@
+ #!/bin/sh
+
+ prefix=@prefix@
++exec_prefix=@exec_prefix@
+ datarootdir=@datarootdir@
+ datadir=@datadir@
+-codegendir=${datadir}/pygobject/2.0/codegen
++codegendir=@pyexecdir@/gtk-2.0/codegen
+
+ PYTHONPATH=$codegendir
+ export PYTHONPATH
+--- a/pygobject-2.0.pc.in 2007-11-01 12:20:22.000000000 -0400
++++ b/pygobject-2.0.pc.in 2008-05-28 22:21:04.000000000 -0400
+@@ -4,6 +4,7 @@
+ datarootdir=@datarootdir@
+ datadir=@datadir@
+ libdir=@libdir@
++pyexecdir=@pyexecdir@
+
+ # you can use the --variable=pygtkincludedir argument to
+ # pkg-config to get this value. You might want to use this to
+@@ -12,5 +12,5 @@
+ defsdir=${datadir}/pygobject/2.0/defs
+-codegendir=${datadir}/pygobject/2.0/codegen
++codegendir=${pyexecdir}/gtk-2.0/codegen
+
+ Name: PyGObject
+ Description: Python bindings for GObject