aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSardem FF7 <sardemff7.pub@gmail.com>2010-12-21 21:53:53 +0100
committerSardem FF7 <sardemff7.pub@gmail.com>2010-12-21 21:53:53 +0100
commit76f3b195c9b280a7e80a4c8de80166660ec64a5d (patch)
tree6af19954f0ecbc81a31524d31ba1080077741a0d /net-libs
parentDepend on mozilla overlay for nspr/nss stuff (diff)
downloadsardemff7-76f3b195c9b280a7e80a4c8de80166660ec64a5d.tar.gz
sardemff7-76f3b195c9b280a7e80a4c8de80166660ec64a5d.tar.bz2
sardemff7-76f3b195c9b280a7e80a4c8de80166660ec64a5d.zip
Add some patches and apply 'old' ones
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/xulrunner/Manifest3
-rw-r--r--net-libs/xulrunner/files/gentoo-specific.patch89
-rw-r--r--net-libs/xulrunner/xulrunner-9999.ebuild7
3 files changed, 98 insertions, 1 deletions
diff --git a/net-libs/xulrunner/Manifest b/net-libs/xulrunner/Manifest
index 8daa6a5..bb0c20d 100644
--- a/net-libs/xulrunner/Manifest
+++ b/net-libs/xulrunner/Manifest
@@ -1,4 +1,5 @@
AUX Xlib-const-XAtomNames.patch 914 RMD160 ab1fca929f638ab8b50ec5fad18f726377bdec30 SHA1 236e4614a5964b1c5cdaa0b3019ce231d20f4297 SHA256 d02549a05a6db8227880fb825c4182919b78ef80c57c751e656e18a847d739a1
+AUX gentoo-specific.patch 2957 RMD160 684dc2176769a56c2b1c206b59f999cd44d99c45 SHA1 35ff8e325e45b5384a404a4f99b12fdba9d5e0f3 SHA256 23d981e48a5308dd11ce2fc831071d138d54717bff9cb546dfc5467b0f4204c7
AUX libnotify-0.7-fix.patch 1209 RMD160 07615cde8fb0dbd9876635d0b437943df3f4879c SHA1 16caf17a571b4ede370fc20ffffc87179afd3cd3 SHA256 80dbd0906b45cd42b0fda0ec6fa48daf04cb5f85a14e164287565ffa4e486642
AUX xulrunner-default-prefs.js 709 RMD160 a4d062f75c17552545267ec3fe2f6b54073dafbd SHA1 580128e9edf8021fdbbca2c91abf63cb83bab2c7 SHA256 e6850b0a22f7d3889b49ec4a79a3c4d3d077edd98c8f0ffdc26e30bc70bb4b09
-EBUILD xulrunner-9999.ebuild 7058 RMD160 2aa8701504eec987ca55e769ea921bfcb71a5010 SHA1 68ab93fca7a213ca877d1a74e29ee0a74ed3707f SHA256 d697bcad7ba86e206cff74eb31383231e2daa721357f0914d4224fde994a9c08
+EBUILD xulrunner-9999.ebuild 7252 RMD160 57ff2edf1fc912fa7919928aaca375f896d2060a SHA1 050582135cd1363eab432e760722bc57a4909346 SHA256 91ab7dbf105a2d42856b430633eee3730663f437bf7e7eebb9eb9249a65fdefc
diff --git a/net-libs/xulrunner/files/gentoo-specific.patch b/net-libs/xulrunner/files/gentoo-specific.patch
new file mode 100644
index 0000000..c3a61ca
--- /dev/null
+++ b/net-libs/xulrunner/files/gentoo-specific.patch
@@ -0,0 +1,89 @@
+* gre conf location is a bit hardcoded unfortunately :(
+
+--- extensions/java/xpcom/interfaces/org/mozilla/xpcom/Mozilla.java
++++ extensions/java/xpcom/interfaces/org/mozilla/xpcom/Mozilla.java
+@@ -470,8 +470,8 @@
+
+ final String greUserConfFile = ".gre.config";
+ final String greUserConfDir = ".gre.d";
+- final String greConfPath = "/etc/gre.conf";
+- final String greConfDir = "/etc/gre.d";
++ final String greConfPath = "@GENTOO_PORTAGE_EPREFIX@/etc/gre.conf";
++ final String greConfDir = "@GENTOO_PORTAGE_EPREFIX@/etc/gre.d";
+
+ env = System.getProperty("user.home");
+ if (env != null) {
+--- xpcom/build/nsXPCOMPrivate.h
++++ xpcom/build/nsXPCOMPrivate.h
+@@ -245,8 +245,8 @@
+ #endif
+
+ #define GRE_CONF_NAME ".gre.config"
+-#define GRE_CONF_PATH "/etc/gre.conf"
+-#define GRE_CONF_DIR "/etc/gre.d"
++#define GRE_CONF_PATH "@GENTOO_PORTAGE_EPREFIX@/etc/gre.conf"
++#define GRE_CONF_DIR "@GENTOO_PORTAGE_EPREFIX@/etc/gre.d"
+ #define GRE_USER_CONF_DIR ".gre.d"
+ #endif
+
+--- xulrunner/installer/Makefile.in
++++ xulrunner/installer/Makefile.in
+@@ -73,7 +73,7 @@
+
+ ifndef SKIP_GRE_REGISTRATION
+ # to register xulrunner per-user, override this with $HOME/.gre.d
+-regdir = /etc/gre.d
++regdir = @sysconfdir@/gre.d
+
+ install:: $(MOZILLA_VERSION).system.conf
+ $(NSINSTALL) -D $(DESTDIR)$(regdir)
+--- xulrunner/app/nsRegisterGREUnix.cpp
++++ xulrunner/app/nsRegisterGREUnix.cpp
+@@ -130,7 +130,7 @@
+
+ nsresult rv;
+
+- char root[MAXPATHLEN] = "/etc/gre.d";
++ char root[MAXPATHLEN] = "@GENTOO_PORTAGE_EPREFIX@/etc/gre.d";
+
+ if (!aRegisterGlobally) {
+ char *home = PR_GetEnv("HOME");
+@@ -222,7 +222,7 @@
+ {
+ nsresult rv;
+
+- char root[MAXPATHLEN] = "/etc/gre.d";
++ char root[MAXPATHLEN] = "@GENTOO_PORTAGE_EPREFIX@/etc/gre.d";
+
+ if (!aRegisterGlobally) {
+ char *home = PR_GetEnv("HOME");
+--- browser/components/preferences/advanced.js 2009-11-24 22:12:34.000000000 -0600
++++ browser/components/preferences/advanced.js-new 2009-12-02 10:26:18.378458863 -0600
+@@ -408,7 +408,7 @@
+ var enabledPref = document.getElementById("app.update.enabled");
+ var enableAppUpdate = document.getElementById("enableAppUpdate");
+
+- enableAppUpdate.disabled = !aus.canCheckForUpdates || enabledPref.locked;
++ enableAppUpdate.disabled = true;
+ },
+
+ /**
+@@ -423,8 +423,7 @@
+ var updateModeLabel = document.getElementById("updateModeLabel");
+ var updateMode = document.getElementById("updateMode");
+
+- var disable = enabledPref.locked || !enabledPref.value ||
+- autoPref.locked;
++ var disable = true;
+ updateModeLabel.disabled = updateMode.disabled = disable;
+ },
+
+@@ -440,8 +439,7 @@
+
+ var warnIncompatible = document.getElementById("warnIncompatible");
+
+- var disable = enabledPref.locked || !enabledPref.value || autoPref.locked ||
+- !autoPref.value || modePref.locked;
++ var disable = true;
+ warnIncompatible.disabled = disable;
+ },
diff --git a/net-libs/xulrunner/xulrunner-9999.ebuild b/net-libs/xulrunner/xulrunner-9999.ebuild
index 7b84bd9..f1ea823 100644
--- a/net-libs/xulrunner/xulrunner-9999.ebuild
+++ b/net-libs/xulrunner/xulrunner-9999.ebuild
@@ -57,11 +57,18 @@ pkg_setup() {
}
src_prepare() {
+ # Gentoo specific stuff
+ epatch "${FILESDIR}"/gentoo-specific.patch
+
eprefixify \
extensions/java/xpcom/interfaces/org/mozilla/xpcom/Mozilla.java \
xpcom/build/nsXPCOMPrivate.h \
xulrunner/installer/Makefile.in \
xulrunner/app/nsRegisterGREUnix.cpp
+
+ # Up-to-date geek stuff
+ epatch "${FILESDIR}"/libnotify-0.7-fix.patch
+ epatch "${FILESDIR}"/Xlib-const-XAtomNames.patch
# fix double symbols due to double -ljemalloc
sed -i -e '/^LIBS += $(JEMALLOC_LIBS)/s/^/#/' \