aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSardem FF7 <sardemff7.pub@gmail.com>2011-01-11 17:37:11 +0100
committerSardem FF7 <sardemff7.pub@gmail.com>2011-01-11 17:37:11 +0100
commitd3d99897dfff709c6b082357500e733652b6b8a1 (patch)
treead578c064adc9ba2693c6736658288893d1d277c /net-libs
parentUpdate system-cairo patch as in Mozilla overlay (thanks) (diff)
downloadsardemff7-d3d99897dfff709c6b082357500e733652b6b8a1.tar.gz
sardemff7-d3d99897dfff709c6b082357500e733652b6b8a1.tar.bz2
sardemff7-d3d99897dfff709c6b082357500e733652b6b8a1.zip
Follow Mozilla overlay updates
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/xulrunner/Manifest4
-rw-r--r--net-libs/xulrunner/files/system-cairo-fixup.patch106
-rw-r--r--net-libs/xulrunner/xulrunner-9999.ebuild2
3 files changed, 62 insertions, 50 deletions
diff --git a/net-libs/xulrunner/Manifest b/net-libs/xulrunner/Manifest
index 5e1f465..f85ecea 100644
--- a/net-libs/xulrunner/Manifest
+++ b/net-libs/xulrunner/Manifest
@@ -1,5 +1,5 @@
AUX gentoo-specific.patch 2957 RMD160 684dc2176769a56c2b1c206b59f999cd44d99c45 SHA1 35ff8e325e45b5384a404a4f99b12fdba9d5e0f3 SHA256 23d981e48a5308dd11ce2fc831071d138d54717bff9cb546dfc5467b0f4204c7
AUX libnotify-0.7-fix.patch 1209 RMD160 07615cde8fb0dbd9876635d0b437943df3f4879c SHA1 16caf17a571b4ede370fc20ffffc87179afd3cd3 SHA256 80dbd0906b45cd42b0fda0ec6fa48daf04cb5f85a14e164287565ffa4e486642
-AUX system-cairo-fixup.patch 3763 RMD160 303487222bbe92b3051dcb69cb39a2240bab02d8 SHA1 f2141dbff6ba0677265c20a9ccb3401d2709d268 SHA256 a35041cfe74bcbfde3f7baeb8a0cf30ad759519194478a24e13198801011decc
+AUX system-cairo-fixup.patch 3146 RMD160 c1e15592ab30360cb1b528e174674ace83cf60d1 SHA1 4f5687a84d3a7687242a34a713b28272788feb5e SHA256 376292d4be0f0b3e760a6d30c1cce240a176774cd5a4f62e01ebd7d30f16bf56
AUX xulrunner-default-prefs.js 709 RMD160 a4d062f75c17552545267ec3fe2f6b54073dafbd SHA1 580128e9edf8021fdbbca2c91abf63cb83bab2c7 SHA256 e6850b0a22f7d3889b49ec4a79a3c4d3d077edd98c8f0ffdc26e30bc70bb4b09
-EBUILD xulrunner-9999.ebuild 7369 RMD160 5b5c53ccff326ccd256a3600fd7249552432276d SHA1 bfa88bc833a225080e2de215a08aeca21e602912 SHA256 0b95283d650abbe79ae2a53d615ea0008140c8511e28d51f1c3a53f3214b3a76
+EBUILD xulrunner-9999.ebuild 7373 RMD160 daadbf8d75e196fd624aed51874b1add47408160 SHA1 515125e835f07430e83d3b264d8ca1b433ef3df1 SHA256 0b4e9616f65c2323849509ee63c4d516aa940953cdd6e4fae6e2ebf5d56ad08a
diff --git a/net-libs/xulrunner/files/system-cairo-fixup.patch b/net-libs/xulrunner/files/system-cairo-fixup.patch
index 20288c2..b66d504 100644
--- a/net-libs/xulrunner/files/system-cairo-fixup.patch
+++ b/net-libs/xulrunner/files/system-cairo-fixup.patch
@@ -1,6 +1,27 @@
-work around new features that are not avaliable in system-cairo on linux
-(romaxa's patch with modification for return failure with <gcc-4.5)
+work around new features that are not avaliable in system-cairo on linux
+(romaxa's original patch with modifications to use cairo-tee)
+diff --git a/config/system-headers b/config/system-headers
+--- a/config/system-headers
++++ b/config/system-headers
+@@ -81,16 +81,17 @@ pixman.h
+ cairo.h
+ cairo-atsui.h
+ cairo-beos.h
+ cairo-ft.h
+ cairo-glitz.h
+ cairo-os2.h
+ cairo-pdf.h
+ cairo-ps.h
++cairo-tee.h
+ cairo-quartz.h
+ cairo-win32.h
+ cairo-xlib.h
+ cairo-xlib-xrender.h
+ cairo-directfb.h
+ cairo-qpainter.h
+ #endif
+ dfiff.h
diff --git a/gfx/thebes/gfxASurface.cpp b/gfx/thebes/gfxASurface.cpp
--- a/gfx/thebes/gfxASurface.cpp
+++ b/gfx/thebes/gfxASurface.cpp
@@ -49,7 +70,7 @@ diff --git a/gfx/thebes/gfxASurface.cpp b/gfx/thebes/gfxASurface.cpp
+#ifdef MOZ_TREE_CAIRO
return cairo_surface_get_subpixel_antialiasing(mSurface) == CAIRO_SUBPIXEL_ANTIALIASING_ENABLED;
+#else
-+ return PR_FALSE;
++ return PR_TRUE;
+#endif
}
@@ -62,55 +83,46 @@ diff --git a/gfx/thebes/gfxASurface.cpp b/gfx/thebes/gfxASurface.cpp
diff --git a/gfx/thebes/gfxTeeSurface.cpp b/gfx/thebes/gfxTeeSurface.cpp
--- a/gfx/thebes/gfxTeeSurface.cpp
+++ b/gfx/thebes/gfxTeeSurface.cpp
-@@ -41,37 +41,46 @@
+@@ -32,17 +32,21 @@
+ * and other provisions required by the GPL or the LGPL. If you do not delete
+ * the provisions above, a recipient may use your version of this file under
+ * the terms of any one of the MPL, the GPL or the LGPL.
+ *
+ * ***** END LICENSE BLOCK ***** */
- gfxTeeSurface::gfxTeeSurface(cairo_surface_t *csurf)
- {
- Init(csurf, PR_TRUE);
- }
+ #include "gfxTeeSurface.h"
- gfxTeeSurface::gfxTeeSurface(gfxASurface **aSurfaces, PRInt32 aSurfaceCount)
- {
+#ifdef MOZ_TREE_CAIRO
- NS_ASSERTION(aSurfaceCount > 0, "Must have a least one surface");
- cairo_surface_t *csurf = cairo_tee_surface_create(aSurfaces[0]->CairoSurface());
- Init(csurf, PR_FALSE);
-
- for (PRInt32 i = 1; i < aSurfaceCount; ++i) {
- cairo_tee_surface_add(csurf, aSurfaces[i]->CairoSurface());
- }
+ #include "cairo.h"
++#else
++#include "cairo-tee.h"
+#endif
- }
--const gfxIntSize
--gfxTeeSurface::GetSize() const
--{
-- nsRefPtr<gfxASurface> master = Wrap(cairo_tee_surface_index(mSurface, 0));
-- return master->GetSize();
-+const gfxIntSize
-+gfxTeeSurface::GetSize() const
-+{
-+#ifdef MOZ_TREE_CAIRO
-+ nsRefPtr<gfxASurface> master = Wrap(cairo_tee_surface_index(mSurface, 0));
-+ return master->GetSize();
-+#else
-+ gfxIntSize a;
-+ return a;
-+#endif
+ gfxTeeSurface::gfxTeeSurface(cairo_surface_t *csurf)
+ {
+ Init(csurf, PR_TRUE);
}
- void
- gfxTeeSurface::GetSurfaces(nsTArray<nsRefPtr<gfxASurface> >* aSurfaces)
+ gfxTeeSurface::gfxTeeSurface(gfxASurface **aSurfaces, PRInt32 aSurfaceCount)
{
-+#ifdef MOZ_TREE_CAIRO
- for (PRInt32 i = 0; ; ++i) {
- cairo_surface_t *csurf = cairo_tee_surface_index(mSurface, i);
- if (cairo_surface_status(csurf))
- break;
- nsRefPtr<gfxASurface> *elem = aSurfaces->AppendElement();
- if (!elem)
- return;
- *elem = Wrap(csurf);
- }
-+#endif
- }
+diff --git a/js/src/config/system-headers b/js/src/config/system-headers
+--- a/js/src/config/system-headers
++++ b/js/src/config/system-headers
+@@ -82,16 +82,17 @@ cairo.h
+ cairo-atsui.h
+ cairo-beos.h
+ cairo-ft.h
+ cairo-glitz.h
+ cairo-os2.h
+ cairo-pdf.h
+ cairo-ps.h
+ cairo-quartz.h
++cairo-tee.h
+ cairo-win32.h
+ cairo-xlib.h
+ cairo-xlib-xrender.h
+ cairo-directfb.h
+ cairo-qpainter.h
+ #endif
+ dfiff.h
+ exception
diff --git a/net-libs/xulrunner/xulrunner-9999.ebuild b/net-libs/xulrunner/xulrunner-9999.ebuild
index 304dbb8..dd91f2c 100644
--- a/net-libs/xulrunner/xulrunner-9999.ebuild
+++ b/net-libs/xulrunner/xulrunner-9999.ebuild
@@ -26,7 +26,7 @@ RDEPEND="
>=dev-libs/nss-3.12.8_beta1
>=dev-libs/nspr-4.8.5
>=app-text/hunspell-1.2
- >=x11-libs/cairo-1.10[X]
+ >=x11-libs/cairo-1.10[X,tee]
>=dev-libs/libevent-1.4.7
x11-libs/pango[X]
media-libs/libpng[apng]