summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Solano Gómez <gentoo@sattvik.com>2022-04-10 15:18:17 -0500
committerDaniel Solano Gómez <gentoo@sattvik.com>2022-04-10 15:18:41 -0500
commit922fd62f2cf3491d664ca8f947f0c3aba7cc00dd (patch)
tree6e9e0f38889655c90d67411f8bfe2f2443a46381 /media-video
parentRemove old revision (diff)
downloadsattvik-922fd62f2cf3491d664ca8f947f0c3aba7cc00dd.tar.gz
sattvik-922fd62f2cf3491d664ca8f947f0c3aba7cc00dd.tar.bz2
sattvik-922fd62f2cf3491d664ca8f947f0c3aba7cc00dd.zip
media-video/streamdeck-ui: Add 2.0.3
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Daniel Solano Gómez <gentoo@sattvik.com>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/streamdeck-ui/Manifest2
-rw-r--r--media-video/streamdeck-ui/streamdeck-ui-2.0.3.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/media-video/streamdeck-ui/Manifest b/media-video/streamdeck-ui/Manifest
index 7d99488..96182db 100644
--- a/media-video/streamdeck-ui/Manifest
+++ b/media-video/streamdeck-ui/Manifest
@@ -1,3 +1,5 @@
DIST streamdeck-ui-1.1.2.tar.gz 2573270 BLAKE2B a49638f1a9a62e893888f4c0e9a79cb90fee1a08132091fae5f511e4d52843c30eaf94806952aef77123633a4c913b1e54119f6092f8f0fcf8a548366514c014 SHA512 26c431f4c9a552d9dc79af9387b465d50a41de09d169a2d7642aef4c21e34cd6097981437c7b7a9f24b574fafa385cd4469f0a6a25a1de32b3b5a113f6a3f581
+DIST streamdeck-ui-2.0.3.tar.gz 3892318 BLAKE2B 43706341d656dba75a56e8976545f5716253d1256799c8acb329b649001463e92c6100316d03785f8f8fbd83fde15bd36c85e4d3d84acfdff492a74515378a86 SHA512 3bb88c5067d9a63020f53437f24cbe1e6026b937bec87ac54e93ba0399970714f7fd0a36f3e693e92c52665c574b556686f8df49426cbaca911e5d493e3126bf
EBUILD streamdeck-ui-1.1.2.ebuild 1186 BLAKE2B a0c0b3c024a834d43bc53d7f026f84433a83e1b7dbfa6665d0c70480f6acbd3f69c188c9d9b4ec859f3c7128790259b8e2e7f810ff3e592d1b61d629dc668e76 SHA512 560cf2a7ba1f3a006afcc74cbadb088b7fa6deaf55d88da1ddb30e0c148631f14905aab9aef8386c20d2311ed4b3819cb279190ca07f2879db7b27dc54ce2655
+EBUILD streamdeck-ui-2.0.3.ebuild 1359 BLAKE2B 0893e5928aa7c67f33a04fb16775e8b4f3a6939d0c38e0e92fdc3b1d218ae803c3c3470f1b47dab32e674784a0dc06f1328ab9dd8bb7e5dc711c59a3ef93f1c0 SHA512 9e677387c07887859042c93297ef8e6e917ba65b449e1bf64e577c7cc8d3dcc50de8f3a571f4296c50e2a88bfe3ea1177ec6a3857ca038bef9231531ff21ed14
MISC metadata.xml 340 BLAKE2B 0821dca2b83a5da9b0d87daaa2b3e835439a508a41eaf2adf173a3cca666fa4fa1b49ba0d571f0193c09004ef7fe42565ed75e29946ea08b2a8a5e2bd0835911 SHA512 2d31fac58ef66d6634c562565fa0d17b1c565b3c96fa75f98f86250ea206b7a98856e34ae4915087d6441c3efcd10e9775181b5609aafe5772dd2a863e88d2ea
diff --git a/media-video/streamdeck-ui/streamdeck-ui-2.0.3.ebuild b/media-video/streamdeck-ui/streamdeck-ui-2.0.3.ebuild
new file mode 100644
index 0000000..02239dc
--- /dev/null
+++ b/media-video/streamdeck-ui/streamdeck-ui-2.0.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="A Linux compatible UI for the Elgato Stream Deck"
+HOMEPAGE="https://github.com/timothycrosley/streamdeck-ui"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/timothycrosley/streamdeck-ui.git"
+else
+ SRC_URI="https://github.com/timothycrosley/streamdeck-ui/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ #S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/filetype[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pynput[${PYTHON_USEDEP}]
+ dev-python/pyside2[${PYTHON_USEDEP},designer]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-gfx/cairosvg[${PYTHON_USEDEP}]
+ media-libs/elgato-streamdeck[${PYTHON_USEDEP}]
+ dev-libs/hidapi
+ "
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i "s#os.path.dirname(os.path.abspath(__file__))#'/usr/share/streamdeck-ui'#" streamdeck_ui/config.py
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ insinto /usr/share/streamdeck-ui
+ doins streamdeck_ui/logo.png
+ doins -r streamdeck_ui/fonts
+ distutils-r1_src_install
+}