aboutsummaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorStuart Shelton <stuart@shelton.me>2013-12-08 12:47:23 +0000
committerStuart Shelton <stuart@shelton.me>2013-12-08 12:47:23 +0000
commitb0cd2acb1e6f322864e0e2b81a3371781cc8c309 (patch)
tree1f64332c23f690363fd45938582a7f6d3e9be109 /dev-db
parentAdd www-apps/rpi-monitor-2.5.1 (diff)
downloadsrcshelton-b0cd2acb1e6f322864e0e2b81a3371781cc8c309.tar.gz
srcshelton-b0cd2acb1e6f322864e0e2b81a3371781cc8c309.tar.bz2
srcshelton-b0cd2acb1e6f322864e0e2b81a3371781cc8c309.zip
Add dev-db/libdbi-drivers-0.9.0 with added '--with-dbi-libdir' configure option
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/libdbi-drivers/Manifest3
-rw-r--r--dev-db/libdbi-drivers/files/libdbi-drivers-0.9.0-doc-build-fix.patch22
-rw-r--r--dev-db/libdbi-drivers/libdbi-drivers-0.9.0.ebuild85
3 files changed, 110 insertions, 0 deletions
diff --git a/dev-db/libdbi-drivers/Manifest b/dev-db/libdbi-drivers/Manifest
new file mode 100644
index 00000000..4a24f0f5
--- /dev/null
+++ b/dev-db/libdbi-drivers/Manifest
@@ -0,0 +1,3 @@
+AUX libdbi-drivers-0.9.0-doc-build-fix.patch 694 SHA256 e1750eaeff253efee00c13765184028f10129f2367522861c7b526f0cf825d39 SHA512 0ff58a08909327db91ebd0dfad7ac88ebb17156bbb7afc8bfc8a3711fee37708a7ad715ed50b5085cdd15d3cdb5c06de3a0779694104fb6332a1e9c2f51f5b0e WHIRLPOOL 9dbc00f61263332c26196190928573e6d44c650fd0b538d8d256782a83c98174cb7bfe0d23292527d8fd5a456a30a5eb10113fba78226eb0a31a51a6ce46d038
+DIST libdbi-drivers-0.9.0.tar.gz 1829864 SHA256 43d2eacd573a4faff296fa925dd97fbf2aedbf1ae35c6263478210c61004c854 SHA512 f4d3aaa71014697c53012a10bf9f0af398bcf5ee5872af165f8f43a682d2fb3045a9172ffea0e068dcbfcad52494878c037d8d90fadfaf176936e42f7f1e85c1 WHIRLPOOL 6ed745a19afe4b6b5d51f7730ca9698e645fac529051aeaae886938e063f8fcd3357c2f24913a5428db4847de1de38e931acc1e3e20aeed3e6d71b6877a104d6
+EBUILD libdbi-drivers-0.9.0.ebuild 2117 SHA256 1ac5e6cceef7a4a0c44f789a29cdaa5b7dec93277c87d74c245bf23ba8de77cf SHA512 322a1c4153f10291dd0818b0e91f31f9a4796ec3e6d6638ffb83f4a9e997c5bfadc796b20604659963c17cc2490f6a18cea4e50c880bbaef0ad3ba0a72d42bf0 WHIRLPOOL b29a4fd8754ec3fa9100584ec9b803e0984f8a3af73023e611bfb5207b768114fb3a22a0db11a6d407306a3fa8613ff39f8661c58be6ffbc2d6a50fa8cc5560b
diff --git a/dev-db/libdbi-drivers/files/libdbi-drivers-0.9.0-doc-build-fix.patch b/dev-db/libdbi-drivers/files/libdbi-drivers-0.9.0-doc-build-fix.patch
new file mode 100644
index 00000000..d0d74221
--- /dev/null
+++ b/dev-db/libdbi-drivers/files/libdbi-drivers-0.9.0-doc-build-fix.patch
@@ -0,0 +1,22 @@
+diff -Nuar libdbi-drivers-0.9.0.orig/configure.in libdbi-drivers-0.9.0/configure.in
+--- libdbi-drivers-0.9.0.orig/configure.in 2013-03-11 23:41:05.000000000 +0000
++++ libdbi-drivers-0.9.0/configure.in 2013-08-29 15:52:57.632105403 +0000
+@@ -165,14 +165,13 @@
+ dnl See whether to build the docs
+ dnl ==============================
+
+-ac_docs="YES"
++ac_docs="yes"
+ AC_ARG_ENABLE(docs,
+ [ --disable-docs do not build and install the documentation.],
+- [ if test "$enable_docs" = "no"; then
+- ac_docs="NO"
+- fi])
++ [ ac_docs="$enableval" ],
++ [ ac_docs="no" ])
+
+-if test "$ac_docs" = "YES"; then
++if test "$ac_docs" = "yes"; then
+ docs_subdirs="doc"
+ else
+ docs_subdirs=""
diff --git a/dev-db/libdbi-drivers/libdbi-drivers-0.9.0.ebuild b/dev-db/libdbi-drivers/libdbi-drivers-0.9.0.ebuild
new file mode 100644
index 00000000..99018d01
--- /dev/null
+++ b/dev-db/libdbi-drivers/libdbi-drivers-0.9.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/libdbi-drivers-0.9.0.ebuild,v 1.6 2013/11/27 18:51:43 maekke Exp $
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="The libdbi-drivers project maintains drivers for libdbi."
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${P}/${P}.tar.gz"
+HOMEPAGE="http://libdbi-drivers.sourceforge.net/"
+LICENSE="LGPL-2.1"
+
+IUSE="bindist doc firebird mysql oci8 postgres +sqlite static-libs"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-fbsd"
+SLOT=0
+
+RDEPEND="
+ >=dev-db/libdbi-0.9.0
+ firebird? ( dev-db/firebird )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( dev-db/sqlite:3 )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-text/openjade )
+"
+
+REQUIRED_USE="
+ firebird? ( !bindist )
+ || ( mysql postgres sqlite firebird oci8 )
+"
+
+DOCS="AUTHORS ChangeLog NEWS README README.osx TODO"
+
+pkg_setup() {
+ use oci8 && [[ -z "${ORACLE_HOME}" ]] && die "\$ORACLE_HOME is not set!"
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.9.0-doc-build-fix.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf="--with-dbi-libdir=${EROOT}/usr/$(get_libdir)"
+ # WARNING: the configure script does NOT work correctly
+ # --without-$driver does NOT work
+ # so do NOT use `use_with...`
+ # Future additions:
+ # msql
+ # freetds
+ # ingres
+ # db2
+ use mysql && myconf+=" --with-mysql"
+ use postgres && myconf+=" --with-pgsql"
+ use sqlite && myconf+=" --with-sqlite3"
+ use firebird && myconf+=" --with-firebird"
+ if use oci8; then
+ [[ -z "${ORACLE_HOME}" ]] && die "\$ORACLE_HOME is not set!"
+ myconf+=" --with-oracle-dir=${ORACLE_HOME} --with-oracle"
+ fi
+
+ econf \
+ $(use_enable doc docs) \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_test() {
+ if [[ -z "${WANT_INTERACTIVE_TESTS}" ]]; then
+ ewarn "Tests disabled due to interactivity."
+ ewarn "Run with WANT_INTERACTIVE_TESTS=1 if you want them."
+ return 0
+ fi
+ einfo "Running interactive tests"
+ emake check
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+}