aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/mongodb/mongodb-3.2.16.ebuild')
-rw-r--r--dev-db/mongodb/mongodb-3.2.16.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-db/mongodb/mongodb-3.2.16.ebuild b/dev-db/mongodb/mongodb-3.2.16.ebuild
index 228a7cd2..b0a569b9 100644
--- a/dev-db/mongodb/mongodb-3.2.16.ebuild
+++ b/dev-db/mongodb/mongodb-3.2.16.ebuild
@@ -125,7 +125,9 @@ src_compile() {
# respect mongoDB upstream's basic recommendations
# see bug #536688 and #526114
if ! use debug; then
- filter-flags '-m*'
+ use arm || filter-flags '-m*' # ... but not on ARM, where flags such as -march/-mtune, -mfpu,
+ # and -mfloat-abi, etc. are *essential* in order to produce
+ # working code.
filter-flags '-O?'
fi
escons "${scons_opts[@]}" core tools || die