summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNoel Darlow <mail@mcgruff.plus.com>2012-05-08 21:42:31 +0100
committerNoel Darlow <mail@mcgruff.plus.com>2012-05-08 21:42:31 +0100
commitf770434d9fbddd03491d911bb5adb4fb4e01b809 (patch)
treecd611ef81b84d21edc693a47b0826ded9276da5b /app-admin/gentool
parentfirst commit (diff)
downloadunderlay-f770434d9fbddd03491d911bb5adb4fb4e01b809.tar.gz
underlay-f770434d9fbddd03491d911bb5adb4fb4e01b809.tar.bz2
underlay-f770434d9fbddd03491d911bb5adb4fb4e01b809.zip
ardour-irc beta ebuild
Diffstat (limited to 'app-admin/gentool')
-rw-r--r--app-admin/gentool/ChangeLog0
-rw-r--r--app-admin/gentool/gentool-0.1.3.ebuild47
-rw-r--r--app-admin/gentool/metadata.xml10
3 files changed, 57 insertions, 0 deletions
diff --git a/app-admin/gentool/ChangeLog b/app-admin/gentool/ChangeLog
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/app-admin/gentool/ChangeLog
diff --git a/app-admin/gentool/gentool-0.1.3.ebuild b/app-admin/gentool/gentool-0.1.3.ebuild
new file mode 100644
index 0000000..560ed64
--- /dev/null
+++ b/app-admin/gentool/gentool-0.1.3.ebuild
@@ -0,0 +1,47 @@
+EAPI=2
+inherit eutils
+DESCRIPTION="gentoo system management"
+HOMEPAGE=""
+SRC_URI=""
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE=""
+
+#DEPEND=">=app-misc/bashfun-0.1.2
+# layman"
+RDEPEND="net-misc/rsync
+ sys-boot/grub"
+
+src_install() {
+ #config protect?
+ dodir '/opt/gem' || die "out of cheese error 1"
+ #insinto '/opt/gem' || die "out of cheese error 2"
+
+ ls -avlh ${FILESDIR}'/'${PVR}'/opt/gem/'
+ cp -ar ${FILESDIR}'/'${PVR}'/opt/gem/'* ${D}'/opt/gem/' || die "out of cheese error 3"
+ dodir '/etc/gem' || die "out of cheese error 4"
+ insinto '/etc/gem' || die "out of cheese error 5"
+ doins ${FILESDIR}'/'${PVR}'/etc/gem/config.sh' || die "out of cheese error 6"
+ doenvd ${FILESDIR}'/'${PVR}'/etc/env.d/99gem-env' || die "out of cheese error 7"
+}
+
+pkg_postinst() {
+ if [ ! -f /opt/bin/gem ]
+ then
+ cd /opt/bin
+ ln -s /opt/gem/bin/gem.sh gem
+ fi
+
+ path_minus_opt_bin=`echo $PATH | sed 's~/opt/bin:~~g'`
+ if [ $PATH = $path_minus_opt_bin ]
+ then
+ ewarn
+ ewarn 'OMG! /opt/bin is not in your $PATH!'
+ ewarn '(gem is installed at /opt/bin/gem)'
+ ewarn
+ fi
+ ewarn
+ ewarn 'you may want to edit /etc/gem/config.sh now - just follow instructions in the file'
+ ewarn
+}
diff --git a/app-admin/gentool/metadata.xml b/app-admin/gentool/metadata.xml
new file mode 100644
index 0000000..19b6c00
--- /dev/null
+++ b/app-admin/gentool/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>underlay</herd>
+<maintainer>
+ <email>gem@aperiplus.co.uk</email>
+ <description>gentoo manager</description>
+</maintainer>
+<longdescription>Gem is a portage wrapper with extra commands to help manage software updates. Prior to an emerge, you can quickly back up OS and apps with `gem sync` and, if it all goes wrong, revert back to the old package versions very quickly with no downtime (the backups are bootable). This is particularly important in a rolling release distro like gentoo. Other functions include `gem kernel` which automates most of the work of building a new kernel.</longdescription>
+</pkgmetadata>