summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNoel Darlow <mail@mcgruff.plus.com>2012-05-17 19:40:04 +0100
committerNoel Darlow <mail@mcgruff.plus.com>2012-05-17 19:40:04 +0100
commit69d1a09afa3e41f7adaa9303353985b2ed98c282 (patch)
tree91c022b805df3f9587df2b10be3c46c2b9e8c607 /media-sound/openoctave-midi/.svn/text-base/openoctave-midi-9999.ebuild.svn-base
parentfixing ardour-irc ebuild (diff)
downloadunderlay-69d1a09afa3e41f7adaa9303353985b2ed98c282.tar.gz
underlay-69d1a09afa3e41f7adaa9303353985b2ed98c282.tar.bz2
underlay-69d1a09afa3e41f7adaa9303353985b2ed98c282.zip
first try for ebuilds of bashfun and gentool - corrections to follow...
Diffstat (limited to 'media-sound/openoctave-midi/.svn/text-base/openoctave-midi-9999.ebuild.svn-base')
-rw-r--r--media-sound/openoctave-midi/.svn/text-base/openoctave-midi-9999.ebuild.svn-base69
1 files changed, 69 insertions, 0 deletions
diff --git a/media-sound/openoctave-midi/.svn/text-base/openoctave-midi-9999.ebuild.svn-base b/media-sound/openoctave-midi/.svn/text-base/openoctave-midi-9999.ebuild.svn-base
new file mode 100644
index 0000000..4db1085
--- /dev/null
+++ b/media-sound/openoctave-midi/.svn/text-base/openoctave-midi-9999.ebuild.svn-base
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:$
+
+inherit cmake-utils eutils exteutils git #kde qt3
+
+# TODO: this ebuild needs some kde/qt3 eclass work -- will not function
+
+DESCRIPTION="OpenOctave MIDI sequencer"
+HOMEPAGE="http://www.openoctave.org"
+SRC_URI=""
+
+EGIT_REPO_URI="git://68.150.160.199:9418/var/git/openoctave.git"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-*"
+IUSE="debug lilypond export kde gnome"
+
+RDEPEND="lilypond? ( media-sound/lilypond
+ || ( kde? ( kde-base/kghostview ) gnome? ( app-text/evince ) app-text/ggv ) )
+ export? ( || ( kde-base/kdialog kde-base/kdebase )
+ dev-perl/XML-Twig
+ media-libs/libsndfile )
+ >=media-libs/ladspa-sdk-1.0
+ >=media-libs/ladspa-cmt-1.14
+ || ( x11-libs/libX11 virtual/x11 )
+ >=media-libs/liblrdf-0.3
+ >=sci-libs/fftw-3.0.0
+ >=media-libs/liblo-0.7
+ x11-libs/libXtst"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.15
+ >=dev-util/cmake-2.4.2"
+
+#need-kde 3.1
+#need-qt 3
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup(){
+ if ! use export && \
+ ! ( has_all-pkg "media-libs/libsndfile dev-perl/XML-Twig" && \
+ has_any-pkg "kde-base/kdialog kde-base/kdebase" ) ;then
+ ewarn "you won't be able to use the project-package-manager"
+ ewarn "please remerge with USE=\"export\"" && sleep 3
+ fi
+
+ if ! use lilypond && ! ( has_version "media-sound/lilypond" && has_any-pkg "app-text/ggv kde-base/kghostview app-text/evince" ) ;then
+ ewarn "lilypond preview won't work."
+ ewarn "If you want this feature please remerge USE=\"lilypond\""
+ fi
+}
+
+src_unpack() {
+ git_src_unpack
+}
+
+src_compile() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable debug DEBUG)
+ $(cmake-utils_use_enable debug FULLDBG)"
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ cd "${S}"
+ dodoc AUTHORS README TRANSLATORS
+}