summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/ardour-irc/ardour-irc-0.2.6.ebuild')
-rw-r--r--media-sound/ardour-irc/ardour-irc-0.2.6.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-sound/ardour-irc/ardour-irc-0.2.6.ebuild b/media-sound/ardour-irc/ardour-irc-0.2.6.ebuild
new file mode 100644
index 0000000..4ac57ff
--- /dev/null
+++ b/media-sound/ardour-irc/ardour-irc-0.2.6.ebuild
@@ -0,0 +1,53 @@
+EAPI=2
+DESCRIPTION="IR remote control for Ardour"
+HOMEPAGE=""
+SRC_URI="http://www.aperiplus.co.uk/downloads/src/${P}.tar.bz2"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ app-misc/lirc
+ media-libs/liblo
+ dev-perl/Audio-Ardour-Irc
+ dev-perl/Lirc-Client
+ dev-perl/Class-Accessor
+ dev-perl/File-Path-Expand"
+
+DEPEND="${RDEPEND}"
+
+confdir=/etc/ardour-irc/
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_install() {
+ insinto /usr/bin/ || die "out of cheese error 0"
+ doins ${S}"/usr/bin/aircd" || die "out of cheese error 1"
+ dodir $confdir || die "out of cheese error 2"
+ insinto $confdir || die "out of cheese error 3"
+ doins ${S}${confdir}"lirc.conf" || die "out of cheese error 4"
+ doins ${S}${confdir}"lirc.conf-vdomate" || die "out of cheese error 5"
+}
+
+# /usr/portage/distfiles/svn-src/ardour/2.0-ongoing/libs/ardour/osc.cc
+
+pkg_postinst() {
+ chmod +x /usr/bin/aircd
+ elog ""
+ elog "(1) See http://en.gentoo-wiki.com/wiki/LIRC for info on setting up LIRC."
+ elog ""
+ elog "(2) You need to create a valid "${confdir}"lirc.conf for your remote."
+ elog " Instructions are in the file."
+ elog ""
+ elog "(3) OSC is not enabled by default in Ardour - see menu: Options/Misc Options."
+ elog ""
+ elog "(4) Start the Ardour-Irc daemon from the command line:"
+ elog ""
+ elog " $ aircd"
+ elog ""
+ elog " ...Ardour will now be able to hear commands from your remote."
+ elog ""
+}