aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Martins <leonardo@venidera.com>2012-03-27 18:55:31 -0300
committerLeonardo Martins <leonardo@venidera.com>2012-03-27 18:55:31 -0300
commit4cf1fab456aedece52208c1c5b44cc0950efc8d7 (patch)
treee6936b80e6007b31b9a366dddf97274fc7da94f7 /app-admin
parentFixed dev-util/vmc ebuild header (diff)
downloadvenidera-4cf1fab456aedece52208c1c5b44cc0950efc8d7.tar.gz
venidera-4cf1fab456aedece52208c1c5b44cc0950efc8d7.tar.bz2
venidera-4cf1fab456aedece52208c1c5b44cc0950efc8d7.zip
Moved portage tree one level up
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/euca2ools/ChangeLog0
-rw-r--r--app-admin/euca2ools/euca2ools-1.3.1.ebuild68
2 files changed, 68 insertions, 0 deletions
diff --git a/app-admin/euca2ools/ChangeLog b/app-admin/euca2ools/ChangeLog
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/app-admin/euca2ools/ChangeLog
diff --git a/app-admin/euca2ools/euca2ools-1.3.1.ebuild b/app-admin/euca2ools/euca2ools-1.3.1.ebuild
new file mode 100644
index 0000000..28270b1
--- /dev/null
+++ b/app-admin/euca2ools/euca2ools-1.3.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+#EAPI=0
+
+inherit distutils
+
+DESCRIPTION="Command-line tools for interacting with Amazon EC2 and S3 API-compatible Web services using the REST/Query API"
+HOMEPAGE="http://open.eucalyptus.com"
+SRC_URI="http://open.eucalyptus.com/sites/all/modules/pubdlcnt/pubdlcnt.php?file=http://eucalyptussoftware.com/downloads/releases/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc64"
+IUSE=""
+DEPEND=">=dev-python/boto-1.9d
+ >=dev-lang/python-2.5
+ >=dev-python/m2crypto-0.19.1"
+
+RDEPEND="${DEPEND}"
+
+DOCS="${S}/COPYING
+ ${S}/CHANGELOG
+ ${S}/README
+ ${S}/INSTALL"
+
+src_compile() {
+ emake build || die "emake failed"
+}
+
+src_install() {
+ cd "${S}/euca2ools"
+ distutils_src_install
+ cd "${S}/bin"
+ for tool in *; do
+ newbin ${tool} ${tool}
+ done
+
+ # Install the manpages
+ if [[ -d ${S}/man ]]; then
+ doman ${S}/man/* || die "doman"
+ fi
+}
+
+pkg_postinst(){
+ einfo ""
+ einfo " Euca2ools use cryptographic credentials for authentication. Two
+ types of credentials are issued by EC2- and S3-compatible services: x509
+ certificates and keys. While some commands only require the latter, it is
+ best to always specify both types of credentials."
+
+ einfo ""
+ einfo " Furthermore, unless the front end Web services reside on
+ 'localhost', the URLs of the EC2- and S3-compatible service endpoints must
+ also be specified."
+ einfo ""
+ einfo "If you are running Euca2ools against Eucalyptus, sourcing the
+ \"eucarc\" file that is included as part of the credentials zip-file that
+ you downloaded from the Eucalyptus Web interface should be enough to set up
+ all of the above variables correctly."
+ einfo ""
+ einfo "For more information please refer to the:"
+ einfo " * --help option of the individual commands,"
+ einfo " * check the man pages for each command,"
+ einfo " * consult the local documentation at /usr/share/doc/$P,"
+ einfo " *consult http://open.eucalyptus.com/wiki/Documentation."
+ einfo ""
+}