summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2012-07-02 03:47:52 +0000
committerRyan Hill <dirtyepic@gentoo.org>2012-07-02 03:47:52 +0000
commitc2f683120af5955227f47d663c46b0f02dc55b29 (patch)
tree9eacefc9d76504f5a997a00903b3fadffc0408ce /app-editors/wxhexeditor/wxhexeditor-0.20.ebuild
parentPer request from Bug 396253, took over maintainership of media-video/makemkv.... (diff)
downloadgentoo-2-c2f683120af5955227f47d663c46b0f02dc55b29.tar.gz
gentoo-2-c2f683120af5955227f47d663c46b0f02dc55b29.tar.bz2
gentoo-2-c2f683120af5955227f47d663c46b0f02dc55b29.zip
Version bump, bug #407161. Remove old.
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/wxhexeditor/wxhexeditor-0.20.ebuild')
-rw-r--r--app-editors/wxhexeditor/wxhexeditor-0.20.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-editors/wxhexeditor/wxhexeditor-0.20.ebuild b/app-editors/wxhexeditor/wxhexeditor-0.20.ebuild
new file mode 100644
index 000000000000..0e12813473b0
--- /dev/null
+++ b/app-editors/wxhexeditor/wxhexeditor-0.20.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/wxhexeditor/wxhexeditor-0.20.ebuild,v 1.1 2012/07/02 03:47:52 dirtyepic Exp $
+
+EAPI="4"
+WX_GTK_VER="2.8"
+
+inherit eutils toolchain-funcs wxwidgets
+
+MY_PN="wxHexEditor"
+
+DESCRIPTION="A cross-platform hex editor designed specially for large files."
+HOMEPAGE="http://wxhexeditor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-v${PV}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-crypt/mhash
+ dev-libs/udis86
+ x11-libs/wxGTK:2.8[X]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+pkg_pretend() {
+ tc-has-openmp \
+ || die "${PN} uses OpenMP libraries. Please use an OpenMP-capable compiler."
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}