summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-12 22:53:33 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-12 22:53:33 +0000
commit2343508d7ddfa07198a7f51f0c17eff72e509f30 (patch)
treedcc82e97989248606b4979a62cb99f40fcf7fe38 /app-emulation
parentCompile against latest libpng (diff)
downloadgentoo-2-2343508d7ddfa07198a7f51f0c17eff72e509f30.tar.gz
gentoo-2-2343508d7ddfa07198a7f51f0c17eff72e509f30.tar.bz2
gentoo-2-2343508d7ddfa07198a7f51f0c17eff72e509f30.zip
Compile against newest libpng
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/zsnes/ChangeLog8
-rw-r--r--app-emulation/zsnes/files/digest-zsnes-1.337-r11
-rw-r--r--app-emulation/zsnes/zsnes-1.337-r1.ebuild35
3 files changed, 43 insertions, 1 deletions
diff --git a/app-emulation/zsnes/ChangeLog b/app-emulation/zsnes/ChangeLog
index b4a610455068..1ca2ea46e32a 100644
--- a/app-emulation/zsnes/ChangeLog
+++ b/app-emulation/zsnes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/zsnes
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/zsnes/ChangeLog,v 1.1 2002/02/01 21:53:01 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/zsnes/ChangeLog,v 1.2 2002/04/12 22:53:33 seemant Exp $
+
+*zsnes-1.337-r1 (12 Apr 2002)
+
+ 12 Apr 2002; Seemant Kulleen <seemant@gentoo.org> zsnes-1.337-r1.ebuild :
+
+ Compile against newest libpng
*zsnes-1.337 (1 Feb 2002)
diff --git a/app-emulation/zsnes/files/digest-zsnes-1.337-r1 b/app-emulation/zsnes/files/digest-zsnes-1.337-r1
new file mode 100644
index 000000000000..503d02e6ea11
--- /dev/null
+++ b/app-emulation/zsnes/files/digest-zsnes-1.337-r1
@@ -0,0 +1 @@
+MD5 092740f7ee0e3fbf92016a45f0a0df8b zsnes1337src.tar.gz 911599
diff --git a/app-emulation/zsnes/zsnes-1.337-r1.ebuild b/app-emulation/zsnes/zsnes-1.337-r1.ebuild
new file mode 100644
index 000000000000..57cbdd30ef38
--- /dev/null
+++ b/app-emulation/zsnes/zsnes-1.337-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/zsnes/zsnes-1.337-r1.ebuild,v 1.1 2002/04/12 22:53:33 seemant Exp $
+# Don't attempt to introduce $CFLAGS usage, docs say result will be slower.
+
+S=${WORKDIR}/${P}
+DESCRIPTION="zsnes is an excellent snes (super nintendo) emulator"
+SRC_URI="http://prdownloads.sourceforge.net/zsnes/zsnes1337src.tar.gz"
+HOMEPAGE="http://www.zsnes.com/"
+
+RDEPEND="opengl? ( virtual/opengl )
+ virtual/x11
+ >=media-libs/libsdl-1.2.0
+ sys-libs/zlib
+ media-libs/libpng"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/nasm-0.98"
+
+
+src_compile() {
+ cd ${S}/src
+ use opengl || myconf="--without-opengl"
+ ./configure --prefix=/usr --host=${CHOST} $myconf || die
+ make || die
+}
+src_install () {
+ cd ${S}/src
+ into /usr
+ dobin zsnes
+ doman linux/zsnes.man
+ cd ${S}
+ dodoc *.txt linux/*
+}