summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-05-10 05:47:53 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-05-10 05:47:53 +0000
commitfc8e54ed9ded7455502a4b67e4da17c846e1c812 (patch)
tree745f7e0a1bc75d7eec4cfe9537d2907fd4f8268c /app-text/bogosort
parentVersion bump. (diff)
downloadgentoo-2-fc8e54ed9ded7455502a4b67e4da17c846e1c812.tar.gz
gentoo-2-fc8e54ed9ded7455502a4b67e4da17c846e1c812.tar.bz2
gentoo-2-fc8e54ed9ded7455502a4b67e4da17c846e1c812.zip
Fix inherit, bump to eapi 5
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-text/bogosort')
-rw-r--r--app-text/bogosort/ChangeLog11
-rw-r--r--app-text/bogosort/bogosort-0.4.2-r1.ebuild35
-rw-r--r--app-text/bogosort/bogosort-0.4.2.ebuild6
3 files changed, 46 insertions, 6 deletions
diff --git a/app-text/bogosort/ChangeLog b/app-text/bogosort/ChangeLog
index 240edfd2002f..fc0833875616 100644
--- a/app-text/bogosort/ChangeLog
+++ b/app-text/bogosort/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/bogosort
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bogosort/ChangeLog,v 1.18 2011/02/06 05:36:52 leio Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/bogosort/ChangeLog,v 1.19 2013/05/10 05:47:53 patrick Exp $
+
+*bogosort-0.4.2-r1 (10 May 2013)
+
+ 10 May 2013; Patrick Lauer <patrick@gentoo.org> +bogosort-0.4.2-r1.ebuild,
+ bogosort-0.4.2.ebuild:
+ Fix inherit, bump to eapi 5
06 Feb 2011; Mart Raudsepp <leio@gentoo.org> bogosort-0.4.2.ebuild:
Drop to ~mips
@@ -59,4 +65,3 @@
14 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> +metadata.xml,
+bogosort-0.4.2.ebuild:
New package
-
diff --git a/app-text/bogosort/bogosort-0.4.2-r1.ebuild b/app-text/bogosort/bogosort-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..b1c2c1d3a177
--- /dev/null
+++ b/app-text/bogosort/bogosort-0.4.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/bogosort/bogosort-0.4.2-r1.ebuild,v 1.1 2013/05/10 05:47:53 patrick Exp $
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A file sorting program which uses the bogosort algorithm"
+HOMEPAGE="http://www.lysator.liu.se/~qha/bogosort/"
+SRC_URI="ftp://ulrik.haugen.se/pub/unix/bogosort/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/xmalloc.patch \
+ "${FILESDIR}"/${P}-glibc-2.10.patch
+}
+
+src_configure() {
+ tc-export CC
+ econf || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README NEWS ChangeLog AUTHORS || die
+}
diff --git a/app-text/bogosort/bogosort-0.4.2.ebuild b/app-text/bogosort/bogosort-0.4.2.ebuild
index 316297c09230..bfe36c1bd4c4 100644
--- a/app-text/bogosort/bogosort-0.4.2.ebuild
+++ b/app-text/bogosort/bogosort-0.4.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bogosort/bogosort-0.4.2.ebuild,v 1.15 2011/02/06 05:36:52 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bogosort/bogosort-0.4.2.ebuild,v 1.16 2013/05/10 05:47:53 patrick Exp $
-inherit libtool eutils toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="A file sorting program which uses the bogosort algorithm"
HOMEPAGE="http://www.lysator.liu.se/~qha/bogosort/"