summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-09-12 17:44:27 +0000
committerPacho Ramos <pacho@gentoo.org>2010-09-12 17:44:27 +0000
commit8056f60eb642b9d91f254ad49ab6762effbcedc7 (patch)
tree9fd86afe10d763d1d848f9c153c83c575c74bb6c /dev-dotnet
parentDelete older ebuild. (diff)
downloadgentoo-2-8056f60eb642b9d91f254ad49ab6762effbcedc7.tar.gz
gentoo-2-8056f60eb642b9d91f254ad49ab6762effbcedc7.tar.bz2
gentoo-2-8056f60eb642b9d91f254ad49ab6762effbcedc7.zip
Version bump and new maintainer.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/pe-format/ChangeLog11
-rw-r--r--dev-dotnet/pe-format/metadata.xml10
-rw-r--r--dev-dotnet/pe-format/pe-format-2.0.3.ebuild25
3 files changed, 42 insertions, 4 deletions
diff --git a/dev-dotnet/pe-format/ChangeLog b/dev-dotnet/pe-format/ChangeLog
index 438ac731090c..3b03787f17ae 100644
--- a/dev-dotnet/pe-format/ChangeLog
+++ b/dev-dotnet/pe-format/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-dotnet/pe-format
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/ChangeLog,v 1.16 2010/09/12 04:27:06 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/ChangeLog,v 1.17 2010/09/12 17:44:27 pacho Exp $
+
+*pe-format-2.0.3 (12 Sep 2010)
+
+ 12 Sep 2010; Pacho Ramos <pacho@gentoo.org> +pe-format-2.0.3.ebuild,
+ metadata.xml:
+ Version bump with a new upstream, new proxy maintainer and fixing old bugs
+ #246456, #29795 (for support more exe files), #294749 (stop using bashisms
+ and adapt script to openrc), #321233 (pe-format2 is now pe-format). Really
+ thanks a lot to Michał Górny for taking care of this package.
12 Sep 2010; Joseph Jezak <josejx@gentoo.org> pe-format-1.ebuild:
Marked ppc for bug #327279.
diff --git a/dev-dotnet/pe-format/metadata.xml b/dev-dotnet/pe-format/metadata.xml
index 9500449acf14..7330c0e25aa3 100644
--- a/dev-dotnet/pe-format/metadata.xml
+++ b/dev-dotnet/pe-format/metadata.xml
@@ -1,7 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>dotnet</herd>
- <longdescription lang="en">
- </longdescription>
+<herd>dotnet</herd>
+<maintainer>
+ <email>gentoo@mgorny.alt.pl</email>
+ <name>Michał Górny</name>
+ <description>Proxy maintainer, please CC him in bug reports and
+ assign to dotnet.</description>
+</maintainer>
</pkgmetadata>
diff --git a/dev-dotnet/pe-format/pe-format-2.0.3.ebuild b/dev-dotnet/pe-format/pe-format-2.0.3.ebuild
new file mode 100644
index 000000000000..a4d57d556bee
--- /dev/null
+++ b/dev-dotnet/pe-format/pe-format-2.0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/pe-format-2.0.3.ebuild,v 1.1 2010/09/12 17:44:27 pacho Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Intelligent PE executable wrapper for binfmt_misc"
+HOMEPAGE="http://github.com/mgorny/pe-format2/"
+SRC_URI="http://github.com/downloads/mgorny/${PN}2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="!sys-apps/pe-format2"
+
+src_compile() {
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ emake ginstall || die
+}