summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-03-30 06:32:33 +0000
committerIan Delaney <idella4@gentoo.org>2014-03-30 06:32:33 +0000
commit00f5d174a5f2b6094f6bc0f0f3409152efa018d7 (patch)
treed74948a062e3885d3cb3189db052cc6e4f4cd511 /dev-python/stevedore/stevedore-0.12.ebuild
parentNew package by me. (diff)
downloadgentoo-2-00f5d174a5f2b6094f6bc0f0f3409152efa018d7.tar.gz
gentoo-2-00f5d174a5f2b6094f6bc0f0f3409152efa018d7.tar.bz2
gentoo-2-00f5d174a5f2b6094f6bc0f0f3409152efa018d7.zip
Drop pypy2_0 support due to lack of its support in pbr, update deps, drop old.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/stevedore/stevedore-0.12.ebuild')
-rw-r--r--dev-python/stevedore/stevedore-0.12.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/stevedore/stevedore-0.12.ebuild b/dev-python/stevedore/stevedore-0.12.ebuild
deleted file mode 100644
index afa0c0eac99a..000000000000
--- a/dev-python/stevedore/stevedore-0.12.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-0.12.ebuild,v 1.2 2013/11/12 06:06:51 prometheanfire Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3} pypy2_0 )
-
-inherit distutils-r1
-
-DESCRIPTION="Manage dynamic plugins for Python applications"
-HOMEPAGE="https://github.com/dreamhost/stevedore"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- virtual/python-argparse[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
- <dev-python/pbr-1.0[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/flake8[$(python_gen_usedep python{2_7,3_2,3_3})] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/pillow[$(python_gen_usedep python{2_7,3_2,3_3})] )"
-
-python_compile_all() {
- if use doc; then
- mkdir docs/source/_build || die
- sphinx-build -b html -c docs/source docs/source/ docs/source/_build
- fi
-}
-
-python_test() {
- nosetests -d --with-coverage --cover-inclusive --cover-package stevedore \
- || die "Tests failed under ${EPYTHON}"
- flake8 stevedore setup.py || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/source/_build/. )
- distutils-r1_python_install_all
-}