summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-03-30 06:32:33 +0000
committerIan Delaney <idella4@gentoo.org>2014-03-30 06:32:33 +0000
commit00f5d174a5f2b6094f6bc0f0f3409152efa018d7 (patch)
treed74948a062e3885d3cb3189db052cc6e4f4cd511 /dev-python/stevedore
parentNew package by me. (diff)
downloadgentoo-2-00f5d174a5f2b6094f6bc0f0f3409152efa018d7.tar.gz
gentoo-2-00f5d174a5f2b6094f6bc0f0f3409152efa018d7.tar.bz2
gentoo-2-00f5d174a5f2b6094f6bc0f0f3409152efa018d7.zip
Drop pypy2_0 support due to lack of its support in pbr, update deps, drop old.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/stevedore')
-rw-r--r--dev-python/stevedore/ChangeLog4
-rw-r--r--dev-python/stevedore/stevedore-0.10.ebuild43
-rw-r--r--dev-python/stevedore/stevedore-0.11.ebuild43
-rw-r--r--dev-python/stevedore/stevedore-0.12.ebuild46
-rw-r--r--dev-python/stevedore/stevedore-0.14.1.ebuild9
-rw-r--r--dev-python/stevedore/stevedore-0.15.ebuild9
6 files changed, 10 insertions, 144 deletions
diff --git a/dev-python/stevedore/ChangeLog b/dev-python/stevedore/ChangeLog
index 272013440653..abd0db5c44cd 100644
--- a/dev-python/stevedore/ChangeLog
+++ b/dev-python/stevedore/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for dev-python/stevedore
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/ChangeLog,v 1.14 2014/03/30 04:29:19 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/ChangeLog,v 1.15 2014/03/30 06:32:33 idella4 Exp $
*stevedore-0.15 (30 Mar 2014)
@@ -42,7 +42,7 @@
Stable for amd64, wrt bug #450086
16 Jun 2013; Ian Delaney <idella4@gentoo.org> stevedore-0.9.1.ebuild:
- correct setuotools in deps wrt Bug #473278
+ correct setuptools in deps wrt Bug #473278
*stevedore-0.9.1 (14 Jun 2013)
diff --git a/dev-python/stevedore/stevedore-0.10.ebuild b/dev-python/stevedore/stevedore-0.10.ebuild
deleted file mode 100644
index 65b4bceebaa5..000000000000
--- a/dev-python/stevedore/stevedore-0.10.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-0.10.ebuild,v 1.1 2013/08/08 06:30:09 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3} pypy2_0 )
-
-inherit distutils-r1
-
-DESCRIPTION="Manage dynamic plugins for Python applications"
-HOMEPAGE="https://github.com/dreamhost/stevedore"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/flake8[$(python_gen_usedep python{2_7,3_2,3_3})] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/pillow[$(python_gen_usedep python{2_7,3_2,3_3})] )"
-
-python_compile_all() {
- if use doc; then
- mkdir docs/source/_build || die
- sphinx-build -b html -c docs/source docs/source/ docs/source/_build
- fi
-}
-
-python_test() {
- nosetests -d --with-coverage --cover-inclusive --cover-package stevedore \
- || die "Tests failed under ${EPYTHON}"
- flake8 stevedore setup.py || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/source/_build/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/stevedore/stevedore-0.11.ebuild b/dev-python/stevedore/stevedore-0.11.ebuild
deleted file mode 100644
index 38e268c421bf..000000000000
--- a/dev-python/stevedore/stevedore-0.11.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-0.11.ebuild,v 1.1 2013/08/29 20:23:21 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3} pypy2_0 )
-
-inherit distutils-r1
-
-DESCRIPTION="Manage dynamic plugins for Python applications"
-HOMEPAGE="https://github.com/dreamhost/stevedore"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/flake8[$(python_gen_usedep python{2_7,3_2,3_3})] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/pillow[$(python_gen_usedep python{2_7,3_2,3_3})] )"
-
-python_compile_all() {
- if use doc; then
- mkdir docs/source/_build || die
- sphinx-build -b html -c docs/source docs/source/ docs/source/_build
- fi
-}
-
-python_test() {
- nosetests -d --with-coverage --cover-inclusive --cover-package stevedore \
- || die "Tests failed under ${EPYTHON}"
- flake8 stevedore setup.py || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/source/_build/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/stevedore/stevedore-0.12.ebuild b/dev-python/stevedore/stevedore-0.12.ebuild
deleted file mode 100644
index afa0c0eac99a..000000000000
--- a/dev-python/stevedore/stevedore-0.12.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-0.12.ebuild,v 1.2 2013/11/12 06:06:51 prometheanfire Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3} pypy2_0 )
-
-inherit distutils-r1
-
-DESCRIPTION="Manage dynamic plugins for Python applications"
-HOMEPAGE="https://github.com/dreamhost/stevedore"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- virtual/python-argparse[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
- <dev-python/pbr-1.0[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/flake8[$(python_gen_usedep python{2_7,3_2,3_3})] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/pillow[$(python_gen_usedep python{2_7,3_2,3_3})] )"
-
-python_compile_all() {
- if use doc; then
- mkdir docs/source/_build || die
- sphinx-build -b html -c docs/source docs/source/ docs/source/_build
- fi
-}
-
-python_test() {
- nosetests -d --with-coverage --cover-inclusive --cover-package stevedore \
- || die "Tests failed under ${EPYTHON}"
- flake8 stevedore setup.py || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/source/_build/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/stevedore/stevedore-0.14.1.ebuild b/dev-python/stevedore/stevedore-0.14.1.ebuild
index 57aac5dbbb9f..63f113d5e3e9 100644
--- a/dev-python/stevedore/stevedore-0.14.1.ebuild
+++ b/dev-python/stevedore/stevedore-0.14.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-0.14.1.ebuild,v 1.1 2014/03/01 02:13:24 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-0.14.1.ebuild,v 1.2 2014/03/30 06:32:33 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3} pypy2_0 )
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
inherit distutils-r1
@@ -22,10 +22,9 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
<dev-python/pbr-1.0[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/flake8[$(python_gen_usedep python{2_7,3_2,3_3})] )
+ dev-python/coverage[${PYTHON_USEDEP}] )
doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/pillow[$(python_gen_usedep python{2_7,3_2,3_3})] )"
+ dev-python/pillow[${PYTHON_USEDEP}] )"
python_compile_all() {
if use doc; then
diff --git a/dev-python/stevedore/stevedore-0.15.ebuild b/dev-python/stevedore/stevedore-0.15.ebuild
index cfd3f0b3e96f..217917151595 100644
--- a/dev-python/stevedore/stevedore-0.15.ebuild
+++ b/dev-python/stevedore/stevedore-0.15.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-0.15.ebuild,v 1.1 2014/03/30 04:29:19 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-0.15.ebuild,v 1.2 2014/03/30 06:32:33 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3} pypy2_0 )
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
inherit distutils-r1
@@ -22,10 +22,9 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
<dev-python/pbr-1.0[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/flake8[$(python_gen_usedep python{2_7,3_2,3_3})] )
+ dev-python/coverage[${PYTHON_USEDEP}] )
doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/pillow[$(python_gen_usedep python{2_7,3_2,3_3})] )"
+ dev-python/pillow[${PYTHON_USEDEP}] )"
python_compile_all() {
if use doc; then