summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-01-22 17:23:31 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-01-22 17:23:31 +0000
commitb9c789b2d83fe9b17a950a7a642ccb9816f27cf3 (patch)
treebba0b81c1c2afbd7976a66bde0573da44da3a9f5 /games-board
parentStable for x86, wrt bug #446232 (diff)
downloadgentoo-2-b9c789b2d83fe9b17a950a7a642ccb9816f27cf3.tar.gz
gentoo-2-b9c789b2d83fe9b17a950a7a642ccb9816f27cf3.tar.bz2
gentoo-2-b9c789b2d83fe9b17a950a7a642ccb9816f27cf3.zip
EAPI-bump, respect cflags wrt #453430
(Portage version: 2.2.0_alpha158/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/xmille/ChangeLog9
-rw-r--r--games-board/xmille/xmille-2.0-r2.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/games-board/xmille/ChangeLog b/games-board/xmille/ChangeLog
index f384a826a12b..bfee33290080 100644
--- a/games-board/xmille/ChangeLog
+++ b/games-board/xmille/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/xmille
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/xmille/ChangeLog,v 1.11 2010/10/08 09:29:37 tupone Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/xmille/ChangeLog,v 1.12 2013/01/22 17:23:31 hasufell Exp $
+
+*xmille-2.0-r2 (22 Jan 2013)
+
+ 22 Jan 2013; Julian Ospald <hasufell@gentoo.org> +xmille-2.0-r2.ebuild:
+ EAPI-bump, respect cflags wrt #453430
08 Oct 2010; Tupone Alfredo <tupone@gentoo.org> xmille-2.0-r1.ebuild:
Respect LDFLAGS. Bug #336826 by flameeyes@gentoo.org
diff --git a/games-board/xmille/xmille-2.0-r2.ebuild b/games-board/xmille/xmille-2.0-r2.ebuild
new file mode 100644
index 000000000000..756eb5b85735
--- /dev/null
+++ b/games-board/xmille/xmille-2.0-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/xmille/xmille-2.0-r2.ebuild,v 1.1 2013/01/22 17:23:31 hasufell Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs games
+
+DEB_PATCH_VER="12"
+DESCRIPTION="Mille Bournes card game"
+HOMEPAGE="http://www.milleborne.info/"
+SRC_URI="mirror://debian/pool/main/x/xmille/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/x/xmille/${PN}_${PV}-${DEB_PATCH_VER}.diff.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXext"
+DEPEND="${RDEPEND}
+ app-text/rman
+ x11-misc/imake"
+
+S=${WORKDIR}/${P}.orig
+
+PATCHES=( "${WORKDIR}"/${PN}_${PV}-${DEB_PATCH_VER}.diff )
+
+src_configure() {
+ xmkmf || die
+}
+
+src_compile() {
+ emake -j1 \
+ AR="$(tc-getAR) clq" \
+ RANLIB="$(tc-getRANLIB)" \
+ CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ dogamesbin xmille
+ dodoc CHANGES README
+ newman xmille.man xmille.6
+ prepgamesdirs
+}