summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-05-20 03:50:18 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-05-20 03:50:18 +0000
commit934363d8d4c8b25c83e9bee547057d809b86f0f5 (patch)
treec17b9e4b836ff031ebf7fe07ae1a584e9f8d4088 /kde-base/kdebindings-ruby
parentHOMEPAGE changed. (diff)
downloadgentoo-2-934363d8d4c8b25c83e9bee547057d809b86f0f5.tar.gz
gentoo-2-934363d8d4c8b25c83e9bee547057d809b86f0f5.tar.bz2
gentoo-2-934363d8d4c8b25c83e9bee547057d809b86f0f5.zip
Remove kdevplatform USE flag
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kdebindings-ruby')
-rw-r--r--kde-base/kdebindings-ruby/ChangeLog7
-rw-r--r--kde-base/kdebindings-ruby/kdebindings-ruby-4.4.2.ebuild9
-rw-r--r--kde-base/kdebindings-ruby/kdebindings-ruby-4.4.3.ebuild9
-rw-r--r--kde-base/kdebindings-ruby/metadata.xml1
4 files changed, 12 insertions, 14 deletions
diff --git a/kde-base/kdebindings-ruby/ChangeLog b/kde-base/kdebindings-ruby/ChangeLog
index c22ef056791b..e44af9af1188 100644
--- a/kde-base/kdebindings-ruby/ChangeLog
+++ b/kde-base/kdebindings-ruby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdebindings-ruby
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/ChangeLog,v 1.9 2010/05/17 15:37:30 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/ChangeLog,v 1.10 2010/05/20 03:50:18 reavertm Exp $
+
+ 20 May 2010; Maciej Mrozowski <reavertm@gentoo.org>
+ kdebindings-ruby-4.4.2.ebuild, kdebindings-ruby-4.4.3.ebuild,
+ metadata.xml:
+ Remove kdevplatform USE flag
17 May 2010; Maciej Mrozowski <reavertm@gentoo.org> metadata.xml:
Fix USE flag descriptions
diff --git a/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.2.ebuild b/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.2.ebuild
index 4b519399b510..475fc5712019 100644
--- a/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.2.ebuild
+++ b/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.2.ebuild,v 1.1 2010/03/30 19:52:53 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.2.ebuild,v 1.2 2010/05/20 03:50:18 reavertm Exp $
EAPI="2"
@@ -14,10 +14,10 @@ inherit kde4-meta ruby-ng
DESCRIPTION="KDE Ruby bindings"
KEYWORDS="~amd64 ~x86"
-IUSE="akonadi debug kdevplatform okular phonon plasma qscintilla qwt semantic-desktop"
+IUSE="akonadi debug okular phonon plasma qscintilla qwt semantic-desktop"
DEPEND="
- $(add_kdebase_dep smoke 'akonadi?,kdevplatform?,okular?,phonon?,qscintilla?,qwt?,semantic-desktop?')
+ $(add_kdebase_dep smoke 'akonadi?,okular?,phonon?,qscintilla?,qwt?,semantic-desktop?')
"
RDEPEND="${DEPEND}
@@ -63,9 +63,6 @@ each_ruby_configure() {
mycmakeargs=(
$(cmake-utils_use_enable akonadi KdepimLibs)
$(cmake-utils_use_enable akonadi)
- $(cmake-utils_use_enable kdevplatform KDEVPLATFORM_RUBY)
- $(cmake-utils_use_enable kdevplatform KDevPlatform)
- $(cmake-utils_use_with kdevplatform KDevPlatform)
$(cmake-utils_use_enable okular)
$(cmake-utils_use_enable plasma PLASMA_RUBY)
$(cmake-utils_use_enable phonon)
diff --git a/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.3.ebuild b/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.3.ebuild
index fbb0cc55c529..102f4dc35f37 100644
--- a/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.3.ebuild
+++ b/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.3.ebuild,v 1.1 2010/05/03 20:35:29 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.3.ebuild,v 1.2 2010/05/20 03:50:18 reavertm Exp $
EAPI="2"
@@ -14,10 +14,10 @@ inherit kde4-meta ruby-ng
DESCRIPTION="KDE Ruby bindings"
KEYWORDS="~amd64 ~x86"
-IUSE="akonadi debug kdevplatform okular phonon plasma qscintilla qwt semantic-desktop"
+IUSE="akonadi debug okular phonon plasma qscintilla qwt semantic-desktop"
DEPEND="
- $(add_kdebase_dep smoke 'akonadi?,kdevplatform?,okular?,phonon?,qscintilla?,qwt?,semantic-desktop?')
+ $(add_kdebase_dep smoke 'akonadi?,okular?,phonon?,qscintilla?,qwt?,semantic-desktop?')
"
RDEPEND="${DEPEND}
@@ -63,9 +63,6 @@ each_ruby_configure() {
mycmakeargs=(
$(cmake-utils_use_enable akonadi KdepimLibs)
$(cmake-utils_use_enable akonadi)
- $(cmake-utils_use_enable kdevplatform KDEVPLATFORM_RUBY)
- $(cmake-utils_use_enable kdevplatform KDevPlatform)
- $(cmake-utils_use_with kdevplatform KDevPlatform)
$(cmake-utils_use_enable okular)
$(cmake-utils_use_enable plasma PLASMA_RUBY)
$(cmake-utils_use_enable phonon)
diff --git a/kde-base/kdebindings-ruby/metadata.xml b/kde-base/kdebindings-ruby/metadata.xml
index a0ce97cdf4ad..81e2ae61cbf9 100644
--- a/kde-base/kdebindings-ruby/metadata.xml
+++ b/kde-base/kdebindings-ruby/metadata.xml
@@ -4,7 +4,6 @@
<herd>kde</herd>
<use>
<flag name="akonadi">Compile bindings for Akonadi.</flag>
- <flag name="kdevplatform">Compile bindings for <pkg>dev-util/kdevplatform</pkg>.</flag>
<flag name="okular">Compile bindings for <pkg>kde-base/okular</pkg>.</flag>
<flag name="phonon">Compile bindings for Phonon.</flag>
<flag name="plasma">Compile bindings for KDE's Plasma.</flag>