summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-07-22 16:18:20 +0000
committerAron Griffis <agriffis@gentoo.org>2004-07-22 16:18:20 +0000
commit50ffb02b1367420c9db24adc8f36c67d78e1c014 (patch)
tree38323e5cbf5d9cccd462a9339b6bdf96158a17d9 /media-gfx/graphviz
parentInitial import (bug #49337) (Manifest recommit) (diff)
downloadgentoo-2-50ffb02b1367420c9db24adc8f36c67d78e1c014.tar.gz
gentoo-2-50ffb02b1367420c9db24adc8f36c67d78e1c014.tar.bz2
gentoo-2-50ffb02b1367420c9db24adc8f36c67d78e1c014.zip
Update SRC_URI #53602, bump to 1.12 #52343, run gnuconfig_update in src_unpack
Diffstat (limited to 'media-gfx/graphviz')
-rw-r--r--media-gfx/graphviz/ChangeLog5
-rw-r--r--media-gfx/graphviz/files/digest-graphviz-1.121
-rw-r--r--media-gfx/graphviz/graphviz-1.10.ebuild9
-rw-r--r--media-gfx/graphviz/graphviz-1.12.ebuild55
4 files changed, 65 insertions, 5 deletions
diff --git a/media-gfx/graphviz/ChangeLog b/media-gfx/graphviz/ChangeLog
index a6f5615f194c..d06654646127 100644
--- a/media-gfx/graphviz/ChangeLog
+++ b/media-gfx/graphviz/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-gfx/graphviz
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.30 2004/07/21 02:18:24 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.31 2004/07/22 16:18:20 agriffis Exp $
+
+ 22 Jul 2004; Aron Griffis <agriffis@gentoo.org> graphviz-1.10.ebuild:
+ Update SRC_URI #53602, bump to 1.12 #52343, run gnuconfig_update in src_unpack
20 Jul 2004; Tom Gall <tgall@gentoo.org> graphviz-1.10.ebuild:
stable on ppc64, bug #57163
diff --git a/media-gfx/graphviz/files/digest-graphviz-1.12 b/media-gfx/graphviz/files/digest-graphviz-1.12
new file mode 100644
index 000000000000..649f3c7c439a
--- /dev/null
+++ b/media-gfx/graphviz/files/digest-graphviz-1.12
@@ -0,0 +1 @@
+MD5 84910caae072c714d107ca9f3e54ace0 graphviz-1.12.tar.gz 3371279
diff --git a/media-gfx/graphviz/graphviz-1.10.ebuild b/media-gfx/graphviz/graphviz-1.10.ebuild
index c010f4d9e666..09876898d8e7 100644
--- a/media-gfx/graphviz/graphviz-1.10.ebuild
+++ b/media-gfx/graphviz/graphviz-1.10.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-1.10.ebuild,v 1.17 2004/07/21 02:18:24 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-1.10.ebuild,v 1.18 2004/07/22 16:18:20 agriffis Exp $
inherit gnuconfig
DESCRIPTION="open source graph drawing software"
HOMEPAGE="http://www.research.att.com/sw/tools/graphviz/"
-SRC_URI="http://www.graphviz.org/pub/graphviz/${P}.tar.gz"
+SRC_URI="http://www.graphviz.org/pub/graphviz/ARCHIVE/${P}.tar.gz"
LICENSE="as-is | ATT"
SLOT="0"
@@ -24,11 +24,12 @@ src_unpack() {
unpack ${A}
cd ${S}
sed -i -e "s:+0 -1:-k 1,2:" "${S}/dotneato/common/Makefile.in"
+
+ # Run gnuconfig_update on all arches, needed at least for mips
+ gnuconfig_update
}
src_compile() {
- #if arch is mips, need gnuconfig tweak to build
- gnuconfig_update
local myconf
#if no tcltk, this will generate configure warnings, but will
#compile without tcltk support
diff --git a/media-gfx/graphviz/graphviz-1.12.ebuild b/media-gfx/graphviz/graphviz-1.12.ebuild
new file mode 100644
index 000000000000..2cb45d97d09b
--- /dev/null
+++ b/media-gfx/graphviz/graphviz-1.12.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-1.12.ebuild,v 1.1 2004/07/22 16:18:20 agriffis Exp $
+
+inherit gnuconfig
+
+DESCRIPTION="open source graph drawing software"
+HOMEPAGE="http://www.research.att.com/sw/tools/graphviz/"
+SRC_URI="http://www.graphviz.org/pub/graphviz/ARCHIVE/${P}.tar.gz"
+
+LICENSE="as-is | ATT"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~mips"
+IUSE="tcltk"
+
+#Can use freetype-1.3 or 2.0, but not both
+DEPEND=">=sys-libs/zlib-1.1.3
+ >=media-libs/libpng-1.2
+ >=media-libs/jpeg-6b
+ media-libs/freetype
+ tcltk? ( >=dev-lang/tk-8.3 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # It would be really nice if devs would comment this sort of hack
+ # when putting it in.
+ sed -i -e "s:+0 -1:-k 1,2:" "${S}/dotneato/common/Makefile.in"
+
+ # Run gnuconfig_update on all arches, needed at least for mips
+ gnuconfig_update
+}
+
+src_compile() {
+ local myconf
+
+ # if no tcltk, this will generate configure warnings, but will
+ # compile without tcltk support
+ use tcltk || myconf="${myconf} --without-tcl --without-tk"
+
+ econf ${myconf} || die "econf failed"
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog FAQ.txt INSTALL MINTERMS.txt \
+ NEWS README
+
+ dohtml -r .
+ dodoc doc/*.pdf
+}