summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-06-20 21:20:20 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-06-20 21:20:20 +0000
commit292281caf79d7b341dab74c2ea1a628603194eba (patch)
tree18a2176d42a351f46929888654fe2f365f2de08d /media-video/xine-ui
parentUpdated to 0.9.11. (diff)
downloadgentoo-2-292281caf79d7b341dab74c2ea1a628603194eba.tar.gz
gentoo-2-292281caf79d7b341dab74c2ea1a628603194eba.tar.bz2
gentoo-2-292281caf79d7b341dab74c2ea1a628603194eba.zip
Updated to 0.9.11.
Diffstat (limited to 'media-video/xine-ui')
-rw-r--r--media-video/xine-ui/ChangeLog8
-rw-r--r--media-video/xine-ui/files/digest-xine-ui-0.9.111
-rw-r--r--media-video/xine-ui/xine-ui-0.9.11.ebuild65
3 files changed, 73 insertions, 1 deletions
diff --git a/media-video/xine-ui/ChangeLog b/media-video/xine-ui/ChangeLog
index 275cefd3adbd..60283bfa99a9 100644
--- a/media-video/xine-ui/ChangeLog
+++ b/media-video/xine-ui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/xine-ui
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.12 2002/06/16 19:22:15 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.13 2002/06/20 21:20:20 agenkin Exp $
+
+*xine-ui-0.9.11 (20 Jun 2002)
+
+ 20 Jun 2002; Arcady Genkin <agenkin@thpoon.com> xine-ui-0.9.11.ebuld :
+
+ Update to version 0.9.11.
*xine-ui-0.9.10-r1 (16 Jun 2002)
diff --git a/media-video/xine-ui/files/digest-xine-ui-0.9.11 b/media-video/xine-ui/files/digest-xine-ui-0.9.11
new file mode 100644
index 000000000000..77378f40ba36
--- /dev/null
+++ b/media-video/xine-ui/files/digest-xine-ui-0.9.11
@@ -0,0 +1 @@
+MD5 317fa27be81145935332a6ba003396f3 xine-ui-0.9.11.tar.gz 1257846
diff --git a/media-video/xine-ui/xine-ui-0.9.11.ebuild b/media-video/xine-ui/xine-ui-0.9.11.ebuild
new file mode 100644
index 000000000000..941f801f6efd
--- /dev/null
+++ b/media-video/xine-ui/xine-ui-0.9.11.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.9.11.ebuild,v 1.1 2002/06/20 21:20:20 agenkin Exp $
+
+DESCRIPTION="Xine is a free gpl-licensed video player for unix-like systems"
+HOMEPAGE="http://xine.sourceforge.net/"
+LICENSE="GPL"
+
+DEPEND="virtual/glibc
+ media-libs/libpng
+ >=media-libs/xine-lib-${PV}
+ nls? ( sys-devel/gettext )
+ X? ( virtual/x11 )
+ directfb? ( >=dev-libs/DirectFB-0.9.9 )
+ gnome? ( gnome-base/ORBit )"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+
+SRC_URI="http://xine.sourceforge.net/files/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ use directfb || ( \
+ sed -e "s:dfb::" src/Makefile.in \
+ > src/Makefile.in.hacked
+ mv src/Makefile.in.hacked src/Makefile.in
+ )
+
+ sed -e "s:LDFLAGS =:LDFLAGS = -L/lib:" src/xitk/Makefile.in \
+ > src/xitk/Makefile.in.hacked
+ mv src/xitk/Makefile.in.hacked src/xitk/Makefile.in
+
+}
+
+src_compile() {
+
+ # Most of these are not working currently, but are here for completeness
+ local myconf
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ docsdir=/usr/share/doc/${PF} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}