summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-11-12 14:34:07 +0000
committerMichael Weber <xmw@gentoo.org>2011-11-12 14:34:07 +0000
commit7beb157f888e333838d9459f59ce70ec57094719 (patch)
tree826f315dc049c3e31a5b465375d1a08e98c13bfd /net-analyzer/authforce
parentDrop duped ChangeLog messages. (diff)
downloadgentoo-2-7beb157f888e333838d9459f59ce70ec57094719.tar.gz
gentoo-2-7beb157f888e333838d9459f59ce70ec57094719.tar.bz2
gentoo-2-7beb157f888e333838d9459f59ce70ec57094719.zip
Revbump to fix curl-0.7.22 compartibiliy (thanks to Andrew Savchenko, bug 389571)
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/authforce')
-rw-r--r--net-analyzer/authforce/ChangeLog9
-rw-r--r--net-analyzer/authforce/authforce-0.9.9-r1.ebuild29
-rw-r--r--net-analyzer/authforce/files/authforce-0.9.9-curl.patch10
3 files changed, 47 insertions, 1 deletions
diff --git a/net-analyzer/authforce/ChangeLog b/net-analyzer/authforce/ChangeLog
index ed3cb1eeddfa..01d82c1feeaf 100644
--- a/net-analyzer/authforce/ChangeLog
+++ b/net-analyzer/authforce/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/authforce
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/authforce/ChangeLog,v 1.16 2011/11/05 16:07:19 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/authforce/ChangeLog,v 1.17 2011/11/12 14:34:07 xmw Exp $
+
+*authforce-0.9.9-r1 (12 Nov 2011)
+
+ 12 Nov 2011; Michael Weber <xmw@gentoo.org> +authforce-0.9.9-r1.ebuild,
+ +files/authforce-0.9.9-curl.patch:
+ Revbump to fix curl-0.7.22 compartibiliy (thanks to Andrew Savchenko, bug
+ 389571)
05 Nov 2011; Jeroen Roovers <jer@gentoo.org> authforce-0.9.9.ebuild:
Do not install COPYING.
diff --git a/net-analyzer/authforce/authforce-0.9.9-r1.ebuild b/net-analyzer/authforce/authforce-0.9.9-r1.ebuild
new file mode 100644
index 000000000000..7a5efde42c65
--- /dev/null
+++ b/net-analyzer/authforce/authforce-0.9.9-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/authforce/authforce-0.9.9-r1.ebuild,v 1.1 2011/11/12 14:34:07 xmw Exp $
+
+EAPI=4
+
+inherit base
+
+DESCRIPTION="An HTTP authentication brute forcer"
+HOMEPAGE="http://www.divineinvasion.net/authforce"
+SRC_URI="http://www.divineinvasion.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="curl nls"
+DEPEND="sys-libs/readline
+ nls? ( sys-devel/gettext )
+ curl? ( net-misc/curl )"
+
+DOCS=( AUTHORS BUGS NEWS README THANKS TODO )
+PATCHES=( "${FILESDIR}"/${P}-curl.patch )
+
+src_configure() {
+ econf \
+ $(use_with curl) \
+ $(use_enable nls) \
+ --with-path=/usr/share/${PN}/data:.
+}
diff --git a/net-analyzer/authforce/files/authforce-0.9.9-curl.patch b/net-analyzer/authforce/files/authforce-0.9.9-curl.patch
new file mode 100644
index 000000000000..22552f8aafd4
--- /dev/null
+++ b/net-analyzer/authforce/files/authforce-0.9.9-curl.patch
@@ -0,0 +1,10 @@
+--- authforce-0.9.9/src/http.c
++++ authforce-0.9.9/src/http.c
+@@ -7,7 +7,6 @@
+ #include <time.h>
+ #ifdef USE_CURL
+ #include <curl/curl.h>
+-#include <curl/types.h>
+ #include <curl/easy.h>
+ #endif /* USE_CURL */
+ #ifdef MEMWATCH