summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-09 17:55:40 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-09 17:55:40 +0000
commit021e6aa1318d352ed747a6b126b5cc750c3952ed (patch)
tree800b136886cb35290e89e21a2ddb92a2fc825d70 /sci-biology
parentStable for x86, wrt bug #425456 (diff)
downloadgentoo-2-021e6aa1318d352ed747a6b126b5cc750c3952ed.tar.gz
gentoo-2-021e6aa1318d352ed747a6b126b5cc750c3952ed.tar.bz2
gentoo-2-021e6aa1318d352ed747a6b126b5cc750c3952ed.zip
sci-biology/allpathslg: Version bump, fix compilation errors with gcc-4.7, #425472
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/allpathslg/ChangeLog7
-rw-r--r--sci-biology/allpathslg/allpathslg-42337.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/sci-biology/allpathslg/ChangeLog b/sci-biology/allpathslg/ChangeLog
index f1b3747e4344..6568253d00ee 100644
--- a/sci-biology/allpathslg/ChangeLog
+++ b/sci-biology/allpathslg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/allpathslg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/allpathslg/ChangeLog,v 1.7 2012/05/29 02:51:11 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/allpathslg/ChangeLog,v 1.8 2012/07/09 17:55:40 jlec Exp $
+
+*allpathslg-42337 (09 Jul 2012)
+
+ 09 Jul 2012; Justin Lecher <jlec@gentoo.org> +allpathslg-42337.ebuild:
+ Version bump, fix compilation errors with gcc-4.7, #425472
*allpathslg-41839 (29 May 2012)
diff --git a/sci-biology/allpathslg/allpathslg-42337.ebuild b/sci-biology/allpathslg/allpathslg-42337.ebuild
new file mode 100644
index 000000000000..c86c7de6d62d
--- /dev/null
+++ b/sci-biology/allpathslg/allpathslg-42337.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/allpathslg/allpathslg-42337.ebuild,v 1.1 2012/07/09 17:55:40 jlec Exp $
+
+EAPI=4
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="De novo assembly of whole-genome shotgun microreads"
+HOMEPAGE="http://www.broadinstitute.org/science/programs/genome-biology/crd"
+SRC_URI="ftp://ftp.broadinstitute.org/pub/crd/ALLPATHS/Release-LG/latest_source_code/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/boost
+ >=sys-devel/gcc-4.3.3
+ sci-biology/vaal"
+RDEPEND=""
+
+src_prepare() {
+ sed -i 's/-ggdb3//' configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ einstall || die
+ # Provided by sci-biology/vaal
+ for i in QueryLookupTable ScaffoldAccuracy MakeLookupTable Fastb ShortQueryLookup; do
+ rm "${D}/usr/bin/$i" || die
+ done
+}