summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-12-03 04:25:44 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-12-03 04:25:44 +0000
commit8117b7b0721cdcdbfde027ce9fa41d1949df1c4c (patch)
tree0b030c8d48d1a37c32e02fb8a69b49af50122fbe /sci-chemistry/gopenmol/gopenmol-3.00.ebuild
parentpatch from nelchael for draft/templates folder (diff)
downloadgentoo-2-8117b7b0721cdcdbfde027ce9fa41d1949df1c4c.tar.gz
gentoo-2-8117b7b0721cdcdbfde027ce9fa41d1949df1c4c.tar.bz2
gentoo-2-8117b7b0721cdcdbfde027ce9fa41d1949df1c4c.zip
(#53333) New molecular graphics package for visualizing and analyzing structures. Based on ebuild by Dirk-Jan Heijs <heijs@phys.rug.nl>, with updates and fixes by me.
(Portage version: 2.0.53)
Diffstat (limited to 'sci-chemistry/gopenmol/gopenmol-3.00.ebuild')
-rw-r--r--sci-chemistry/gopenmol/gopenmol-3.00.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sci-chemistry/gopenmol/gopenmol-3.00.ebuild b/sci-chemistry/gopenmol/gopenmol-3.00.ebuild
new file mode 100644
index 000000000000..ca6664fc640e
--- /dev/null
+++ b/sci-chemistry/gopenmol/gopenmol-3.00.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gopenmol/gopenmol-3.00.ebuild,v 1.1 2005/12/03 04:25:44 spyderous Exp $
+
+inherit eutils
+
+DESCRIPTION="gOpenMol is a tool for the visualization and analysis of molecular structures"
+HOMEPAGE="http://www.csc.fi/gopenmol"
+SRC_URI="${HOMEPAGE}/distribute/${P}-linux.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/tcl-8.4*
+ =dev-lang/tk-8.4*
+ dev-tcltk/bwidget
+ virtual/opengl
+ virtual/glut
+ media-libs/jpeg
+ dev-lang/python
+ || ( (
+ x11-libs/libXmu
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXi
+ x11-libs/libXxf86vm
+ )
+ virtual/x11
+ )"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/gOpenMol-${PV}/src"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-include-config-for-plugins.patch
+}
+
+src_compile() {
+ econf || die "./configure failed"
+
+ emake || die "emake failed"
+
+ # Plugins are not build by default
+ cd ${S}/plugins
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+
+ cd ${S}/plugins
+ einstall || die
+
+ dosed /usr/bin/rungOpenMol
+}
+
+pkg_postinst() {
+ einfo "Run gOpenMol using the rungOpenMol script."
+}