summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-03-31 01:21:16 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-03-31 01:21:16 +0000
commit96583523ad176abdeb93ee26af4774644efde404 (patch)
tree92f9fa083c0840ae18d0d76f4ed71a7d2cd65ee7 /sys-apps/acl
parentdep fixums (diff)
downloadgentoo-2-96583523ad176abdeb93ee26af4774644efde404.tar.gz
gentoo-2-96583523ad176abdeb93ee26af4774644efde404.tar.bz2
gentoo-2-96583523ad176abdeb93ee26af4774644efde404.zip
new set of xfs apps
Diffstat (limited to 'sys-apps/acl')
-rw-r--r--sys-apps/acl/acl-20020330.ebuild43
-rw-r--r--sys-apps/acl/files/digest-acl-200203301
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/acl/acl-20020330.ebuild b/sys-apps/acl/acl-20020330.ebuild
new file mode 100644
index 000000000000..a96c20ab9912
--- /dev/null
+++ b/sys-apps/acl/acl-20020330.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-20020330.ebuild,v 1.1 2002/03/31 01:21:16 drobbins Exp $
+
+S=${WORKDIR}/cmd/${PN}
+DESCRIPTION="XFS dump/restore utilities"
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/xfs-cmd-${PV}.tar.bz2"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-apps/attr sys-devel/make"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ # 1) add a ${DESTDIR} prefix to all install paths so we can relocate during the "install" phase
+ # 2) we also set the /usr/share/doc/ directory to the correct value.
+ # 3) we remove a hard-coded "-O1"
+ # 4) we fix some Makefile-created library symlinks that contains absolute paths
+ cp include/builddefs include/builddefs.orig
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' \
+ -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" \
+ -e 's:-O1::' \
+ include/builddefs.orig > include/builddefs || die
+# -e 's:-S \(.*\) $(PKG_.*_DIR)/\(.*$\):-S \1 \2:' \
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install install-dev install-lib || die
+ #fix freaky symlinks
+ cd ${D}/usr/lib
+ rm libacl.so
+ ln -s ../../lib/libacl.so libacl.so
+ cd ${D}/lib
+ rm *a
+ ln -s ../usr/lib/libacl.la libacl.la
+ ln -s ../usr/lib/libacl.a libacl.a
+}
diff --git a/sys-apps/acl/files/digest-acl-20020330 b/sys-apps/acl/files/digest-acl-20020330
new file mode 100644
index 000000000000..2993709f2f6e
--- /dev/null
+++ b/sys-apps/acl/files/digest-acl-20020330
@@ -0,0 +1 @@
+MD5 18bbd9b036cae38073bcaeef8b89ecf6 xfs-cmd-20020330.tar.bz2 1546532