summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-10 11:24:12 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-11 18:49:16 +1000
commit20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3 (patch)
tree717d375d4bc34b50cfb78c9712a992489ed8d73b /app-crypt/rpm-sequoia/rpm-sequoia-1.6.0-r1.ebuild
parenteclass: update rust usedep handling; address feedback (diff)
downloadgentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.tar.gz
gentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.tar.bz2
gentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.zip
*/*: fix rust eclass usedep/mutlilib handling; inherit order
The rust eclass has been updated to directly inject a required MULTILIB_USEDEP when requested. RUST_USEDEP has been renamed to RUST_REQUIRED_USE to be consistent with other eclasses. llvm-r1 should be imported after cargo and the eclass now enables this. Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'app-crypt/rpm-sequoia/rpm-sequoia-1.6.0-r1.ebuild')
-rw-r--r--app-crypt/rpm-sequoia/rpm-sequoia-1.6.0-r1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/app-crypt/rpm-sequoia/rpm-sequoia-1.6.0-r1.ebuild b/app-crypt/rpm-sequoia/rpm-sequoia-1.6.0-r1.ebuild
index 1563c0d6977e..afd0c9eb297b 100644
--- a/app-crypt/rpm-sequoia/rpm-sequoia-1.6.0-r1.ebuild
+++ b/app-crypt/rpm-sequoia/rpm-sequoia-1.6.0-r1.ebuild
@@ -238,7 +238,7 @@ CRATES="
LLVM_COMPAT=( 17 )
RUST_NEEDS_LLVM=1
-inherit llvm-r1 cargo
+inherit cargo llvm-r1
DESCRIPTION="Implementation of the RPM PGP interface using Sequoia"
HOMEPAGE="https://sequoia-pgp.org/ https://github.com/rpm-software-management/rpm-sequoia"