summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Ratiu <adrian.ratiu@collabora.com>2021-12-06 14:30:24 +0200
committerSam James <sam@gentoo.org>2022-01-04 10:07:39 +0000
commita792e455bfcba4b7a462d1cadb1eab2ed1c3f7fc (patch)
tree35e7cd16ff3ef74a426b60aea8a5f47ebb1ce7fe /dev-libs/protobuf
parentmedia-sound/yoshimi: removed obsolete 2.1.1.1 (diff)
downloadgentoo-a792e455bfcba4b7a462d1cadb1eab2ed1c3f7fc.tar.gz
gentoo-a792e455bfcba4b7a462d1cadb1eab2ed1c3f7fc.tar.bz2
gentoo-a792e455bfcba4b7a462d1cadb1eab2ed1c3f7fc.zip
dev-libs/protobuf: fix Objective-C compiler selection
During the protobuf configure phase, autotools gives priority to GCC if $OBJC is unset, thus leading to cases where GCC is used for Objective-C even though Clang is used for the rest of the build, so we set OBJC to correctly picks up CC values. Closes: https://bugs.gentoo.org/830584 Signed-off-by: Adrian Ratiu <adrian.ratiu@collabora.com> Closes: https://github.com/gentoo/gentoo/pull/23197 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/protobuf')
-rw-r--r--dev-libs/protobuf/protobuf-3.16.0.ebuild3
-rw-r--r--dev-libs/protobuf/protobuf-3.17.0.ebuild3
-rw-r--r--dev-libs/protobuf/protobuf-3.17.1.ebuild3
-rw-r--r--dev-libs/protobuf/protobuf-3.17.2.ebuild3
-rw-r--r--dev-libs/protobuf/protobuf-3.17.3.ebuild3
-rw-r--r--dev-libs/protobuf/protobuf-3.19.1.ebuild3
-rw-r--r--dev-libs/protobuf/protobuf-9999.ebuild3
7 files changed, 14 insertions, 7 deletions
diff --git a/dev-libs/protobuf/protobuf-3.16.0.ebuild b/dev-libs/protobuf/protobuf-3.16.0.ebuild
index ed6e85a966fb..68eb4507463b 100644
--- a/dev-libs/protobuf/protobuf-3.16.0.ebuild
+++ b/dev-libs/protobuf/protobuf-3.16.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2008-2021 Gentoo Authors
+# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -74,6 +74,7 @@ src_configure() {
multilib_src_configure() {
local options=(
+ OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)
diff --git a/dev-libs/protobuf/protobuf-3.17.0.ebuild b/dev-libs/protobuf/protobuf-3.17.0.ebuild
index 6391fd499f34..390df7df0b7c 100644
--- a/dev-libs/protobuf/protobuf-3.17.0.ebuild
+++ b/dev-libs/protobuf/protobuf-3.17.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2008-2021 Gentoo Authors
+# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -74,6 +74,7 @@ src_configure() {
multilib_src_configure() {
local options=(
+ OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)
diff --git a/dev-libs/protobuf/protobuf-3.17.1.ebuild b/dev-libs/protobuf/protobuf-3.17.1.ebuild
index 6391fd499f34..390df7df0b7c 100644
--- a/dev-libs/protobuf/protobuf-3.17.1.ebuild
+++ b/dev-libs/protobuf/protobuf-3.17.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2008-2021 Gentoo Authors
+# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -74,6 +74,7 @@ src_configure() {
multilib_src_configure() {
local options=(
+ OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)
diff --git a/dev-libs/protobuf/protobuf-3.17.2.ebuild b/dev-libs/protobuf/protobuf-3.17.2.ebuild
index 6391fd499f34..390df7df0b7c 100644
--- a/dev-libs/protobuf/protobuf-3.17.2.ebuild
+++ b/dev-libs/protobuf/protobuf-3.17.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2008-2021 Gentoo Authors
+# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -74,6 +74,7 @@ src_configure() {
multilib_src_configure() {
local options=(
+ OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)
diff --git a/dev-libs/protobuf/protobuf-3.17.3.ebuild b/dev-libs/protobuf/protobuf-3.17.3.ebuild
index 1254928d7c06..a29ab8dcb86c 100644
--- a/dev-libs/protobuf/protobuf-3.17.3.ebuild
+++ b/dev-libs/protobuf/protobuf-3.17.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2008-2021 Gentoo Authors
+# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -74,6 +74,7 @@ src_configure() {
multilib_src_configure() {
local options=(
+ OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)
diff --git a/dev-libs/protobuf/protobuf-3.19.1.ebuild b/dev-libs/protobuf/protobuf-3.19.1.ebuild
index 534446b5f41a..41c154dc9b6a 100644
--- a/dev-libs/protobuf/protobuf-3.19.1.ebuild
+++ b/dev-libs/protobuf/protobuf-3.19.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2008-2021 Gentoo Authors
+# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -71,6 +71,7 @@ src_configure() {
multilib_src_configure() {
local options=(
+ OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)
diff --git a/dev-libs/protobuf/protobuf-9999.ebuild b/dev-libs/protobuf/protobuf-9999.ebuild
index cfe56720a1a3..f2b413703d21 100644
--- a/dev-libs/protobuf/protobuf-9999.ebuild
+++ b/dev-libs/protobuf/protobuf-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2008-2021 Gentoo Authors
+# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -52,6 +52,7 @@ src_configure() {
multilib_src_configure() {
local options=(
+ OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)