summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/protobuf')
-rw-r--r--dev-libs/protobuf/protobuf-3.16.0.ebuild3
-rw-r--r--dev-libs/protobuf/protobuf-3.17.0.ebuild3
-rw-r--r--dev-libs/protobuf/protobuf-3.17.1.ebuild3
-rw-r--r--dev-libs/protobuf/protobuf-3.17.2.ebuild3
-rw-r--r--dev-libs/protobuf/protobuf-3.17.3.ebuild3
-rw-r--r--dev-libs/protobuf/protobuf-3.19.1.ebuild3
-rw-r--r--dev-libs/protobuf/protobuf-9999.ebuild3
7 files changed, 14 insertions, 7 deletions
diff --git a/dev-libs/protobuf/protobuf-3.16.0.ebuild b/dev-libs/protobuf/protobuf-3.16.0.ebuild
index ed6e85a966fb..68eb4507463b 100644
--- a/dev-libs/protobuf/protobuf-3.16.0.ebuild
+++ b/dev-libs/protobuf/protobuf-3.16.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2008-2021 Gentoo Authors
+# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -74,6 +74,7 @@ src_configure() {
multilib_src_configure() {
local options=(
+ OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)
diff --git a/dev-libs/protobuf/protobuf-3.17.0.ebuild b/dev-libs/protobuf/protobuf-3.17.0.ebuild
index 6391fd499f34..390df7df0b7c 100644
--- a/dev-libs/protobuf/protobuf-3.17.0.ebuild
+++ b/dev-libs/protobuf/protobuf-3.17.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2008-2021 Gentoo Authors
+# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -74,6 +74,7 @@ src_configure() {
multilib_src_configure() {
local options=(
+ OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)
diff --git a/dev-libs/protobuf/protobuf-3.17.1.ebuild b/dev-libs/protobuf/protobuf-3.17.1.ebuild
index 6391fd499f34..390df7df0b7c 100644
--- a/dev-libs/protobuf/protobuf-3.17.1.ebuild
+++ b/dev-libs/protobuf/protobuf-3.17.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2008-2021 Gentoo Authors
+# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -74,6 +74,7 @@ src_configure() {
multilib_src_configure() {
local options=(
+ OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)
diff --git a/dev-libs/protobuf/protobuf-3.17.2.ebuild b/dev-libs/protobuf/protobuf-3.17.2.ebuild
index 6391fd499f34..390df7df0b7c 100644
--- a/dev-libs/protobuf/protobuf-3.17.2.ebuild
+++ b/dev-libs/protobuf/protobuf-3.17.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2008-2021 Gentoo Authors
+# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -74,6 +74,7 @@ src_configure() {
multilib_src_configure() {
local options=(
+ OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)
diff --git a/dev-libs/protobuf/protobuf-3.17.3.ebuild b/dev-libs/protobuf/protobuf-3.17.3.ebuild
index 1254928d7c06..a29ab8dcb86c 100644
--- a/dev-libs/protobuf/protobuf-3.17.3.ebuild
+++ b/dev-libs/protobuf/protobuf-3.17.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2008-2021 Gentoo Authors
+# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -74,6 +74,7 @@ src_configure() {
multilib_src_configure() {
local options=(
+ OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)
diff --git a/dev-libs/protobuf/protobuf-3.19.1.ebuild b/dev-libs/protobuf/protobuf-3.19.1.ebuild
index 534446b5f41a..41c154dc9b6a 100644
--- a/dev-libs/protobuf/protobuf-3.19.1.ebuild
+++ b/dev-libs/protobuf/protobuf-3.19.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2008-2021 Gentoo Authors
+# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -71,6 +71,7 @@ src_configure() {
multilib_src_configure() {
local options=(
+ OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)
diff --git a/dev-libs/protobuf/protobuf-9999.ebuild b/dev-libs/protobuf/protobuf-9999.ebuild
index cfe56720a1a3..f2b413703d21 100644
--- a/dev-libs/protobuf/protobuf-9999.ebuild
+++ b/dev-libs/protobuf/protobuf-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2008-2021 Gentoo Authors
+# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -52,6 +52,7 @@ src_configure() {
multilib_src_configure() {
local options=(
+ OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)