summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-07-25 00:45:16 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-07-25 00:59:08 +0200
commit3e20ec1bc5c95d51337e11c0021a8313e5dc08a7 (patch)
tree2fc3a225e3996cf6ee92002d4d275149a24ea578 /dev-python/requests-mock/requests-mock-1.5.2.ebuild
parentx11-libs/libiterm-mbt: remove last rited package (diff)
downloadgentoo-3e20ec1bc5c95d51337e11c0021a8313e5dc08a7.tar.gz
gentoo-3e20ec1bc5c95d51337e11c0021a8313e5dc08a7.tar.bz2
gentoo-3e20ec1bc5c95d51337e11c0021a8313e5dc08a7.zip
dev-python/requests-mock: bump to 1.5.2, add Python 3.7
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-python/requests-mock/requests-mock-1.5.2.ebuild')
-rw-r--r--dev-python/requests-mock/requests-mock-1.5.2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/requests-mock/requests-mock-1.5.2.ebuild b/dev-python/requests-mock/requests-mock-1.5.2.ebuild
new file mode 100644
index 000000000000..5c4420858b1f
--- /dev/null
+++ b/dev-python/requests-mock/requests-mock-1.5.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock out responses from the requests package"
+HOMEPAGE="https://github.com/jamielennox/requests-mock"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/subunit[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # Disable reno which only works inside a git repository
+ # Disable intersphinx
+ sed -i -e "s/'reno.sphinxext',//" \
+ -e "s/'sphinx.ext.intersphinx'//" \
+ doc/source/conf.py || die
+ # Remove the release notes section which requires reno
+ rm doc/source/release-notes.rst || die
+ sed -i '/^=============$/,/release-notes/d' doc/source/index.rst || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build doc/source docs/source/build/_html || die
+ HTML_DOCS=( docs/source/build/_html/. )
+ fi
+}
+
+python_test() {
+ rm -rf .testrepository \
+ || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}