summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-10-04 16:05:07 -0700
committerJoonas Niilola <juippis@gentoo.org>2024-11-02 14:46:00 +0200
commit38aaf498fb55d877ac4714fc0d234e3db0adb209 (patch)
treeae35b0d738a3c370c1e38718b0483c16c7b123d5 /games-emulation
parentgames-emulation/sameboy-jg: drop 0.16.2-r1 (diff)
downloadgentoo-38aaf498fb55d877ac4714fc0d234e3db0adb209.tar.gz
gentoo-38aaf498fb55d877ac4714fc0d234e3db0adb209.tar.bz2
gentoo-38aaf498fb55d877ac4714fc0d234e3db0adb209.zip
games-emulation/jgrf: add 1.2.0
Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/jgrf/Manifest1
-rw-r--r--games-emulation/jgrf/jgrf-1.2.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/games-emulation/jgrf/Manifest b/games-emulation/jgrf/Manifest
index 09334e68d8e7..45fdd71bedb7 100644
--- a/games-emulation/jgrf/Manifest
+++ b/games-emulation/jgrf/Manifest
@@ -1,2 +1,3 @@
DIST jgrf-1.0.2.tar.bz2 297837 BLAKE2B 1119f3b11ec4d64eda775ca39a13f1c6873dfa06b206229e12edf1790b8abb5ebf6b9161dd11fd735e9e3745c9c4bb7fc3a9e44523a65be8bd2ca139d0ccc14f SHA512 75b4c8fe8b142a144eccdcbbb763c78c091f869d3411caa127a8c319af1c37cd1157f63a2ee28945f4dc1c5b7b465b15a9c7fdeb23e03bb7d7441e8caa16b435
DIST jgrf-1.1.0.tar.bz2 300956 BLAKE2B a9bdacfb1713a20eaf78794f149773ba19c594941e7fe793d67d1c1a7f86bb8e5911ba92e35ac2a3bbef2c00009b478038fb93636d0a36f567596d44d4bfa7f0 SHA512 4fb96c9fea7bca818b44870bbb69cdb0c062739766d82793909228ba43d3b3be0c1ecfbad8fb2b18e445ae5a0c3958141bbc16726b97a4d3eaef596e94af88b7
+DIST jgrf-1.2.0.tar.bz2 306722 BLAKE2B 55453ea21a53f57c938c9c5b40614c37dc9438787cc1f8116fd30c4d64b397147bca4abdcbc1f69de10c510bedc7e3ef652496783b87b7748c83283925ca5669 SHA512 a012a1918dd734aac6ac92ddbe657b19809ef101c99e79e0754d05a4656b546a5aa6aa7f70eec441ecaf46d5501fd6c20caff4568c3abdaeb932be47304bd713
diff --git a/games-emulation/jgrf/jgrf-1.2.0.ebuild b/games-emulation/jgrf/jgrf-1.2.0.ebuild
new file mode 100644
index 000000000000..64d0d2963deb
--- /dev/null
+++ b/games-emulation/jgrf/jgrf-1.2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs xdg
+
+DESCRIPTION="The Jolly Good Reference Frontend"
+HOMEPAGE="https://jgemu.gitlab.io/jgrf.html"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="BSD CC0-1.0 MIT ZLIB"
+SLOT="1"
+
+DEPEND="
+ dev-libs/miniz
+ dev-libs/openssl:0=
+ media-libs/jg:1=
+ media-libs/libepoxy[egl(+)]
+ media-libs/libsdl2[opengl,sound,video]
+ media-libs/speexdsp
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ PREFIX="${EPREFIX}"/usr \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ USE_EXTERNAL_MD5=1 \
+ USE_EXTERNAL_MINIZ=1
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ USE_EXTERNAL_MD5=1 \
+ USE_EXTERNAL_MINIZ=1
+}