summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-07-23 10:16:39 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-07-23 11:14:07 -0400
commit769d77532c9e692fb6af3924a0b54f3be5ef7f3b (patch)
treeb93d0b441d43dd393a368d14802fd223bb190b76 /gui-libs
parentgui-libs/egl-gbm: add multilib support (diff)
downloadgentoo-769d77532c9e692fb6af3924a0b54f3be5ef7f3b.tar.gz
gentoo-769d77532c9e692fb6af3924a0b54f3be5ef7f3b.tar.bz2
gentoo-769d77532c9e692fb6af3924a0b54f3be5ef7f3b.zip
gui-libs/egl-wayland: add multilib support
To match NVIDIA that started shipping egl-gbm/wayland 32bit variant in >=nvidia-drivers-560 to let 32bit applications work right on wayland. ...albeit this is rather uncommon given most 32bit applications would be using xwayland at best, but do not want an unexpected setup that may confuse some things like steam or wine's new wayland support. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/egl-wayland/egl-wayland-1.1.13-r1.ebuild42
-rw-r--r--gui-libs/egl-wayland/egl-wayland-1.1.14-r1.ebuild42
2 files changed, 84 insertions, 0 deletions
diff --git a/gui-libs/egl-wayland/egl-wayland-1.1.13-r1.ebuild b/gui-libs/egl-wayland/egl-wayland-1.1.13-r1.ebuild
new file mode 100644
index 000000000000..93079328f2a5
--- /dev/null
+++ b/gui-libs/egl-wayland/egl-wayland-1.1.13-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+DESCRIPTION="EGLStream-based Wayland external platform"
+HOMEPAGE="https://github.com/NVIDIA/egl-wayland/"
+SRC_URI="
+ https://github.com/NVIDIA/egl-wayland/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-libs/wayland[${MULTILIB_USEDEP}]
+ x11-libs/libdrm[${MULTILIB_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+ >=gui-libs/eglexternalplatform-1.1-r1
+ media-libs/libglvnd
+"
+BDEPEND="
+ dev-util/wayland-scanner
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.6-remove-werror.patch
+)
+
+src_install() {
+ meson-multilib_src_install
+
+ insinto /usr/share/egl/egl_external_platform.d
+ doins "${FILESDIR}"/10_nvidia_wayland.json
+}
diff --git a/gui-libs/egl-wayland/egl-wayland-1.1.14-r1.ebuild b/gui-libs/egl-wayland/egl-wayland-1.1.14-r1.ebuild
new file mode 100644
index 000000000000..93079328f2a5
--- /dev/null
+++ b/gui-libs/egl-wayland/egl-wayland-1.1.14-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+DESCRIPTION="EGLStream-based Wayland external platform"
+HOMEPAGE="https://github.com/NVIDIA/egl-wayland/"
+SRC_URI="
+ https://github.com/NVIDIA/egl-wayland/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-libs/wayland[${MULTILIB_USEDEP}]
+ x11-libs/libdrm[${MULTILIB_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+ >=gui-libs/eglexternalplatform-1.1-r1
+ media-libs/libglvnd
+"
+BDEPEND="
+ dev-util/wayland-scanner
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.6-remove-werror.patch
+)
+
+src_install() {
+ meson-multilib_src_install
+
+ insinto /usr/share/egl/egl_external_platform.d
+ doins "${FILESDIR}"/10_nvidia_wayland.json
+}