summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 20:39:29 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 20:39:29 +0000
commit1cb73ae8cd01b90097c00edde8374e16497110bd (patch)
treebfe2ee8aea814d1794bccb1c58104b06b70fd462 /app-crypt
parentChanged econf||die to econf (diff)
downloadhistorical-1cb73ae8cd01b90097c00edde8374e16497110bd.tar.gz
historical-1cb73ae8cd01b90097c00edde8374e16497110bd.tar.bz2
historical-1cb73ae8cd01b90097c00edde8374e16497110bd.zip
Changed src_install () to src_install()
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/heimdal/heimdal-0.5.1.ebuild10
-rw-r--r--app-crypt/heimdal/heimdal-0.5.ebuild12
-rw-r--r--app-crypt/johntheripper/johntheripper-1.6.ebuild16
-rw-r--r--app-crypt/krb5/krb5-1.2.5-r1.ebuild18
-rw-r--r--app-crypt/krb5/krb5-1.2.5-r2.ebuild16
-rw-r--r--app-crypt/krb5/krb5-1.2.6.ebuild9
-rw-r--r--app-crypt/kth-krb/kth-krb-1.1-r1.ebuild10
-rw-r--r--app-crypt/kth-krb/kth-krb-1.1.1.ebuild10
-rw-r--r--app-crypt/kth-krb/kth-krb-1.2.1.ebuild10
-rw-r--r--app-crypt/kth-krb/kth-krb-1.2.ebuild10
-rw-r--r--app-crypt/pam_krb5/pam_krb5-1.0.ebuild11
-rw-r--r--app-crypt/ssh-multiadd/ssh-multiadd-1.3.1.ebuild11
12 files changed, 68 insertions, 75 deletions
diff --git a/app-crypt/heimdal/heimdal-0.5.1.ebuild b/app-crypt/heimdal/heimdal-0.5.1.ebuild
index a103b4467290..b5e3f0d8ef74 100644
--- a/app-crypt/heimdal/heimdal-0.5.1.ebuild
+++ b/app-crypt/heimdal/heimdal-0.5.1.ebuild
@@ -1,16 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.5.1.ebuild,v 1.1 2002/10/26 15:24:01 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.5.1.ebuild,v 1.2 2002/11/30 20:29:48 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Kerberos 5 implementation from KTH"
SRC_URI="ftp://ftp.pdc.kth.se/pub/${PN}/src/${P}.tar.gz"
HOMEPAGE="http://www.pdc.kth.se/heimdal/"
-IUSE="ssl ldap berkdb ipv6"
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 sparc sparc64"
+IUSE="ssl ldap berkdb ipv6"
DEPEND=">=app-crypt/kth-krb-1.2.1
ssl? ( dev-libs/openssl )
@@ -23,7 +22,6 @@ src_unpack() {
cd ${S}/lib/krb5
mv Makefile.in Makefile.in.bak
sed "s:LIB_crypt = @LIB_crypt@:LIB_crypt = -lssl @LIB_crypt@:g" Makefile.in.bak >Makefile.in
-
}
src_compile() {
@@ -37,8 +35,6 @@ src_compile() {
use berkdb || myconf="${myconf} --without-berkely-db"
-echo $myconf
-
./configure --host=${CHOST} \
--prefix=/usr/heimdal \
--sysconfdir=/etc \
@@ -48,7 +44,7 @@ echo $myconf
make || die
}
-src_install () {
+src_install() {
make prefix=${D}/usr/heimdal \
sysconfdir=${D}/etc \
install || die
diff --git a/app-crypt/heimdal/heimdal-0.5.ebuild b/app-crypt/heimdal/heimdal-0.5.ebuild
index b9650eaac556..9bf207de981a 100644
--- a/app-crypt/heimdal/heimdal-0.5.ebuild
+++ b/app-crypt/heimdal/heimdal-0.5.ebuild
@@ -1,16 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.5.ebuild,v 1.3 2002/10/17 13:23:59 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.5.ebuild,v 1.4 2002/11/30 20:25:51 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Kerberos 5 implementation from KTH"
SRC_URI="ftp://ftp.pdc.kth.se/pub/${PN}/src/${P}.tar.gz"
HOMEPAGE="http://www.pdc.kth.se/heimdal/"
-IUSE="ssl ldap berkdb ipv6"
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86"
+IUSE="ssl ldap berkdb ipv6"
DEPEND=">=app-crypt/kth-krb-1.1-r1
ssl? ( dev-libs/openssl )
@@ -23,7 +22,6 @@ src_unpack() {
cd ${S}/lib/krb5
mv Makefile.in Makefile.in.bak
sed "s:LIB_crypt = @LIB_crypt@:LIB_crypt = -lssl @LIB_crypt@:g" Makefile.in.bak >Makefile.in
-
}
src_compile() {
@@ -37,18 +35,16 @@ src_compile() {
use berkdb || myconf="${myconf} --without-berkely-db"
-echo $myconf
-
./configure --host=${CHOST} \
--prefix=/usr/heimdal \
--sysconfdir=/etc \
--with-krb4=/usr/athena \
- ${myconf} || die
+ ${myconf}
make || die
}
-src_install () {
+src_install() {
make prefix=${D}/usr/heimdal \
sysconfdir=${D}/etc \
install || die
diff --git a/app-crypt/johntheripper/johntheripper-1.6.ebuild b/app-crypt/johntheripper/johntheripper-1.6.ebuild
index e7a5db91b1ca..25d785ded1d4 100644
--- a/app-crypt/johntheripper/johntheripper-1.6.ebuild
+++ b/app-crypt/johntheripper/johntheripper-1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/johntheripper-1.6.ebuild,v 1.4 2002/10/17 13:23:59 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/johntheripper-1.6.ebuild,v 1.5 2002/11/30 20:32:53 vapier Exp $
PN0="john"
S=${WORKDIR}/${PN0}-${PV}
@@ -8,11 +8,12 @@ DEBPATCH=${PN0}_${PV}-17.diff.gz
DESCRIPTION="John the Ripper is a fast password cracker."
HOMEPAGE="http://www.openwall.com/${PN0}/"
SRC_URI="${HOMEPAGE}/${PN0}-${PV}.tar.gz
- http://ftp.debian.org/debian/pool/main/j/${PN0}/${DEBPATCH}"
-IUSE="mmx"
+ http://ftp.debian.org/debian/pool/main/j/${PN0}/${DEBPATCH}"
+
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc sparc64"
+IUSE="mmx"
DEPEND=">=sys-devel/binutils-2.8.1.0.15"
@@ -26,15 +27,14 @@ src_compile() {
mv Makefile Makefile.orig
sed -e "s/-m486//" -e "s/-Wall -O2/${CFLAGS}/" \
Makefile.orig > Makefile
- if [ -z "`use mmx`" ]
- then
- emake generic
+ if [ `use mmx` ] ; then
+ emake linux-x86-mmx-elf || die
else
- emake linux-x86-mmx-elf
+ emake generic || die
fi
}
-src_install () {
+src_install() {
dodir /usr/share/${PN0} /etc
insinto /etc
doins run/john.ini debian/john-mail.msg debian/john-mail.conf
diff --git a/app-crypt/krb5/krb5-1.2.5-r1.ebuild b/app-crypt/krb5/krb5-1.2.5-r1.ebuild
index 16a0c20e2bab..91a549b510f7 100644
--- a/app-crypt/krb5/krb5-1.2.5-r1.ebuild
+++ b/app-crypt/krb5/krb5-1.2.5-r1.ebuild
@@ -1,35 +1,37 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.5-r1.ebuild,v 1.5 2002/10/04 03:57:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.5-r1.ebuild,v 1.6 2002/11/30 20:33:36 vapier Exp $
-S=${WORKDIR}/${P}/src
SRC_URI="http://www.crypto-publish.org/dist/mit-kerberos5/${P}.tar.gz"
DESCRIPTION="MIT Kerberos V (set up for pam)"
-HOMEPAGE="http://crypto-publish.org"
+HOMEPAGE="http://crypto-publish.org/"
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 sparc sparc64"
-DEPEND="virtual/glibc"
+S=${WORKDIR}/${P}/src
src_compile() {
-
patch -p0 < ${FILESDIR}/${PN}-1.2.2-gentoo.diff || die
econf \
--with-krb4 \
--enable-shared \
- --enable-dns || die
+ --enable-dns
+
mv Makefile Makefile.orig
#Don't install the ftp, telnet, r* apps; use pam instead
sed -e 's/ appl / /' Makefile.orig > Makefile
make || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
cd ..
dodoc README
- echo 'NOTE: ftp, telnet, r* apps not installed. Install pam-krb5!'
+}
+
+pkg_postinst() {
+ ewarn 'NOTE: ftp, telnet, r* apps not installed. Install pam-krb5!'
}
diff --git a/app-crypt/krb5/krb5-1.2.5-r2.ebuild b/app-crypt/krb5/krb5-1.2.5-r2.ebuild
index 7f02d223731e..b329c65932a0 100644
--- a/app-crypt/krb5/krb5-1.2.5-r2.ebuild
+++ b/app-crypt/krb5/krb5-1.2.5-r2.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.5-r2.ebuild,v 1.3 2002/08/16 02:36:53 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.5-r2.ebuild,v 1.4 2002/11/30 20:34:23 vapier Exp $
-S=${WORKDIR}/${P}/src
SRC_URI="http://www.crypto-publish.org/dist/mit-kerberos5/${P}.tar.gz"
DESCRIPTION="MIT Kerberos V (set up for pam)"
HOMEPAGE="http://web.mit.edu/kerberos/www/"
@@ -11,10 +10,9 @@ SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 sparc sparc64"
-DEPEND="virtual/glibc"
+S=${WORKDIR}/${P}/src
src_compile() {
-
patch -p0 < ${FILESDIR}/${PN}-1.2.2-gentoo.diff || die
cd ${S}/lib/rpc
@@ -24,16 +22,20 @@ src_compile() {
econf \
--with-krb4 \
--enable-shared \
- --enable-dns || die
+ --enable-dns
+
mv Makefile Makefile.orig
#Don't install the ftp, telnet, r* apps; use pam instead
sed -e 's/ appl / /' Makefile.orig > Makefile
make || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
cd ..
dodoc README
- echo 'NOTE: ftp, telnet, r* apps not installed. Install pam-krb5!'
+}
+
+pkg_postinst() {
+ ewarn 'NOTE: ftp, telnet, r* apps not installed. Install pam-krb5!'
}
diff --git a/app-crypt/krb5/krb5-1.2.6.ebuild b/app-crypt/krb5/krb5-1.2.6.ebuild
index 45e35ed3c3d2..6bca36a7783c 100644
--- a/app-crypt/krb5/krb5-1.2.6.ebuild
+++ b/app-crypt/krb5/krb5-1.2.6.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.6.ebuild,v 1.1 2002/10/28 14:01:18 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.6.ebuild,v 1.2 2002/11/30 20:35:04 vapier Exp $
-S=${WORKDIR}/${P}/src
SRC_URI="http://www.crypto-publish.org/dist/mit-kerberos5/${P}.tar.gz"
DESCRIPTION="MIT Kerberos V (set up for pam)"
HOMEPAGE="http://web.mit.edu/kerberos/www/"
@@ -12,7 +11,7 @@ SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 sparc sparc64"
-DEPEND="virtual/glibc"
+S=${WORKDIR}/${P}/src
src_unpack() {
unpack ${A}
@@ -28,14 +27,14 @@ src_compile() {
econf \
--with-krb4 \
--enable-shared \
- --enable-dns || die
+ --enable-dns
mv Makefile Makefile.orig
#Don't install the ftp, telnet, r* apps; use pam instead
sed -e 's/ appl / /' Makefile.orig > Makefile
make || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
cd ..
dodoc README
diff --git a/app-crypt/kth-krb/kth-krb-1.1-r1.ebuild b/app-crypt/kth-krb/kth-krb-1.1-r1.ebuild
index 436f32cfaa67..25350ed3237b 100644
--- a/app-crypt/kth-krb/kth-krb-1.1-r1.ebuild
+++ b/app-crypt/kth-krb/kth-krb-1.1-r1.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.1-r1.ebuild,v 1.7 2002/10/05 05:39:05 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.1-r1.ebuild,v 1.8 2002/11/30 20:35:44 vapier Exp $
-IUSE="ssl afs"
-
-S=${WORKDIR}/krb4-${PV}
DESCRIPTION="Kerberos 4 implementation from KTH"
SRC_URI="ftp://ftp.pdc.kth.se/pub/krb/src/krb4-${PV}.tar.gz"
HOMEPAGE="http://www.pdc.kth.se/kth-krb/"
@@ -12,10 +9,13 @@ HOMEPAGE="http://www.pdc.kth.se/kth-krb/"
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 sparc sparc64"
+IUSE="ssl afs"
DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
afs? ( >=net-fs/openafs-1.2.2-r7 )"
+S=${WORKDIR}/krb4-${PV}
+
src_compile() {
local myconf=""
@@ -32,7 +32,7 @@ src_compile() {
make || die
}
-src_install () {
+src_install() {
make prefix=${D}/usr/athena \
sysconfdir=${D}/etc \
install || die
diff --git a/app-crypt/kth-krb/kth-krb-1.1.1.ebuild b/app-crypt/kth-krb/kth-krb-1.1.1.ebuild
index b3c5ad6cd587..6c7d626c9314 100644
--- a/app-crypt/kth-krb/kth-krb-1.1.1.ebuild
+++ b/app-crypt/kth-krb/kth-krb-1.1.1.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.1.1.ebuild,v 1.3 2002/10/05 05:39:05 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.1.1.ebuild,v 1.4 2002/11/30 20:36:18 vapier Exp $
-IUSE="ssl afs"
-
-S=${WORKDIR}/krb4-${PV}
DESCRIPTION="Kerberos 4 implementation from KTH"
SRC_URI="ftp://ftp.pdc.kth.se/pub/krb/src/krb4-${PV}.tar.gz"
HOMEPAGE="http://www.pdc.kth.se/kth-krb/"
@@ -12,10 +9,13 @@ HOMEPAGE="http://www.pdc.kth.se/kth-krb/"
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 sparc sparc64"
+IUSE="ssl afs"
DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
afs? ( >=net-fs/openafs-1.2.2-r7 )"
+S=${WORKDIR}/krb4-${PV}
+
src_compile() {
local myconf=""
@@ -32,7 +32,7 @@ src_compile() {
make || die
}
-src_install () {
+src_install() {
make prefix=${D}/usr/athena \
sysconfdir=${D}/etc \
install || die
diff --git a/app-crypt/kth-krb/kth-krb-1.2.1.ebuild b/app-crypt/kth-krb/kth-krb-1.2.1.ebuild
index 47e73c92a8dd..ad26f4657f31 100644
--- a/app-crypt/kth-krb/kth-krb-1.2.1.ebuild
+++ b/app-crypt/kth-krb/kth-krb-1.2.1.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.2.1.ebuild,v 1.1 2002/10/26 15:24:01 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.2.1.ebuild,v 1.2 2002/11/30 20:37:38 vapier Exp $
-IUSE="ssl afs"
-
-S=${WORKDIR}/krb4-${PV}
DESCRIPTION="Kerberos 4 implementation from KTH"
SRC_URI="ftp://ftp.pdc.kth.se/pub/krb/src/krb4-${PV}.tar.gz"
HOMEPAGE="http://www.pdc.kth.se/kth-krb/"
@@ -12,10 +9,13 @@ HOMEPAGE="http://www.pdc.kth.se/kth-krb/"
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 sparc sparc64"
+IUSE="ssl afs"
DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
afs? ( >=net-fs/openafs-1.2.2-r7 )"
+S=${WORKDIR}/krb4-${PV}
+
src_compile() {
local myconf=""
@@ -32,7 +32,7 @@ src_compile() {
make || die
}
-src_install () {
+src_install() {
make prefix=${D}/usr/athena \
sysconfdir=${D}/etc \
install || die
diff --git a/app-crypt/kth-krb/kth-krb-1.2.ebuild b/app-crypt/kth-krb/kth-krb-1.2.ebuild
index a2b7481723f9..18841b98d5ec 100644
--- a/app-crypt/kth-krb/kth-krb-1.2.ebuild
+++ b/app-crypt/kth-krb/kth-krb-1.2.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.2.ebuild,v 1.1 2002/10/18 09:04:22 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.2.ebuild,v 1.2 2002/11/30 20:37:07 vapier Exp $
-IUSE="ssl afs"
-
-S=${WORKDIR}/krb4-${PV}
DESCRIPTION="Kerberos 4 implementation from KTH"
SRC_URI="ftp://ftp.pdc.kth.se/pub/krb/src/krb4-${PV}.tar.gz"
HOMEPAGE="http://www.pdc.kth.se/kth-krb/"
@@ -12,10 +9,13 @@ HOMEPAGE="http://www.pdc.kth.se/kth-krb/"
SLOT="0"
LICENSE="as-is"
KEYWORDS="~x86 ~sparc ~sparc64"
+IUSE="ssl afs"
DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
afs? ( >=net-fs/openafs-1.2.2-r7 )"
+S=${WORKDIR}/krb4-${PV}
+
src_compile() {
local myconf=""
@@ -32,7 +32,7 @@ src_compile() {
make || die
}
-src_install () {
+src_install() {
make prefix=${D}/usr/athena \
sysconfdir=${D}/etc \
install || die
diff --git a/app-crypt/pam_krb5/pam_krb5-1.0.ebuild b/app-crypt/pam_krb5/pam_krb5-1.0.ebuild
index 250e6856cef0..89dddaf71b02 100644
--- a/app-crypt/pam_krb5/pam_krb5-1.0.ebuild
+++ b/app-crypt/pam_krb5/pam_krb5-1.0.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pam_krb5/pam_krb5-1.0.ebuild,v 1.9 2002/10/04 03:58:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pam_krb5/pam_krb5-1.0.ebuild,v 1.10 2002/11/30 20:38:42 vapier Exp $
-S=${WORKDIR}/${PN}
DESCRIPTION="Pam module for MIT Kerberos V"
SRC_URI="http://www.fcusack.com/soft/${P}.tar.gz"
-HOMEPAGE="http://www.fcusack.com"
+HOMEPAGE="http://www.fcusack.com/"
SLOT="0"
LICENSE="BSD GPL-2 as-is"
@@ -14,16 +13,18 @@ KEYWORDS="x86 sparc sparc64"
DEPEND="app-crypt/krb5
sys-libs/pam"
+S=${WORKDIR}/${PN}
+
src_compile() {
patch -p0 < ${FILESDIR}/${P}-gentoo.diff || die
make CFLAGS="$CFLAGS" || die
}
-src_install () {
+src_install() {
exeinto /lib/security
doexe pam_krb5.so.1
dosym /lib/security/pam_krb5.so.1 /lib/security/pam_krb5.so
-
+
doman pam_krb5.5
dodoc COPYRIGHT README TODO
}
diff --git a/app-crypt/ssh-multiadd/ssh-multiadd-1.3.1.ebuild b/app-crypt/ssh-multiadd/ssh-multiadd-1.3.1.ebuild
index 60070a4e92e7..33cc03b5c587 100644
--- a/app-crypt/ssh-multiadd/ssh-multiadd-1.3.1.ebuild
+++ b/app-crypt/ssh-multiadd/ssh-multiadd-1.3.1.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/ssh-multiadd/ssh-multiadd-1.3.1.ebuild,v 1.12 2002/10/05 05:39:05 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ssh-multiadd/ssh-multiadd-1.3.1.ebuild,v 1.13 2002/11/30 20:39:29 vapier Exp $
-IUSE="X"
-
-S=${WORKDIR}/${P}
DESCRIPTION="adds multiple ssh keys to the ssh authentication agent. These may use the same passphrase. Unlike ssh-add, if any of the keys use the same passphrase, you will only need to enter each unique passphrase once, and keys that are already added will not be prompted for again."
SRC_URI="http://www.azstarnet.com/~donut/programs/ssh-multiadd/${P}.tar.gz"
HOMEPAGE="http://www.azstarnet.com/~donut/programs/index_s.html#ssh-multiadd"
@@ -12,6 +9,7 @@ HOMEPAGE="http://www.azstarnet.com/~donut/programs/index_s.html#ssh-multiadd"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc sparc64"
+IUSE="X"
DEPEND=">=dev-lang/python-2.0-r3
X? ( >=net-misc/x11-ssh-askpass-1.2.2 )"
@@ -20,12 +18,11 @@ DEPEND=">=dev-lang/python-2.0-r3
#so I added the X? ( ) -- drobbins
src_unpack() {
- unpack ${A}
- cd ${S}
+ unpack ${A} ; cd ${S}
patch -p0 < ${FILESDIR}/ssh-multiadd-1.3.1.diff
}
-src_install () {
+src_install() {
dobin ssh-multiadd
doman ssh-multiadd.1
dodoc COPYING ChangeLog README todo