summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-17 18:13:35 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-17 18:13:35 +0000
commit23ea1ae089181ab0e45bef6dddeedf7b80577c2b (patch)
treee28fbfba8eeaa0f46f53c185cb9c55a469bea80f /dev-ruby
parentFix lxde wrapper (diff)
downloadhistorical-23ea1ae089181ab0e45bef6dddeedf7b80577c2b.tar.gz
historical-23ea1ae089181ab0e45bef6dddeedf7b80577c2b.tar.bz2
historical-23ea1ae089181ab0e45bef6dddeedf7b80577c2b.zip
Version bump.
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/fast_gettext/ChangeLog7
-rw-r--r--dev-ruby/fast_gettext/fast_gettext-0.5.12.ebuild31
-rw-r--r--dev-ruby/i18n/ChangeLog7
-rw-r--r--dev-ruby/i18n/i18n-0.6.0.ebuild75
-rw-r--r--dev-ruby/jquery-rails/ChangeLog7
-rw-r--r--dev-ruby/jquery-rails/jquery-rails-1.0.11.ebuild26
-rw-r--r--dev-ruby/loquacious/ChangeLog7
-rw-r--r--dev-ruby/loquacious/loquacious-1.8.1.ebuild38
8 files changed, 194 insertions, 4 deletions
diff --git a/dev-ruby/fast_gettext/ChangeLog b/dev-ruby/fast_gettext/ChangeLog
index afc4ea2dfc49..7b2c2ffad0a3 100644
--- a/dev-ruby/fast_gettext/ChangeLog
+++ b/dev-ruby/fast_gettext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/fast_gettext
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/ChangeLog,v 1.1 2011/05/09 06:30:52 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/ChangeLog,v 1.2 2011/06/17 18:05:57 graaff Exp $
+
+*fast_gettext-0.5.12 (17 Jun 2011)
+
+ 17 Jun 2011; Hans de Graaff <graaff@gentoo.org> +fast_gettext-0.5.12.ebuild:
+ Version bump.
*fast_gettext-0.5.11 (09 May 2011)
diff --git a/dev-ruby/fast_gettext/fast_gettext-0.5.12.ebuild b/dev-ruby/fast_gettext/fast_gettext-0.5.12.ebuild
new file mode 100644
index 000000000000..2cff7c23c860
--- /dev/null
+++ b/dev-ruby/fast_gettext/fast_gettext-0.5.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/fast_gettext-0.5.12.ebuild,v 1.1 2011/06/17 18:05:57 graaff Exp $
+
+EAPI="4"
+
+# jruby support requires sqlite3 support for jruby.
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG Readme.md"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+
+inherit ruby-fakegem
+
+DESCRIPTION="GetText but 3.5 x faster, 560 x less memory, simple, clean namespace (7 vs 34) and threadsave!"
+HOMEPAGE="https://github.com/grosser/fast_gettext"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/activerecord )"
+
+all_ruby_prepare() {
+ rm Gemfile Gemfile.lock || die
+}
diff --git a/dev-ruby/i18n/ChangeLog b/dev-ruby/i18n/ChangeLog
index 8f05e914f8ce..6cf30e06c4e3 100644
--- a/dev-ruby/i18n/ChangeLog
+++ b/dev-ruby/i18n/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/i18n
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.32 2011/02/26 18:34:53 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.33 2011/06/17 18:10:28 graaff Exp $
+
+*i18n-0.6.0 (17 Jun 2011)
+
+ 17 Jun 2011; Hans de Graaff <graaff@gentoo.org> +i18n-0.6.0.ebuild:
+ Version bump.
26 Feb 2011; Raúl Porcel <armin76@gentoo.org> i18n-0.5.0-r1.ebuild:
Add ~ia64/~sparc/~x86 wrt #355697
diff --git a/dev-ruby/i18n/i18n-0.6.0.ebuild b/dev-ruby/i18n/i18n-0.6.0.ebuild
new file mode 100644
index 000000000000..4f7748c7cf31
--- /dev/null
+++ b/dev-ruby/i18n/i18n-0.6.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.6.0.ebuild,v 1.1 2011/06/17 18:10:28 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 jruby ree18"
+
+# doc regeneration seem to need Jeweler, which is not currently
+# available
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.textile CHANGELOG.textile"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Add Internationalization support to your Ruby application."
+HOMEPAGE="http://rails-i18n.org/"
+
+SRC_URI="http://github.com/svenfuchs/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/svenfuchs-${PN}-*"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~hppa ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+# The testsuite uses the activerecord gem to run some tests; they
+# require sqlite3-ruby, and that is not available on JRuby.
+#USE_RUBY="${USE_RUBY/jruby/}" \
+# ruby_add_bdepend "
+# test? (
+# dev-ruby/activerecord
+# dev-ruby/sqlite3-ruby
+# dev-ruby/ruby2ruby
+# )"
+
+# mocha is optionally used by the testsuite, try to increase coverage
+# of testing by depending on it; when mocha is used, though,
+# test-unit:2 cannot be merged at the same time (mocha problem?)
+#
+# One further test dependency would be ruby-cldr
+# (http://rubygems.org/gems/ruby-cldr) but we don't have it in tree
+# yet.
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha
+ dev-ruby/test_declarative
+ )"
+
+src_compile() {
+ # permissions need to be stricter for Ruby-Inline to work properly.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_compile
+}
+
+src_test() {
+ # permissions need to be stricter for Ruby-Inline to work properly.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_test
+}
+
+each_ruby_test() {
+ # Make sure the optional activerecord tests are not run for jruby
+ # because we don't ship a compatible sqlite3
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ each_fakegem_test
+ esac
+}
diff --git a/dev-ruby/jquery-rails/ChangeLog b/dev-ruby/jquery-rails/ChangeLog
index 67a2f5701483..b4f963aa4522 100644
--- a/dev-ruby/jquery-rails/ChangeLog
+++ b/dev-ruby/jquery-rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/jquery-rails
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/jquery-rails/ChangeLog,v 1.1 2011/05/29 09:59:24 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/jquery-rails/ChangeLog,v 1.2 2011/06/17 18:11:52 graaff Exp $
+
+*jquery-rails-1.0.11 (17 Jun 2011)
+
+ 17 Jun 2011; Hans de Graaff <graaff@gentoo.org> +jquery-rails-1.0.11.ebuild:
+ Version bump.
*jquery-rails-1.0.9 (29 May 2011)
diff --git a/dev-ruby/jquery-rails/jquery-rails-1.0.11.ebuild b/dev-ruby/jquery-rails/jquery-rails-1.0.11.ebuild
new file mode 100644
index 000000000000..5ecb285a20fd
--- /dev/null
+++ b/dev-ruby/jquery-rails/jquery-rails-1.0.11.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/jquery-rails/jquery-rails-1.0.11.ebuild,v 1.1 2011/06/17 18:11:52 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="vendor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="jQuery! For Rails! So great."
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/railties:3.0 >=dev-ruby/thor-0.14"
diff --git a/dev-ruby/loquacious/ChangeLog b/dev-ruby/loquacious/ChangeLog
index 40e04c930d91..f828357e1246 100644
--- a/dev-ruby/loquacious/ChangeLog
+++ b/dev-ruby/loquacious/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/loquacious
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/loquacious/ChangeLog,v 1.11 2011/06/04 06:43:52 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/loquacious/ChangeLog,v 1.12 2011/06/17 18:13:35 graaff Exp $
+
+*loquacious-1.8.1 (17 Jun 2011)
+
+ 17 Jun 2011; Hans de Graaff <graaff@gentoo.org> +loquacious-1.8.1.ebuild:
+ Version bump.
*loquacious-1.8.0 (04 Jun 2011)
diff --git a/dev-ruby/loquacious/loquacious-1.8.1.ebuild b/dev-ruby/loquacious/loquacious-1.8.1.ebuild
new file mode 100644
index 000000000000..c638453d863f
--- /dev/null
+++ b/dev-ruby/loquacious/loquacious-1.8.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/loquacious/loquacious-1.8.1.ebuild,v 1.1 2011/06/17 18:13:35 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 jruby ree18"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Descriptive configuration files for Ruby written in Ruby"
+HOMEPAGE="http://github.com/TwP/${PN}"
+
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.6.0:2 )"
+
+all_ruby_compile() {
+ rdoc lib || die "Documentation generation failed."
+}
+
+each_ruby_test() {
+ ${RUBY} -S rspec spec || die "Tests failed."
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}