summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-10 13:52:58 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-10 13:52:58 +0200
commit330a02c0b45b201bb40ac8f6cbed9889aaecd648 (patch)
treeb5e33b93735d03295580f718a5af2a10268e2047 /dev-python/magic-wormhole
parentdev-python/magic-wormhole: Take for python@ (diff)
downloadgentoo-330a02c0b45b201bb40ac8f6cbed9889aaecd648.tar.gz
gentoo-330a02c0b45b201bb40ac8f6cbed9889aaecd648.tar.bz2
gentoo-330a02c0b45b201bb40ac8f6cbed9889aaecd648.zip
dev-python/magic-wormhole: Unbundle dev-python/versioneer
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/magic-wormhole')
-rw-r--r--dev-python/magic-wormhole/magic-wormhole-0.15.0.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/magic-wormhole/magic-wormhole-0.15.0.ebuild b/dev-python/magic-wormhole/magic-wormhole-0.15.0.ebuild
index e6ae25346922..30073baf9323 100644
--- a/dev-python/magic-wormhole/magic-wormhole-0.15.0.ebuild
+++ b/dev-python/magic-wormhole/magic-wormhole-0.15.0.ebuild
@@ -39,6 +39,7 @@ RDEPEND="
"
BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
test? (
dev-python/magic-wormhole-mailbox-server[${PYTHON_USEDEP}]
~dev-python/magic-wormhole-transit-relay-0.2.1[${PYTHON_USEDEP}]
@@ -47,6 +48,11 @@ BDEPEND="
distutils_enable_tests pytest
+src_prepare() {
+ distutils-r1_src_prepare
+ rm versioneer.py || die
+}
+
python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest